HTML Editor Help
August 2009

Got questions about the features in HTML Editor? Want to check out some helpful tutorials to get you up to speed on using the program? You’ve come to the right place!

Program Overview
Learn about the tools and features available within the program.

Tutorials
Step-by-step instructions for the most commonly used features of the program.

Frequently Asked Questions
Got a question about the software? Find your answer here.

CoffeeCup Information
Learn more about CoffeeCup and review all the legal gobbledygook.

Still Can’t Find Your Answer?
Visit our user forums (http://www.coffeecup.com/forums/), check out the articles and video tutorials in our online Knowledgebase (http://www.coffeecup.com/html-editor/help/) or contact our fabulous tech support team (http://www.coffeecup.com/help/)!
Program Overview

Learn about the tools and features available within the program.

• What is the HTML Editor?
• How to use this manual
• What’s new
• System requirements
• Installing the software
• Opening the program
• Menu bar
• Toolbar
• Code Editor
• Visual Editor
• Preview tab
• Statusbar
• Resource browser
  ▪ My Websites tab
  ▪ My Computer tab
  ▪ Code Snippets tab
  ▪ Tags tab
  ▪ Characters tab
Tutorials

Step-by-step instructions for the most commonly used features of the program.

Creating and Modifying Your Pages

- Working with Website Projects
- Creating a new Webpage
- Adding an image to your page
- How to change the appearance of text
- Working with links
  - Absolute vs. relative links
  - Adding a link to your page
  - Adding an e-mail link to your page
  - Linking to a downloadable document
  - Linking to different parts of the same page
- How to create a list
- How to use snippets
- How to add a Flash™ element created with a CoffeeCup Flash™ program
- How to use the Frame designer
- How to use the CSS Menu Designer
- How to use the Open From Web function
- How to use bookmarks
- How to use the Code Cleaner
- How to use Extended Find and Replace
- Previewing your work

Customizing the Program

- Switching between open files
- Adjusting code highlighting options
- How to create a custom toolbar
- Customizing code completion tags
Frequently Asked Questions

Got a question about the software? Find your answer here.

- Frequently asked questions
  - Features, tools, and functionality
  - Customization
  - Error messages and troubleshooting
  - Miscellaneous
- Keyboard shortcuts
- Glossary
CoffeeCup Information

Learn more about CoffeeCup Software and review all the legal gobbledygook.

- About CoffeeCup Software
- Contact us
- Thank you
- End User License Agreement
- Notice of copyright
- Software privacy policy
What is the HTML Editor?

The HTML Editor is a full-featured Web design tool for beginners and experts alike. A host of useful features help you create and modify Webpages quickly and efficiently, reveal the ins and outs of HTML, and give you complete control over the design and structure of your Website.

Since a Website is far more than just the files that make it up, the HTML Editor also contains Website Projects, a comprehensive system that keeps your work organized. It may sound hard to believe, but you’ll never have to worry about an incorrectly referenced links or images again! And with improved validation, you can rest assured that your Website will always perform reliably.

Sweet add-ons like a built-in CSS menu designer, color scheme generator, and image mapping tool — not to mention the ability to open external applications from within the program — put all the essential Web design tools in one place. And since no Website is complete until it’s published to the Web, we included a built-in FTP client and server access, allowing you to upload work easily and edit documents directly on your server.
How to Use This Manual

Welcome to the CoffeeCup HTML Editor PDF Help manual! This is the place to go to learn the ins and outs of this program.

You can navigate through this manual using the table of contents on the left or by just reading it straight through. If you’re wondering about a certain term, you can search for it in the box up top. There’s also a glossary that covers commonly used (and commonly misunderstood) terms.

You may have noticed that glossary is bold and red in the previous paragraph. That’s because it’s a link that, when clicked, takes you to the Glossary. This manual contains tons of links formatted in **bold red text** and

- bulleted
- lists
- like
- this
- one.

You’ll also see links to Webpages containing additional information formatted like this: [http://www.coffeecup.com](http://www.coffeecup.com). Just click them, and your default Web browser will open the page.

We’ve included some handy icons to help highlight important information.

- **For More Information**
  Links you to a tutorial or frequently asked question that explains the tool or function in more detail.

- **Online Resource**
  Links you to a Website containing information that may be beyond the scope of this manual.

- **Use This Tool With...**
  Links to another tool or function that can be used with the tool or function being described.

- **Watch Out!**
  Look for this icon to see common user errors that may occur when using the tool or function.
You’ll also notice that the manual is divided into different sections. The Program Overview portion explains what all the different menus, buttons, and commands do. If you have a question about what a button or menu option does, you’ll find your answer here.

If you want to learn how to perform a task in the program, check out the Tutorials section. It walks you through common tasks using simple, step-by-step instructions.

Have a question? Visit the FAQ. We’ve kept track of the questions we hear most often from our users and gathered them together in this section.

We hope this helps! If you have any questions, comments, or suggestions about how this manual can be improved, we’d love to hear them. Shoot us an e-mail at wordnerd@coffeecup.com.

Any technical support requests should still go to http://www.coffeecup.com/help/myroom/.
What’s New

2009

- Renamed Projects to Website Projects and improved the feature
- Updated markup
- Added Validate HTML tool, which opens the W3C markup validation service in the default browser (http://validator.w3.org/)
- Added Server tab to the Resource browser
- Open From Web tool can now download and open CSS files
- Added Theme Chooser window
- Updated user interface
- Additional preferences for customizing the workspace
- Updated Help manual
- Improved Find and Replace performance
- Additional options in Quick Start window, including DOCTYPE and character sets
- Replaced DHTML Menu Builder with CSS Menu Designer
- Added Welcome window that provides options to help users get started quickly

System Requirements
To run the software efficiently, your computer system should meet the following requirements:

- Operating System – XP, Vista 32-bit
- Disk Space – 30 MB
- RAM – 120 MB

Installing the Software
If you are installing the registered version of the software, it is highly recommended that you uninstall the trial version before installing the registered version, and then restart your computer. If you have created any projects with the trial version, it is recommended that you back them up to prevent loss.

If you haven’t already downloaded your software, you can log into your CoffeeCup user account (http://www.coffeecup.com/login/) using the e-mail address and password you used when purchasing the software. Once you have downloaded the software, double-click the .exe file to start the setup process. As you proceed through the setup, you can let the program install with the default settings, or you can choose where you would like it installed. We recommend you stick with the default settings.
Installing CoffeeCup Software on Mac OSX

CoffeeCup Software is designed for installation under Windows only. However, you can install and use the software on Mac OSX with the correct utilities. CrossOver (http://www.codeweavers.com/), developed by CodeWeavers, and VMware (http://www.vmware.com), developed by VMware, Inc., both allow you to emulate our software on Mac OSX.

Upgrading the Software

When upgrading your software, you will need to log into your CoffeeCup user account (http://www.coffeecup.com/login/) just as you did to download the registered version of the software. When you download the upgrade, it will be a new full version and not just an upgrade to the existing software on your system. To install an upgrade, we recommend that you uninstall the previous version of the software and restart your computer. This is because installing over a previously installed version can cause some functions to not work correctly. Therefore, it is best to install a fresh copy.

Uninstalling the Software

To uninstall the program, you will need to use the Add/Remove Programs feature under your control panel settings in Windows. You can access this by clicking Start > Settings > Control Panel > Add or Remove Programs.

The uninstall feature may not remove all files from your system. You may need to remove some files and folders manually. Also, if you have previously created projects, make sure to back them up to prevent loss.
Opening the Program

When you first open the HTML Editor, two windows appear: the Tip of the Day window and the Welcome window.

**Tip of the Day Window**
Displays helpful tips for working with the program.

To navigate the tips, use the Previous and Next buttons. If you do not want to see these tips on startup, uncheck the checkbox next to **Show tip of the day on startup**.

🔗 To re-enable the Tip of the Day window, go to Help > Tip of the Day or use the options under Tools > Preferences > General tab.

**Welcome Window**
Contains links to commonly used program functions.
New Blank Page
Opens the Quick Start window, which allows you to define settings for your new page, including the page title, color scheme, meta information, and character set.

New Website Project
Opens the Website Project Settings window, which lets you create a blank Website Project or to create a Website Project from existing files. You can also enter additional information, such as your server settings, and select your file upload options.

Start With a Theme
Opens a window that allows you to choose from several Webpage themes.
A theme includes three pages (index.html, about-us.html, and contact-us.html) that include the HTML and images for a basic design. You can replace the images and text with your own content. If you prefer to work with a page structure, go to **File > New From Layout**. For more information about the difference between layouts and themes, read *What is the difference between a layout and a theme?*

For detailed tutorials covering each of these options for creating a new page, read *Creating a New Webpage*.

**Open Existing Files**
Allows you to open and work with a previously created file.

**Open a Website Project**
Allows you to open and work with a previously created Website Project.

**What’s a Website Project Anyway?**
Opens the *What is a Website Project?* Website Project, which gives step-by-step instructions for how to work with Website Projects.
Menu Bar

The Menu bar is located at the top of the program. It gives you access to all the program tools, as well as options like changing how the program looks, opening and closing pages, etc.

The options under each category change depending whether you are using the Code or Visual editor. In this manual, we have described the view from the Code Editor, because it contains all the available options.

- File menu
- Edit menu
- View menu
- My Websites menu
- Document menu
- Insert menu
- Format menu
- Tools menu
- Window menu
- Help menu
File Menu

The File menu contains options that allow you to create, open, close, and save pages, upload and print your work, and exit the program.

For detailed tutorials covering the four different ways to create a new Webpage, read Creating a New Webpage.

New From Quick Start...
Opens the Quick Start window, which allows you to define settings for your new page, including the page title, color scheme, meta information, and character set.

New Blank Page (Ctrl+N)
Creates a new page for you to edit from scratch. By default, new pages include some basic HTML to help get you started. This includes the DOCTYPE, html, head, title, meta, and body tags, as well as an HTML comment stating that the page was created with CoffeeCup HTML Editor.

New From Layout...
Opens a window that allows you to choose from several Webpage layouts.
A layout includes the HTML for a basic page structure. You provide the content. If you prefer to work with a page design, go to File > New From Theme. For more information about the difference between layouts and themes, read What is the difference between a layout and a theme?

New From Theme...
Opens a window that allows you to choose from several Webpage themes.
A theme includes three pages (index.html, about-us.html, and contact-us.html) that include the HTML and images for a basic design. You can replace the images and text with your own content. If you prefer to work with a page structure, go to File > New From Layout. For more information about the difference between layouts and themes, read What is the difference between a layout and a theme?

Open... (Ctrl+O)
Allows you to open and work with a previously created file.

Open From Web...
Opens the Open From Web window, which allows you to import an HTML page on the Internet into the HTML Editor. This option works best with HTML pages that do not contain PHP or SSI. These scripts are stored on the server, and sometimes add code to a Webpage that cannot be imported into the HTML Editor.

Recent Files
Displays a list of files you have worked with recently, which allows you to access them more quickly.

Close
Closes the current file you have open, but leaves the program open.

Close All
Closes all the open files, but leaves the program open.

Save (Ctrl+S)
Saves the file you are currently working on. We recommend you save frequently to prevent loss in case something happens to your computer while you are working.

Save As... (Shift+Ctrl+S)
Saves the current file under a different name. This will not overwrite the file you are currently working on; instead, it will create a new file that you can give a different name.

Save All
Saves all the open files.

Save Selected Text as Snippet...
Opens the Save Snippet window, which allows you to name and save the highlighted text as a snippet.
After you click OK, the new snippet will be added to the list in the **Code Snippets** tab. For a detailed tutorial about working with snippets, read **How to Use Snippets**.

**Upload File to Server**
Expands to display a list of options for uploading your work.

**Previously Configured Servers**
Select a previously configured server and then select the folder where you would like to upload your file. This opens the **Upload File to Server** window, which displays the status of the upload and closes automatically when the upload is complete.
Add or Edit Servers...
Opens the Server Configuration window, which allows you to configure a new or existing server profile.

Print (Ctrl+P)
Prints the current file in whatever view you have selected (Code Editor, Visual Editor, or Preview).

Print Preview...
Opens a window that allows you to preview the current file for printing in whatever view you have selected (Code Editor, Visual Editor, or Preview).
Page Setup...
Opens the Print Setup window, which allows you to adjust the printing settings for the current file.

Exit
Closes the program.
Quick Start Window

The Quick Start window allows you to define settings for your new page, including the page title, color scheme, DOCTYPE, character set, and meta information.

For a detailed tutorial about using the Quick Start window, read Creating a New Webpage.

You can preview the settings you choose in the Page Preview pane in the middle of the window.

**Page Title**
The text displayed on the browser’s title bar that also appears in search results. A good page title succinctly describes the content on the page.
**Background Image**
To select a background image for your page, enter the file path in this field or click the **Browse** icon to browse your computer for the image you wish to use. To remove a background image, click the **red X** icon.

**Colors**
There are five color options available: page background, text, and unvisited, visited, and active links. To change the color of any of these elements, click the associated color swatch. This opens a drop-down list of 40 basic colors.

To browse even more colors, click **More Colors**. This opens a rainbow gradient that allows you to adjust brightness and select from a wider range of colors.
Color Scheme Drop-Down List
If you would like to use a color scheme, select one from this drop-down list.

Save
Click this button if you made changes to a scheme that you would like to save.

Save As...
Click this button if you have created a color scheme you would like to use again. This opens a window that allows you to enter a name for your new scheme.

After you click OK, the scheme will be available under the drop-down list.

Delete
Click this button to delete the selected scheme.

Don’t Underline Links
Check this box if you want to remove the automatic underline from your links.

DOCTYPE
Select the desired DOCTYPE from this drop-down list.

Charset
Select your preferred character set from this drop-down list.

Meta Description
This is a short description of your Website. It should be no longer than 50 words.

Meta Keywords
These are words that describe your Webpage. They must each be separated by a comma and a space.

For more information about DOCTYPEs, character sets, and meta information, read New From Quick Start.
Open From Web Window

The Open From Web window allows you to import an HTML page from the Internet into the HTML Editor. To use this tool, enter the URL for the page you want to open in the **URL to Open From the Web** field at the top of the window, and then click **Open**. The **Download Status** area at the bottom of the window will tell you the status of your download.

For a detailed tutorial about how to use this function, read **How to Use the Open From Web function**.

The Open From Web function works best with HTML pages that do not contain PHP or SSI. These scripts are stored on the server, and sometimes add code to a page that cannot be imported into the HTML Editor. Additionally, this function cannot download all the pages in a given Website. To do this, you should use an external FTP client such as Direct FTP (http://www.coffeecup.com/direct-ftp/) or Free FTP (http://www.coffeecup.com/free-ftp/).
Options Tab
Choose where you would like to download the file and what parts of the page you would like to download.

![Options Tab](image)

Download Only the HTML Page (Without Images or Other Required Files) and Open it in the Editor
This option downloads the HTML from the page, but does not include the associated images or other files, like CSS or scripts. It opens the file in the Editor, but does not save it to your computer.

To save an HTML page you have downloaded using this option, go to File > Save.

Save to Disk
This option saves the page to a location you specify on your computer. To specify a location, click the Browse icon and choose the folder where you want the file saved. If you choose to save to disk, you can also use the provided checkboxes to:

- Have the page open in the Editor automatically
- Download images that appear in the page
- Download related files such as CSS and scripts
- Open related CSS files in the HTML Editor.

Proxy Settings Tab
Enter the proxy host name, login, password, port, and type in the provided fields, and then press OK.
If you are unsure of any of this information, contact your hosting provider. If you are not sure whether you should use this information, chances are you do not have to.
Server Configuration Window

The Server Configuration window allows you to configure a new or existing server profile.

Clicking the **Delete** button deletes the selected server profile. Clicking the **Add** or **Edit** button opens the **Server Configuration – Add and Edit** windows, respectively. These allow you to set up an FTP profile you can use to upload your work to your server.

For a detailed tutorial about uploading your work, read the **Uploading Your Website Project** portion of **Working With Website Projects**.
Server Configuration – Add/Edit Window

The Server Configuration – Add and Edit windows, allow you to set up an FTP profile you can use to upload your work to your server.

Put the following information in the provided fields.

⚠️ If you are unsure of any of this information, contact your hosting provider.

**Nickname**
A personal reminder you can use to tell your servers apart. You can name your servers anything you want.

**Username**
The FTP username assigned to you by your Web hosting company. Be sure to enter the information exactly how it was given to you by your provider. Usernames are
case sensitive, so if there are capital letters in your username, you must enter it that way.

**Password**
The FTP password assigned to you by your Web hosting company. Be sure to enter the information exactly how it was given to you by your provider. Passwords are case sensitive, so if there are capital letters in your password, you must enter it that way.

**Port**
A port defines how the server responds to a certain protocol. This number is usually 21, and unless your hosting provider has told you otherwise, you should not change it.

**Use Passive Mode**
Checking this box activates passive mode. Enable passive mode if you experience trouble connecting.

**Host Name**
The TCP/IP hostname of your FTP server. It should be in the form of an IP address, your domain name (e.g. `yourdomain.com`), or your domain name preceded by `ftp`. (e.g. `ftp.yourdomain.com`). Do not include `ftp://` or any directory name such as `ftp.yourdomain.com/mysite`, because these are invalid TCP/IP hostnames. It is up to your Web hosting company to assign your FTP server hostname, so you will need to find out from them what it is.

**Examples of valid Web server addresses**
- `ftp.mysite.com`
- `24.24.100.100`
- `mysite.com`

**Examples of invalid Web server addresses**
- `ftp.mysite.com/mysite`
- `http://www.mysite.com`

**Remote Folders**
Folders on your server where your Website files are stored. Common names for the remote root folder include `www`, `public_html`, or `web`. You can also use this space to configure subfolders on your server where you may want to directly upload your files.

**Test Settings**
Click this button to test the server settings.
Edit Menu

The Edit menu contains options that allow you to undo or redo your actions, cut, copy, paste, select, and delete objects, convert your code case, run a find and replace, and edit your XHTML tags.

**Undo (Ctrl+Z)**
Undoes the last action you have performed.

**Redo (Ctrl+Q)**
Redoes the last action. The Redo function comes in handy when you accidentally use the Undo function or change your mind about undoing an action.

**Cut (Ctrl+X)**
Removes the selected object or text from the screen and stores it on the Windows clipboard. It is then available to be pasted until something else is cut or copied to the clipboard.

**Copy (Ctrl+C)**
Makes a copy of the selected object or text and stores that copy on the Windows clipboard. The object is now available to be pasted until another object is cut or copied to the clipboard.

**Paste (Ctrl+V)**
Takes the object stored on the Windows clipboard and places it on the page. Pasting an object does not remove it from the clipboard, so you can paste the same object as many times as you need.

**Paste Lines as Table**
Takes the object stored on the Windows clipboard and places it in a table. Multiple lines are placed in their own rows.
Delete
Removes the selected object(s).

Select All (Ctrl+A)
Selects everything in the workspace. This is helpful if you want to copy, cut, or delete many objects at a time instead of having to select them all individually.

Convert to UPPERCASE (Shift+Ctrl+U)
Converts the selected text and tags to uppercase.

Convert to lowercase (Shift+Ctrl+L)
Converts the selected text and tags to lowercase.

Convert to Proper Case
Converts the selected text and tags to proper case. Proper case capitalizes the first letter of each word.

Find... (Ctrl+F)
Opens the Extended Find window, which allows you to search the current document, all open documents, or all the documents in a given folder for a search term.

Replace... (Ctrl+H)
Opens the Extended Find and Replace window, which allows you to search the current document, all open documents, or all the documents in a given folder for a search

Find Next (F3)
Finds the next instance of the search term entered in the Extended Find window.

Edit XHTML Tags...
Opens the Edit XHTML Tags window, which allows you to view and edit the attributes and attribute values of the available XHTML tags.
Extended Find Window

The Extended Find window allows you to search the current document, all open documents, or all the documents in a given folder for a search term.

**Find**
Enter the text or code you would like to search for in this field.

**Match Case**
Select this option if you only want to see results with the same capital and lowercase letters as entered in the Find field. For example, if you select this option and search for the phrase “Welcome to my Website,” the program will not recognize the phrase “welcome to my website” as a match.

**Find In**
This area allows you to choose which documents to search. You can look in the current document, in all open documents, or in all the documents in a given folder. If you want to use a folder, click the Browse icon to browse your computer for the desired folder. You can also select which file types you would like to return, and choose whether to search in the subfolders of the given folder.
Extended Find and Replace Window

The Extended Find and Replace window allows you to search the current document, all open documents, or all the documents in a given folder for a search term, and then replace it with text of your choosing.

For a detailed tutorial about using this function, read How to Use Extended Find and Replace.

The Search Results tab displays a complete list of the files where the search term appears. To enable it, go to View > Extended Find Results.

**File**
The path to the file where the term was found.

**Position**
The number of characters in the document that precede the term.
**Find**
Enter the text or code you would like to search for in this field.

**Replace With**
Enter the text or code you would like to replace the search term in this field.

**Match Case**
Select this option if you only want to see results with the same capital and lowercase letters as entered in the Find field. For example, if you select this option and search for the phrase “Welcome to my Website,” the program will not recognize the phrase “welcome to my website” as a match.

**Find In**
This area allows you to choose which documents to search. You can look in the current document, in all open documents, or in all the documents in a given folder. If you want to use a folder, click the Browse icon to browse your computer for the desired folder. You can also select which file types you would like to return, and choose whether to search in the subfolders of the given folder.

When running a find/replace in a folder, the HTML Editor will not confirm changes with you. For this reason, you may wish to back up your files before performing this action.

**Find Next**
Click this button to find the next instance of the search term. This will not replace anything.

**Replace**
Click this button to replace the current instance of the search term.

**Replace All**
Click this button to replace all instances of the search term.
Edit XHTML Tags Window

The Edit XHTML Tags window allows you to view and edit the attributes and attribute values of the available XHTML tags. The changes you make here will appear in the Tags tab when HTML Tags is selected, and in the code completion drop-down list when you are working in the Code Editor.

For more information about working with XHTML, check out the W3Schools XHTML Tutorial (http://www.w3schools.com/Xhtml/).

Tag Start and Tag End
The beginning and end of the tag.

Tags
This is a list of the available XHTML tags. You can add custom XHTML tags by clicking the green plus sign icon at the bottom of the list. You can delete tags by clicking the red X icon, and you can rename them by clicking the Edit Tag Name icon.
Selected Tag Attributes
This is a list of the attributes that can be used with the selected tag. You can add custom XHTML attributes by clicking the green plus sign icon at the bottom of the list. You can delete attributes by clicking the red X icon, and you can rename them by clicking the Edit Attribute Name icon.

Custom Attribute Values
This is a list of the values that can be used with the selected attribute. You can select the value type from the Attribute Type drop-down list. You can add custom values by clicking the green plus sign icon to the right of the list. You can delete values by clicking the red X icon, and you can rename them by clicking the Edit Attribute Name icon.
View Menu

The View menu contains options that allow you to change how things appear in the program.

**Views**
Displays a list of options for how the files under the **My Computer** tab in the **Resource** browser can be displayed: as icons, a list, details, small icons, or thumbnails. The following keyboard shortcuts can be used to access these options:

- **Icons** – Shift+Ctrl+F4
- **List** – Shift+Ctrl+F5
- **Details** – Shift+Ctrl+F7
- **Small Icons** – Shift+Ctrl+F8
- ** Thumbnails** – Shift+Ctrl+F9

**My Websites Tab**
Opens the **My Websites** tab in the **Resource** browser.

**My Computer Tab**
Opens the **My Computer** tab in the **Resource** browser.

**Code Snippets Tab**
Opens the **Code Snippets** tab in the **Resource** browser.

**XHTML Tags Tab**
Opens the XHTML section of the **Tags** tab in the **Resource** browser.

**PHP Tags Tab**
Opens the PHP section of the **Tags** tab in the **Resource** browser.

**CSS Tags Tab**
Opens the CSS section of the **Tags** tab in the **Resource** browser.

**Characters Tab**
Opens the **Characters** tab in the **Resource** browser.
Split-Screen Preview (F12)
Enables split-screen preview, which allows you to preview your work in a browser area below the Code Editor.

To view your work in other browsers, use the Preview tool. It's good Web design practice to test your Website in several different browsers to ensure cross-browser compatibility. The most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari.

Toggle Gutter
Enables the gutter, which is a bar to the left of the code where line numbers, bookmarks, and characters that represent line breaks are displayed.
**Toggle Word Wrap**
Select this option if you would like your text to automatically wrap to fit the Code Editor workspace.

**Toggle Line Numbers**
Turns on line numbers in the gutter.

**Extended Find Results**
Displays the **Search Results** tab at the bottom of the program.
Search Results and Document Dependencies Tabs

This area contains two tabs, Search Results and Document Dependencies. The Search Results tab displays the files where the search term specified in the Extended Find or Extended Find and Replace windows was found. The Document Dependencies tab displays the links and external files referenced in the open Website Project that have not been copied or moved to one of the Website Project folders.

To exit this area, click the red X in its upper right-hand corner.

- Search Results tab
- Document Dependencies tab
Search Results Tab

The Search Results tab displays the files where the search term specified in the Extended Find or Extended Find and Replace windows was found.

**File**
The path to the file where the term was found.

**Position**
The number of characters in the document that precede the term.
Document Dependencies Tab

The Document Dependencies tab displays the links and external files referenced in the open Website Project that have not been copied or moved to one of the Website Project folders.

<table>
<thead>
<tr>
<th>Missing Local File</th>
<th>Project File</th>
<th>Poe</th>
</tr>
</thead>
<tbody>
<tr>
<td>C:\Users\CoffeeCup Software\Desktop\css\aefault.css</td>
<td>C:\Users\CoffeeCup Software\Desktop\about-us.html</td>
<td>48</td>
</tr>
<tr>
<td>C:\Users\CoffeeCup Software\Desktop\css\thickbox.css</td>
<td>C:\Users\CoffeeCup Software\Desktop\about-us.html</td>
<td>544</td>
</tr>
<tr>
<td>C:\Users\CoffeeCup Software\Desktop\js\thickbox.js</td>
<td>C:\Users\CoffeeCup Software\Desktop\about-us.html</td>
<td>667</td>
</tr>
<tr>
<td>C:\Users\CoffeeCup Software\Desktop\contact-us.html</td>
<td>C:\Users\CoffeeCup Software\Desktop\about-us.html</td>
<td>910</td>
</tr>
<tr>
<td>C:\Users\CoffeeCup Software\Desktop\contact-us.html</td>
<td>C:\Users\CoffeeCup Software\Desktop\about-us.html</td>
<td>3039</td>
</tr>
</tbody>
</table>

**Missing Local File**
The path to the file that has not been added to the Website Project.

**Website Project File**
The path to the Website Project file that contains the missing local file.

**Position**
The number of characters in the Website Project file that precede the term.
Document Dependencies Right-Click Menu

Right-clicking the dependencies opens a menu that allows you to work with the selected dependency and Website Project.

**Edit Reference**
Brings you to the reference in the Website Project file so you can work with the HTML.

**Ignore Warning (Remove)**
Removes the warning about this dependency from the Document Dependencies list.

**Find and Copy File to Project**
Opens a window that allows you to browse your computer to find and copy the missing file to your Website Project.
My Websites Menu

The My Websites menu is where you can work with Website Projects in the program.

For more information about using Website Projects, read Working With Website Projects.

New Website Project...
Opens the Website Project Settings window, which lets you create a blank Website Project or to create a Website Project from existing files. You can also enter additional information, such as your server settings, and select your file upload options.

Open Website Project...
Allows you to open and work with a previously created Website Project.

Close Website Project
Closes the current Website Project you have open, but leaves the program open.

All Website Projects
Opens a list of all the Website Projects you have created, which allows you to access these Website Projects more quickly.

Remove Website Project
Removes the selected Website Project from the HTML Editor. The file will not be deleted from your computer.

Website Project Settings...
Opens the Website Project Settings window, which allows you to edit the settings for the current Website Project.

Upload Selected Files
Uploads the currently selected Website Project files to your server. The file structure is preserved during the upload. For example, if you upload an image
called **image.png** that is located in a folder called **images**, **image.png** will be uploaded into the **images** folder on the server. If there is no **images** folder on the server, it will be created during the upload process.

You will need to set up a server profile in the **Website Project Settings** window in order to upload your files.

You can only assign one server per Website Project. If you want to upload any or all of your Website Project files to a different server than the one specified in this field, you have two options:

1. Go to **My Websites > Website Project Settings**, switch the server, and then upload the file(s).
2. Go to the **My Computer** tab, right-click the file(s) you want to publish, and select the server and folder where you want to upload them. If any of your published documents reference these files, the path to the files you are uploading must match the path specified in your HTML code.

**Upload Entire Website Project**

Uploads the entire Website Project to your server. You will need to set up a server profile in order to perform this action.

**Check Website Project Dependencies**

Displays the **Document Dependencies** tab at the bottom of the program.
Website Project Settings Window

The Website Project Settings window allows you to add or edit the settings for a new or existing Website Project.

**Website Project Name**
The name of your Website Project. It is a personal reminder, so you can name it anything you want.

**Website Project Location**
The location where your Website Project is stored on your computer. Use the **Browse** icon to browse your computer for the desired location.

**Server**
The server where you will upload your Website Project files. You can select one of the servers you have already defined or define one using the fields in the **Server Configuration** window.
You can only assign one server per Website Project. If you want to upload any or all of your Website Project files to a different server than the one specified in this field, you have two options:

1. Go to **My Websites > Website Project Settings**, switch the server, and then upload the file(s).
2. Go to the **My Computer** tab, right-click the file(s) you want to publish, and select the server and folder where you want to upload them. If any of your published documents reference these files, the path to the files you are uploading must match the path specified in your HTML code.

**Configure Servers**
Opens the **Server Configuration window**, which allows you to configure a new or existing server profile.

**Remote Root Folder**
The root folder where your Website files are stored on your server. Common names include **www**, **public_html**, or **web**. If you are not sure of this information, contact your hosting provider.

**Server URL**
The TCP/IP hostname of your FTP server. It should be in the form of an IP address, your domain name (e.g. **yourdomain.com**), or your domain name preceded by **ftp**. (e.g. **ftp.yourdomain.com**). Do not include **ftp://** or any directory name such as **ftp.yourdomain.com/mysite**, because these are invalid TCP/IP hostnames. It is up to your Web hosting company to assign your FTP server hostname, so you will need to find out from them what it is.

**Examples of valid Web server addresses**
ftp.mysite.com
24.24.100.100
mysite.com

**Examples of invalid Web server addresses**
ftp://ftp.mysite.com
ftp.mysite.com/mysite
http://www.mysite.com

**Check Dependencies Before Uploading Files**
Checks the dependencies before uploading your files to your server to ensure they are referenced correctly. Website Project dependencies are links and external files, such as style sheets, images, etc.
If Dependencies Are Missing From Local System, Cancel File Upload
Cancels the file upload if any of the document dependencies are not located in the right place in your Website Project.

When Uploading Files
You can choose to always upload dependent files like images and style sheets, never upload them, or have the program confirm with you before uploading them.
Document Menu

The Document menu allows you to work with document properties and bookmarks, and to validate your HTML.

**Document Weight...**
Opens the Document Weight window, which contains information about the size of the currently open document and how long it will take to download to a computer on several different connections.

**Document Dependencies...**
Opens the Document Dependencies window, which lists the background images, items, and external links in your document. You can use this information to keep track of your dependencies and prevent issues like broken links and images.
Document Properties...
Opens the Document Properties window, which lets you change the page title, character set, background image or color, link colors, and color scheme.

Set Highlighter File Type
Displays a list of four file types: text, HTML, CSS, and Perl. The highlighting style in the document will change according to which option you choose.

To change the highlighting color scheme, go to Tools > Preferences > Customization tab, and then click the Modify Highlighting button.

Set Bookmark (Shift+Ctrl+[0–9])
Displays a list of 10 bookmark slots labeled Bookmark 0–9. Selecting one of these options sets a bookmark at the location of the cursor. If you set a bookmark in a slot that already contains a bookmark, it will be reset to the new location.
For a detailed tutorial about working with bookmarks, read How to Use Bookmarks.

**Go to Bookmark (Ctrl+[0–9])**
Displays a list of bookmarks that have been set. Selecting one of these options takes you to the location of the bookmark.

**Clear All Bookmarks**
Clears all the bookmarks that have been set.

**Go to Line Number... (Ctrl+G)**
Opens the Go to Line Number window, which allows you to enter a line number you would like to be taken to.

**Validate HTML...**
Opens [http://validator.w3.org/](http://validator.w3.org/) in your default Web browser. You can validate the HTML of pages you have already published to your server, or you can upload the files to this site and check them before uploading. For more information about using this tool, refer to the site’s documentation ([http://validator.w3.org/about.html](http://validator.w3.org/about.html)).
Document Weight Window

The Document Weight window contains information about the size of the currently open document and how long it will take to download to a computer on several different connections.

**Weight (File Size)**
This area displays the weight (file size) of the current document and of any dependencies (background images, external links, etc.). It also lists the total weight of the document.

**Estimated Download Time**
This area lists the estimated time it will take for your page to load on a computer based on its connection speed.
Document Properties Window

The Document Properties window lets you change the page title, character set, background image or color, link color, and color scheme.

Page Title
The text displayed on the browser's title bar that also appears in search results. A good page title succinctly describes the content on the page.

Background Image
To select a background image for your page, enter the file path in this field or click the Browse icon to browse your computer for the image you wish to use. To remove a background image, click the red X icon.

Colors
There are five color options available: page background, text, and unvisited, visited, and active links. To change the color of any of these elements, click the associated color swatch. This opens a drop-down list of 40 basic colors.
To browse even more colors, click **More Colors**. This opens a rainbow gradient that allows you to adjust brightness and select from a wider range of colors.

**Color Scheme Drop-Down List**
If you would like to use a color scheme, select one from this drop-down list.

**Save**
Click this button if you have made changes to a scheme that you would like to save.
Save As...
Click this button if you have created a color scheme you would like to use again. This opens a window that allows you to enter a name for your new scheme.

After you click OK, the scheme will be available under the drop-down list.

Delete
Click this button to delete the selected scheme.

Don’t Underline Links
Check this box if you would like to remove the automatic underline from your links.

Charset
Select your preferred character set from this drop-down list.
Insert Menu

The Insert menu allows you to insert various elements into your page.

**Link... (Ctrl+L)**
Opens the Insert Link window, which allows you to insert a link and any associated attributes.
Target... (Ctrl+T)
Opens the **Insert Target** window, which allows you to insert a target. Targets and links are used to create links to different parts of the same page.

![Insert Target Window](image)

For a detailed tutorial about using links and targets, read [Linking to Different Parts of the Same Page](#).

**E-mail Link... (Ctrl+E)**
Opens the **Insert E-mail Link** window, which allows you to insert an e-mail link and any associated attributes.

**Quick Link to Open Document**
Expands to display a list of documents that are open in the HTML Editor. Mousing over a document name expands the menu to display a list of the anchors within the document.

Selecting a document and a location within the document inserts a relative link to the document and the selected anchor into the currently open file.

**Quick Link to Relative File**
Expands to display a list of the files and folders located in the same folder as the currently open document, as well as an option to move up one folder.
Selecting a file from this list inserts a relative link to that file in the currently open document.

⚠ Careful where you link! If the file you link to isn’t located in your Working folder or your Website Project, it may not be referenced correctly — meaning the link won’t work. Need more information about working with Website Projects? Check out this tutorial: Working With Website Projects.

**Image… (Ctrl+M)**
Opens the Insert Image window, which allows you to insert an image and any associated attributes, and to create a thumbnail version of the image.

You can also add an image by dragging it from the My Websites or My Computer tab into the Code or Visual editor.

**Sound…**
Opens the Insert Sound window, which you can use to browse your computer for a sound to play on your Webpage.
You can also add a sound by dragging it from the My Websites or My Computer tab into the Code or Visual editor.

**List...**
Opens the Insert List window, which allows you to insert or import one of four different kinds of lists: bulleted, numbered, definition, or unformatted.

**Comment... (Shift+Ctrl+C)**
Opens the Insert Comment window, which allows you to insert a comment. Comments are not rendered by Web browsers and can be used to leave notes for yourself or for anyone else who may view your code.
Horizontal Rule...
Opens the Insert Horizontal Rule window, which allows you to design a horizontal rule and add it to your page.

Color...
Opens the Color window, which allows you to choose a color by selecting it from the rainbow gradient or by manually entering various values associated with the desired color. The hex code for this color will be added wherever the cursor is positioned on the page.
Frame Designer...
Opens the Frame Designer, which allows you to create a frames-based layout.

Table Designer...
Opens the CoffeeCup Table Designer, which allows you to create a table. A table can be used to display information or as your page layout.

Quick Table...
Opens the Quick Table window, which allows you to design a basic table.

Drag your mouse over the squares to pick how many columns and rows are in your table. Click when you have specified the desired dimensions, and the code will be inserted on your page.

Form Items
Opens a submenu that allows you to insert various form items.

For comprehensive information about creating and modifying HTML forms, read the W3Schools tutorial HTML Forms and Input (http://www.w3schools.com/html/html_forms.asp).
Get CoffeeCup Form Builder

Opens the CoffeeCup Web Form Builder page (http://www.coffeecup.com/form-builder/) in your default Web browser. This program simplifies the process of adding Web forms to your Website.

Insert Form...

Opens the Insert Form window, which allows you to set the form method, MIME post method, and URL where the form results will be directed. This information is important if you want your form to work properly!

Drop-Down List...

Opens the Insert Drop-Down List window, which allows you to configure the contents of a drop-down list.
Enter the options you would like to display in the **Item** field, and enter the values you would like to appear in the form results in the **Value** field. The **Name** appears in the form results, and the **Alignment** options control where the element appears on the page.

A drop-down list is a bar with an arrow that expands to show a list when clicked. It is best suited for lists in which your user can only select one option. The drop-down list configured above renders like this:

**List Box...**
Opens the **Insert List Box** window, which allows you to configure the contents of a list box.
Enter the options you would like to display in the **Item** field, and enter the values you would like to appear in the form results in the **Value** field. The **Name** appears in the form results, and the **Alignment** options control where the element appears on the page.

A list is a text box containing a list of items that your user can select, and is best suited for lists in which your user can select several options. The list box configured above renders like this:

![List Box Example](image)

**Radio Button Group...**

Opens the **Insert Radio Button Group** window, which allows you to configure a radio button group. Radio buttons must be grouped in order to work correctly.
Enter the options you would like to display in the Item field, and enter the values you would like to appear in the form results in the Value field. The Name appears in the form results, and the Alignment options control where the element appears on the page.

**Checkbox**
Inserts the code for a checkbox, which is a square box that can be selected and deselected, and is best suited for lists in which your user can select one or more answers. A checkbox looks like this:

☐ Vermont

**Radio Button**
Inserts the code for a radio button, which is a round button that your user can select but only deselect by selecting another option. They are best suited for lists in which your user can only select one answer. A radio button looks like this:

⊙ Vermont

**Image**
Inserts the code for a form image. This is particularly helpful if you want to add custom buttons to your form.

**Text Box**
Inserts the code for a text box, which is a one-line field where your user can type information, and is best suited for short answers, such as name, e-mail address, phone number, etc. A text box looks like this:
**Password Text Box**
Inserts the code for a password text box, which is a one-line field where your user can type a password. All the characters are disguised.

**Hidden Text**
Inserts the code for hidden text, which appears in your copy of the form results and can be used for sorting and filtering information.

**File Browse Text Box**
Inserts the code for a file browse text box, which is used to browse your computer for a file. This file will be uploaded when the form is submitted.

**Text Area**
Inserts the code for a text area, which is a multiple-line field where your user can type information, and is best suited for longer answers, such as messages, feedback, etc. A text area looks like this:

**Button**
Inserts the code for a generic “Submit Query” button, which submits the information to the URL specified in the Insert Form window.

**Submit Button**
Inserts the code for a submit button.

**Reset Button**
Inserts the code for a reset button.

**Style Sheet Items**
Displays a list of options that let you insert various style sheet items.
For comprehensive information about creating and modifying style sheets, read the W3Schools tutorial **CSS Introduction** ([http://www.w3schools.com/css/css_intro.asp](http://www.w3schools.com/css/css_intro.asp)).

**Style Sheet Wizard...**

Opens the **Style Sheet** window, which allows you to choose between creating a new style sheet class and applying a style sheet to a preexisting HTML tag.

![Style Sheet Wizard](image)

After you make your choice, you will be taken to the **Style Sheet Wizard**, which allows you to set the various options for your style sheet.

**Style Sheet Attribute Wizard...**

Opens the **Style Sheet Wizard**, which allows you to set the various options for your style sheet.

**CSS Menu Designer...**

Opens the **CoffeeCup CSS Menu Designer**, which allows you to design a CSS menu.

**Head**

Inserts the `<head></head>` HTML tags. Put header information such as meta tags and titles between these tags. Your head tags should come after your `<html>` tag and before your `<body></body>` tags.

**Title**

Inserts the `<title></title>` HTML tags between the `<head></head>` tags. Put your page title between these tags. A page title is used on the browser’s title bar and will appear in search results. A good page title succinctly describes the content on the page.
**Meta Description**
Inserts the meta description HTML code between the `<head></head>` tags. Put your meta description within this tag. This is a short description of your Website. It should be no longer than 50 words.

**Meta Keywords**
This inserts the meta keyword HTML code between the `<head></head>` tags. Put your meta keywords within this tag. These are words that describe your Webpage. They must each be separated by a comma and a space.

For more information about meta information, read New From Quick Start.
Insert Link Window

The Insert Link window allows you to insert a link and any associated attributes.

For a detailed tutorial about inserting links, read Adding a Link to Your Page.

![Insert Link Window](image)

**Link Text**
The text your user will click. By default, link text is blue and underlined.

**URL**
The location where your user will be taken when they click the link text. If you are linking to an external Website, you must include the full link, including `http://` and `www`, if applicable. If you are linking to a page or document in your Website, you can use a relative link by clicking the file icon to browse your computer for the desired page. You should make sure the file is located in your Working folder or your Website Project to make sure it is referenced correctly.
For more information about using Website Projects, read Working With Website Projects.

**Target**
The frame you want the link to open in. This field is only necessary if you are using frames or if you want to open the link in a new window. To open the link in a new window, select New Browser Window (target="_blank").

**Title**
A description of the link that will appear as a tooltip when the user holds their mouse over the link.

**Show Statusbar Message on Mouseover**
Checking this box displays a description of the link in the Statusbar at the bottom of the Web browser screen. This option is only enabled in Internet Explorer.

**Web Browser Window Message**
Enter the Statusbar message here.
Insert E-mail Link Window

The Insert E-mail Link window allows you to insert an e-mail link and any associated attributes. When your user clicks on this link, their default e-mail client (Thunderbird, Outlook Express, etc.) will open with this e-mail address in the To: field.

For a detailed tutorial about using e-mail links, read Adding an E-mail Link to Your Page.

Link Text
The text your user will click. By default, link text is blue and underlined.

E-mail Address to Link To
The e-mail address that will appear in the user's default e-mail client when they click the link text.

Subject
The subject of the e-mail.
Show Statusbar Message on Mouseover
Checking this box displays a description of the link in the Statusbar at the bottom of the Web browser screen. This option is only enabled in Internet Explorer.

Web Browser Window Message
Enter the Statusbar message here.
Insert Image Window

The Insert Image window allows you to insert an image and any associated attributes, as well as create a thumbnail version of the image. Use the area on the left-hand side of the window to browse your computer for the desired image. The image should be located in your Working folder or Website Project in order to display correctly.

You can also add an image by dragging it from the My Websites or My Computer tab into the Code or Visual editor. For a detailed tutorial about adding images, read Adding an Image to Your Page.

If you want more Web graphics to choose from, click the Get More Great Web Graphics Here button to check out the CoffeeCup Graphics Shop at https://www.coffeecup.com/store/graphics/.

After you have selected an image and configured any additional attributes, click OK. This opens the Copy to Project window, which prompts you to save your image to your Website Project or Working folder.
You can save the image to any of the preexisting folders in your Website Project or click **Create Folder** to create a new folder for your image. When you have selected the folder where your image will be stored, click **OK**.

**General Tab**
This is where you insert the path to the image and its attributes.
**Image**
Enter the image path here. If you select an image using the tools on the left-hand side of the window, the path will appear in this field.

**Alt**
A description of the image displayed when the image cannot be shown, such as in a text-only or speech browser, or if a user has a slow connection. You should always use detailed alt text for all prominent or contextually important images on your Webpage.

**Title**
A description of the image that appears as a tooltip when the user holds their mouse over the image.

**Align**
Select the desired alignment from this drop-down list.

**Border**
Enter the width of the border in pixels in this field. If you do not want a border, enter 0.

**Width and Height**
These fields display the width and height of your image and can also be used to resize it. Providing this information allows the page structure to load correctly before the image loads. If you do not want to include these values, uncheck the **Include size** checkbox.
The image resize feature should only be used to make minor adjustments, since significant adjustments may distort the image. If you need to make advanced changes to your image, use an image-editing program.

**URL to Link To**
If you would like to use the image as a link, use this field to enter the location where your user will be taken when they click the image. If you are linking to an external Website, you must include the full link, including http:// and www, if applicable. If you are linking to a page or document in your Website, you can use a relative link by clicking the **file** icon to browse your computer for the desired page. You should make sure the file is located in your Working folder or your Website Project to make sure it is referenced correctly.

For more information about using Website Projects, read **Working With Website Projects**.

**Thumbnail Tab**
This is where you can create an optional image thumbnail, which is a smaller version of the image. Thumbnails are often used as links to the original version of the image.

![Thumbnail Tab](image)

**Create and Insert Image as Thumbnail**
Select this checkbox if you would like to use the image as a thumbnail.

**Link to Original Image**
Select this checkbox if you would like the thumbnail to link to the original image.
**Thumbnail Filename Prefix**
This differentiates the thumbnail version of the image from the original. By default, it is set to `tn_`, but you can change it to whatever you want.

**Thumbnail Width and Height**
Enter the width and height of the thumbnail here. The aspect ratio is maintained so the image will not be distorted.

**Thumbnail Format and Quality**
Choose the desired image file format (.gif or .jpg) and quality. High-quality images display better, but are also larger, which makes for longer download times.
Insert List Window

The Insert List window allows you to insert one of four different kinds of lists. You can also import a list clicking the Import List button.

For a detailed explanation of how to use lists, read How to Create a List.

![Insert List Window](image)

**List Type**
Choose from the four different list styles: bulleted, numbered, definition, or list items.

**Bullet Style**
Choose from the different bullet styles. This only applies if you are using a bulleted or numbered list.

**List Header Text**
Enter your list header here. A list header appears above the list as a label.

**List Item Field**
Enter the list items in this field. Put each list item on its own line.
Insert Horizontal Rule Window

The Insert Horizontal Rule window allows you to configure the settings of a horizontal rule that is then added to your page. You can preview the changes you make in the Preview area.

For more information about horizontal rules, read What Is a Horizontal Rule?

Alignment
Choose the alignment of your horizontal rule: left, right, or centered.

Width
Choose the line width and whether it is measured as a percentage of the containing element (such as the page or a <div> tag) or in pixels.

Thickness
Choose the line thickness, with 1 being the thinnest and 10 being the thickest.
Shading
Choose whether to apply a 3D effect to the line.

Color
Checking the Include color checkbox allows you to change the color of the line. This effect only appears in Internet Explorer. To select a color, click the color swatch. This opens a drop-down list of 40 basic colors.

To browse even more colors, click More Colors. This opens a rainbow gradient that allows you to adjust brightness and select from a wider range of colors.
Frame Designer

The Frame Designer allows you to create a frames-based layout. Select your preferences using the provided tools, and the designer will automatically insert the code for you. You can preview how your design will look using the Preview pane on the left-hand side of the window.

For a detailed tutorial about how to use this tool, read How to Use the Frame Designer.

Frame Style
Choose from a number of predefined frame styles. These styles include the number of frames, where they are located, and what function they perform. For example, **Header Two Frame** contains two frames, one intended for use as a header and another larger one where the body content goes.

Frame Width and Height
Use these drop-down menus to set the width and height of the selected frame. To select a frame, click it, and it will turn blue.
The width and height are measured in the percentage of the page the frame occupies. If the selected frame takes up the entire height or width of the page by default, you will not be able to adjust that attribute.

**Frame Scrolling**
Choose whether your users can scroll within the frame. **Auto** adds a scroll bar when necessary, **Yes** adds a scroll bar at all times, and **No** will not add a scroll bar at any time.

**Allow Frame Resize**
Select this checkbox if you want your users to be able to resize the frames.

**Frame Border**
Select this checkbox to enable a frame border, and then enter the width of the border in the number field. 0 is the thinnest border and 50 is the largest.

**Frame Name**
Enter a name for the frame here. You should use a name that relates to the frame’s function.

**Source URL**
Enter the URL of the page you want to appear in the frame here. If you are linking to an external Website, you must include the full link, including http:// and www, if applicable. If you are linking to a page or document in your Website, you can use a relative link. You should make sure the file is located in your Working folder or your Website Project to make sure it is referenced correctly.

For more information about using Website Projects, read *Working With Website Projects*. 
CoffeeCup Table Designer

The CoffeeCup Table Designer allows you to design a table. When you are ready to apply your table code to your page, click OK.

The Table Designer is split into two tabs, the Table Design tab and the IE Preview tab. The Table Design tab allows you to add content and work with your table, and the IE Preview tab allows you to see how your work looks in a Web browser.

To test your table in other browsers, add the code to your page and then use the Preview tool. It's good Web design practice to test your Website in several different browsers to ensure cross-browser compatibility. The most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari.

- Insert New Table window
- Table Designer menu bar
- Table Designer toolbar
- Table Designer right-click menu
Insert New Table Window

The Insert New Table window opens when you open the Table Designer and contains tools that allow you to set up a table.

**Number of Rows and Columns**
Enter the number of rows and columns into these fields.

**Background and Border Color**
To change the background and/or border color of the table, click the associated color swatch. This opens a drop-down list of 40 basic colors.
To browse even more colors, click **More Colors**. This opens a rainbow gradient that allows you to adjust brightness and select from a wider range of colors.

![Color Gradient](image)

**Table Width**
Enter the width of the table in this field. You can choose from a percentage of the page or a fixed size in pixels.

**Cell Spacing**
Enter the space in pixels that will appear between each cell.

**Cell Padding**
Enter the space in pixels that will appear between the border of the cell and its contents.

**Border Width**
Enter the width in pixels of the border between the cells.
Table Designer Menu Bar

The Table Designer menu bar is located at the top of the window. It gives you access to all the tools for modifying your table, as well as options like opening, saving, and previewing your work.

- File menu
- Edit menu
- Insert menu
- Format menu
- Table menu
File Menu

The File menu allows you to work with basic aspects of the Table Designer, including creating, opening, saving, and previewing tables, as well as closing the designer.

**New**
Creates a new blank table for you to edit from scratch.

**Open...**
Allows you to open and work with a previously created table.

**Save...**
Saves the table you are currently working on. We recommend you save frequently to prevent loss in case something happens to your computer while you are working.

**Save As...**
Allows you to save the current table under a different name. This will not overwrite the table you are currently working on; instead, it will create a new table that you can give a different name.

**Preview**
Switches the view to the **IE Preview** tab, which allows you to see how your work looks a Web browser.

To test your table in other browsers, add the code to your page and then use the **Preview** tool. It’s good Web design practice to test your Website in several different browsers to ensure cross-browser compatibility. The most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari.

**Exit**
Closes the Table Designer.
Edit Menu

The Edit menu allows you to undo or redo your actions and to cut, copy, paste, select, and delete objects.

**Undo (Ctrl+Z)**
Undoes the last action you have performed.

**Redo (Ctrl+Q)**
Redoes the last action. The Redo function comes in handy when you accidentally use the Undo function or change your mind about undoing an action.

**Cut (Ctrl+X)**
Removes the selected object or text from the screen and stores it on the Windows clipboard. It is then available to be pasted until something else is cut or copied to the clipboard.

**Copy (Ctrl+C)**
Makes a copy of the selected object or text and stores that copy on the Windows clipboard. The object is now available to be pasted until another object is cut or copied to the clipboard.

**Paste (Ctrl+V)**
Takes the object stored on the Windows clipboard and places it on the page. Pasting an object does not remove it from the clipboard, so you can paste the same object as many times as you need.

**Paste Special...**
Allows you to choose the format of the pasted information.
Delete (Ctrl+Del)
Removes the selected object(s).
Insert Menu

The Insert menu allows you to insert an image into your table.

**Insert Image...**

Opens a window that allows you to browse your computer for the image you would like to add to your table.
Format Menu

The Format menu allows you to format the style and font of your text and to set the background color of your table.

**Bold**
Bolds the selected text or, if no text is selected, applies bold formatting to any text typed after the location of the cursor.

**Italic**
Italicizes the selected text or, if no text is selected, applies italic formatting to any text typed after the location of the cursor.

**Underline**
Underlines the selected text or, if no text is selected, applies underline formatting to any text typed after the location of the cursor.

**Font...**
Opens the Font window, which allows you to select the font, style, effects, size, and color of your table text.
**Fill (Background) Color...**

Opens the Fill Color window, which allows you to choose the fill color and set paragraph padding.

You can choose to apply the color to the text, the paragraph, or the entire table. To select more colors, click the More Colors button. This opens the Color window, which allows you to adjust brightness and select from a wider range of colors.
To change the paragraph padding, click the **Padding** button. This opens the **Padding** window, which allows you to set the padding in pixels. The padding is the amount of space that appears between the paragraph and the border of the cell.
Table Menu

The Table menu allows you to insert tables, adjust the table properties, and work with rows, columns, and cell contents.

Insert Table...
Opens the Insert New Table window, which contains tools that allow you to set up a table. When you click OK, the table will be added above any preexisting tables in the Table Design tab.

Table Properties...
Opens the Table Properties window, which contains the same tools as the Insert New Table window. Use it to edit the settings for the existing table.
**Insert Column Left**
Inserts a column to the left of where the cursor is positioned.

**Insert Column Right**
Inserts a column to the right of where the cursor is positioned.

**Insert Row Above**
Inserts a row above where the cursor is positioned.

**Insert Row Below**
Inserts a row below where the cursor is positioned.

**Delete Row(s)**
 Deletes the row where the cursor is positioned or the selected row(s).

**Delete Column(s)**
Deletes the column where the cursor is positioned or the selected column(s).

**Select**
Allows you to select the entire table, a row, a column, or a cell.
Align Cell Contents
Allows you to choose the alignment of the content in the selected cell: top, middle, bottom, or default cell vertical alignment.

Split Cells...
Opens the Split window, which allows you split the selected cell or cells.
You can choose to split the cell into a number of rows and columns that you specify, or if you are working with a cell that you previously merged, you can split the cells back into their original configuration. If you want to merge the contents of the cell before you split them, which consolidates all your content into one cell and then splits it into multiple cells, check the Merge before splitting checkbox.

**Merge Cells**
Merges the contents of the cells into one cell.
Table Designer Toolbar

The Table Designer toolbar contains buttons that you can click to perform certain commonly used actions quickly. Right-clicking the toolbar opens this menu:

Unchecking the **Main Toolbar** (or any custom toolbars that may be listed) removes it from the workspace. It can be re-added by checking it again. Selecting **Customize...** opens the Customize window, which allows you to customize the main toolbar or create your own.

- **New**
  Creates a new blank table for you to edit from scratch.

- **Open**
  Allows you to open and work with a previously created table.

- **Save**
  Saves the table you are currently working on. We recommend you save frequently to prevent loss in case something happens to your computer while you are working.

- **Undo (Ctrl+Z)**
  Undoes the last action you have performed.

- **Redo (Ctrl+Q)**
  Redoes the last action. The Redo function comes in handy when you accidentally use the Undo function or change your mind about undoing an action.

- **Cut (Ctrl+X)**
  Removes the selected object or text from the screen and stores it on the Windows clipboard. It is then available to be pasted until something else is cut or copied to the clipboard.
Copy (Ctrl+C)
Makes a copy of the selected object or text and stores that copy on the Windows clipboard. The object is now available to be pasted until another object is cut or copied to the clipboard.

Paste (Ctrl+V)
Takes the object stored on the Windows clipboard and places it on the page. Pasting an object does not remove it from the clipboard, so you can paste the same object as many times as you need.

Insert Image
Opens a window that allows you to browse your computer for the image you would like to add to your table.

Bold
Bolds the selected text or, if no text is selected, applies bold formatting to any text typed after the location of the cursor.

Italic
Italicizes the selected text or, if no text is selected, applies italic formatting to any text typed after the location of the cursor.

Underline
Underlines the selected text or, if no text is selected, applies underline formatting to any text typed after the location of the cursor.

Font
Opens the Font window, which allows you to select the font, style, effects, size, and color of your table text.
Fill (Background) Color
Opens the Fill Color window, which allows you to choose the fill color and set paragraph padding.
You can choose to apply the color to the text, the paragraph, or the entire table. To select more colors, click the More Colors button. This opens the Color window, which allows you to adjust brightness and select from a wider range of colors.

To change the paragraph padding, click the Padding button. This opens the Padding window, which allows you to set the padding in pixels. The padding is the amount of space that appears between the paragraph and the border of the cell.
**Insert Table**
Opens the **Insert New Table** window, which contains tools that allow you to set up a table. When you click OK, the table will be added above any preexisting tables in the **Table Design** tab.

**Table Properties**
Opens the **Table Properties** window, which contains the same tools as the **Insert New Table** window. Use it to edit the settings for the existing table.

![Table Properties](image)

**Modify Table Cells**
This expands to show some options you can use for modifying the cells in your table.

**Insert Column Left**
Inserts a column to the left of where the cursor is positioned.

**Insert Column Right**
Inserts a column to the right of where the cursor is positioned.
Insert Row Above
Inserts a row above where the cursor is positioned.

Insert Row Below
Inserts a row below where the cursor is positioned.

Delete Row(s)
Deletes the row where the cursor is positioned or the selected row(s).

Delete Column(s)
Deletes the column where the cursor is positioned or the selected column(s).

Merge Cells
Merges the contents of the cells into one cell.

Split Cells...
Opens the Split window, which allows you split the selected cell or cells.

You can choose to split the cell into a number of rows and columns that you specify, or if you are working with a cell that you previously merged, you can split the cells back into their original configuration. If you want to merge the contents of the cell before you split them, which consolidates all your content into one cell and then splits it into multiple cells, check the Merge before splitting checkbox.
Table Designer Right-Click Menu

The right-click menu allows you to access commonly used features in the Table Designer.

**Undo (Ctrl+Z)**
Undoes the last action you have performed.

**Redo (Ctrl+Q)**
Redoes the last action. The Redo function comes in handy when you accidentally use the Undo function or change your mind about undoing an action.

**Cut (Ctrl+X)**
Removes the selected object or text from the screen and stores it on the Windows clipboard. It is then available to be pasted until something else is cut or copied to the clipboard.

**Copy (Ctrl+C)**
Makes a copy of the selected object or text and stores that copy on the Windows clipboard. The object is now available to be pasted until another object is cut or copied to the clipboard.

**Paste (Ctrl+V)**
Takes the object stored on the Windows clipboard and places it on the page. Pasting an object does not remove it from the clipboard, so you can paste the same object as many times as you need.

**Paste Special...**
Allows you to choose the format of the pasted information.
Font...
Opens the **Font** window, which allows you to select the font, style, effects, size, and color of your table text.
Fill (Background) Color...
Opens the Fill Color window, which allows you to choose the fill color and set paragraph padding.

You can choose to apply the color to the text, the paragraph, or the entire table. To select more colors, click the More Colors button. This opens the Color window, which allows you to adjust brightness and select from a wider range of colors.
To change the paragraph padding, click the **Padding** button. This opens the **Padding** window, which allows you to set the padding in pixels. The padding is the amount of space that appears between the paragraph and the border of the cell.

![Padding Window](image)

**Bold**
Bolds the selected text or, if no text is selected, applies bold formatting to any text typed after the location of the cursor.

**Italic**
Italicizes the selected text or, if no text is selected, applies italic formatting to any text typed after the location of the cursor.

**Underline**
Underlines the selected text or, if no text is selected, applies underline formatting to any text typed after the location of the cursor.

**Table**
Expands to display options for creating or editing a table.
**Insert Table...**
Opens the **Insert New Table window**, which contains tools that allow you to set up a table. When you click **OK**, the table will be added above any preexisting tables in the **Table Design** tab.

**Table Properties...**
Opens the **Table Properties** window, which contains the same tools as the **Insert New Table** window. Use it to edit the settings for the existing table.
**Insert Column Left**
Inserts a column to the left of where the cursor is positioned.

**Insert Column Right**
Inserts a column to the right of where the cursor is positioned.

**Insert Row Above**
Inserts a row above where the cursor is positioned.

**Insert Row Below**
Inserts a row below where the cursor is positioned.

**Delete Row(s)**
Deletes the row where the cursor is positioned or the selected row(s).

**Delete Column(s)**
Deletes the column where the cursor is positioned or the selected column(s).

**Select**
Allows you to select the entire table, a row, a column, or a cell.
**Align Cell Contents**
Allows you to choose the alignment of the content in the selected cell: top, middle, bottom, or default cell vertical alignment.

**Split Cells...**
Opens the Split window, which allows you split the selected cell or cells.
You can choose to split the cell into a number of rows and columns that you specify, or if you are working with a cell that you previously merged, you can split the cells back into their original configuration. If you want to merge the contents of the cell before you split them, which consolidates all your content into one cell and then splits it into multiple cells, check the Merge before splitting checkbox.

**Merge Cells**
Merges the contents of the cells into one cell.
Insert Form Window

The Insert Form window allows you to set the form method, MIME post method, and URL where the form results will be directed. This information is important if you want your form to work properly!

For comprehensive information about creating and modifying HTML forms, read the W3Schools tutorial HTML Forms and Input (http://www.w3schools.com/html/html_forms.asp).

Form Method
Choose how you want to transfer the form data. Post sends it to the server and get pulls it from the server.

MIME Post Method (Enctype)
Select the type of application that will process the form data.

Form Contents Go to the Following URL
The URL of the script that actually processes the form. For more information about form scripts and to download free form processing scripts, visit http://www.hotscripts.com.
Style Sheet Wizard

The Style Sheet Wizard allows you to set the various properties of your style sheet.

For comprehensive information about creating and modifying style sheets, read the W3Schools tutorial CSS Introduction (http://www.w3schools.com/css/css_intro.asp).

- Font tab
- Color and Background tab
- Alignment tab
- Margins tab
- Padding tab
- Border tab
Font Tab

The Font tab allows you to set preferences for the font of the class or HTML tag you are modifying for your style sheet.

Font Family
Select the desired font family from these two drop-down menus. **First** is the preferred font, and can technically be any font you want. However, if you do not choose a Web-safe font, it may not display correctly on all computers. We recommend making **Second** a Web-safe font. You can also select a generic font, which always displays correctly, from the **Generic** drop-down list.

Web-safe fonts include:

- Arial
- **Arial Black**
- Courier New
- Times New Roman
- **Comic Sans MS**
- Georgia
- Impact
- Trebuchet MS
- Verdana
**Font Size**
Select the size of your font using one of four measurements: absolute, relative to the containing element, pixels, or a percentage of the containing element.

**Weight**
The lightness or darkness of your font, with 100 being the lightest and 900 being the darkest.

**Style**
Select the font style: normal, italic, or oblique.

**Decoration**
Select the font decoration: none, underline, overline, strikethrough, or blink.

**Transform**
Choose whether to apply capitalization, uppercase or lowercase letters, or none.

**Variant**
Select the variant: normal or small caps.
Color and Background Tab

The Color and Background tab allows you to set the text and background color for the class or HTML tag you are modifying for your style sheet.

Text and Background Color

To change the text or background color, click the associated color swatch. This opens a drop-down list of 40 basic colors.
To browse even more colors, click **More Colors**. This opens a rainbow gradient that allows you to adjust brightness and select from a wider range of colors.

**Background Image**
Click the **folder** icon to browse your computer for the desired background image.
**Repeat**
If you add a background image, you can repeat it horizontally and/or vertically.

**Attachment**
Select **scroll** if you want the image to always appear in the same place even when the page is scrolled up or down. Select **fixed** if you want the image to appear in a fixed place on the page.

**Alignment**
Use these fields to specify the exact alignment of the image. You can set it to the default location, or use a percentage, an absolute pixel location, or keywords.
Alignment Tab

The Alignment tab allows you to set the alignment for the class or HTML tag you are modifying for your style sheet.

Indentation
The space between where your element starts and the left edge of the page. You can set it to the default or adjust the indentation in pixels or a percentage.

Line Height
The vertical space between two lines of text. You can set it to the default or adjust the height in pixels or a percentage.
Alignment
Use these options to set where the content in the class or tag appears on the page. Set the vertical and/or horizontal alignment by keyword or percentage. If you use these options to set the alignment, you cannot use the float property.

Word and Letter Spacing
The amount of space in pixels between words and letters.

Float
Choose whether the content in the class or tag floats to the right or left, or does not float at all. If you use this option to set the alignment, you cannot use the alignment properties.

Clear
Choose the side of the floated element where other floating elements will not appear. For instance, if you select left, no floated elements will appear to the left of the specified floated element.
Margins Tab

The Margins tab allows you to set the margins, width, and height in pixels or a percentage of the containing element for the class or HTML tag you are modifying for your style sheet.

“Margin” refers to the white space surrounding an element. When the margin is increased for a selected element, more space will appear between the element and the objects surrounding it.
Padding Tab

The Padding tab lets you set the padding in pixels or a percentage of the containing element for the left, right, top, and bottom of the class or HTML tag you are modifying for your style sheet.

“Padding” refers to the white space within an element. When padding is increased for a selected element, more space will appear between its outer edges and the objects contained within it.
Border Tab

The Border tab allows you to set the borders for the class or HTML tag you are modifying for your style sheet.

**Size**
The size of the border in pixels or a percentage of the containing element.

**Style**
Choose from eight border styles.

**Color**
To change the text or background color, click the associated color swatch. This opens a drop-down list of 40 basic colors.
To browse even more colors, click **More Colors**. This opens a rainbow gradient that allows you to adjust brightness and select from a wider range of colors.
CSS Menu Designer

The CSS Menu Designer allows you to create a CSS navigation menu.

For a detailed tutorial about how to add a menu using the CSS Menu Designer, read How to Use the CSS Menu Designer. If you’re wondering what happened to the DHTML Menu Builder, read What happened to the DHTML Menu Builder?

It is extremely important to remove any old menu code from your document before inserting a new menu. If you don’t, your menu will not work. To remove your old code, click Save Menu to save any changes to your menu that you have made, and then click Cancel.

If you have already inserted a CSS menu, remove the following code from between your <head></head> tags:

```html
<link rel="stylesheet" type="text/css" href="css/menu-menu.css" media="screen"/>
```

`css/menu-menu.css` is the default name and location of the menu style sheet. If you have changed the name or location of this style sheet, this file path will reflect your changes. Next, remove this code from between the <body></body> tags:
This example contains just two menu items, but your menu may contain more. Be sure to remove the `<ul class="menu-menu">` tags and all the code between them. `menu-menu` is the default name for the menu class. If you have changed the name of the menu, the name you specified will appear here instead. `page1.html` and `page2.html` are the links you specified for the menu items. `Menu Item 1` and `Menu Item 2` are the names you specified for the menu items.

If you need to replace a DHTML menu, remove the code between `<script type='text/javascript'>` and `</script>`. This code should be located just below the `<body>` tag.

Once you have removed your old menu code, reopen the CSS Menu Designer, open your saved menu, and then insert it into your page by clicking OK.

**Open Menu**
Click this button to open a previously created menu.

**Save Menu**
Click this button to save your menu. We recommend you save frequently to prevent loss in case something happens to your computer while you are working.

**Preview**
Click this button to preview your menu in your default browser.

**OK**
Click this button to insert your menu code into the current document. This opens two windows containing information about your menu code:
This window reminds you that you must remove all your old menu code before inserting new code.

⚠️ This step is very important! If you do not remove your old menu code, your menu will not work correctly.

To exit this window, click OK. This opens the Save Menu window, which allows you to save your menu to work with it later.
We only recommend saving your menu if you have already removed your old menu code. Clicking **Save** opens a window that allows you to choose the location where you would like to save your menu.

Once you have saved your menu, the code will automatically be inserted into your page.

If you haven’t removed your old menu code, click **Cancel**. This brings you back to the CSS Menu Designer. From here, you can save your menu without automatically inserting the code into your document. For detailed information about this process, refer to the instructions above.

**Cancel**

Click this button to abandon any unsaved changes to your menu and exit the CSS Menu Designer.

For more information about the different sections of the CSS Menu Designer, click one of these links:

- Menu Designer tab
- Menu Colors tab
- Options tab
Menu Designer Tab

The Menu Designer tab allows you to add and configure menu items.

Your Menu
Allows you to preview the structure of your menu.

Add Root Item
Adds a root item to your menu. Root items make up the main part of the menu that appears at all times.

Add Subitem
Adds a subitem to the selected root item. A subitem appears when you click or mouse over the root item. You can add up to three levels of subitems.

Add Sibling
Adds another item on the same level as the selected item.

Delete Item
Deletes the selected item.

Text
Enter the text you would like to appear on the selected item in this field.
**Link**

Enter the link you would like the currently selected item to point to in this field.
Menu Colors Tab

The Menu Colors tab allows you to set the colors for your menu. You can preview any changes you make in the Menu Color Sample area.

To change the text or background color, enter a hex code or click the associated color swatch. This opens a drop-down list of 65 basic colors.
To browse even more colors, click **More Colors**. This opens a rainbow gradient that allows you to adjust brightness and select from a wider range of colors.

**Background Color**
The background color of the menu.

**Mouseover Background Color**
The background color of the menu when the user holds their mouse over it.

**Font Color**
The color of the menu text.

**Mouseover Font Color**
The color of the menu text when the user holds their mouse over it.
**Border Color**
The color of the menu border.

**Use Main Menu Colors**
Click this button if you want the submenu items to have the same color scheme as the main menu items.
Options Tab

The Options tab allows you to work with menu options not pertaining to the items and the colors.

Orientation
Choose between a horizontal and vertical layout.

Margin Top and Left
Set the top and left margin in pixels in these fields. “Margin” refers to the blank space surrounding the menu. When the margin is increased, more space will appear between the menu and the objects surrounding it.

Border Width
Enter the width of the menu border in pixels in this field.

Font Face, Size, and Style
Choose the font and size of the menu item text, as well as whether it is bold or italicized.

Menu and Submenu Text Alignment
Choose how you want the text in the menu to be aligned: to the left, right, or center.
**Top and Left Padding**
Set the top and left padding in pixels in these fields. “Padding” refers to the blank space within the menu. When the padding is increased, more space will appear between the menu text and the outer edges.

**Use Fixed Width for Menu Items**
Select this checkbox if you would like to use a fixed width for the menu items.

**Item Width**
Set the fixed item width in pixels here.
Format Menu

The Format menu allows you to format your text. If you have selected text, the tags will be applied to the selected text. Otherwise, they will be inserted on the page.

**Font Wizard...**
Opens the **Font Wizard**, which allows you to choose the attributes for a font tag.

**Font Sizes**
Select from font sizes 1 (8 pt) to 7 (36 pt) or adjust the size up or down one increment.

**Font Color...**
Opens the **Color** window, which allows you to choose a color by selecting it from the rainbow gradient or by manually entering various values associated with the desired color.

**Header Sizes**
Inserts header tags (<h1></h1>–<h6></h6>) or applies them to selected text.

**Bold (Ctrl+B)**
Inserts bold tags (<b></b>) or applies them to selected text.

**Italic (Ctrl+I)**
Inserts italic tags (<i></i>) or applies them to selected text.

**Underline (Ctrl+U)**
Inserts underline tags (<u></u>) or applies them to selected text.
**Strikethrough**
Inserts strikethrough tags (&lt;strike&gt;&lt;/strike&gt;) or applies them to selected text.

**Strong**
Inserts strong tags (&lt;strong&gt;&lt;/strong&gt;) or applies them to selected text.

**Emphasis**
Inserts emphasis tags (&lt;em&gt;&lt;/em&gt;) tags or applies them to selected text.

**Subscript**
Inserts subscript tags (&lt;sub&gt;&lt;/sub&gt;) tags or applies them to selected text.

**Superscript**
Inserts superscript tags (&lt;sup&gt;&lt;/sup&gt;) tags or applies them to selected text.

**Preformatted**
Inserts pre tags (&lt;pre&gt;&lt;/pre&gt;) tags or applies them to selected text. Pre tags preserve the formatting of the text they surround, including extra spaces and indenting.

**Left**
Inserts a div tag with the align attribute set to left (&lt;div align="left"&gt;&lt;/div&gt;) or applies it to the selected text.

**Center**
Inserts a div tag with the align attribute set to center (&lt;div align="center"&gt;&lt;/div&gt;) or applies it to the selected text.

**Right**
Inserts a div tag with the align attribute set to right (&lt;div align="right"&gt;&lt;/div&gt;) or applies it to the selected text.

**Justify**
Inserts a div tag with the align attribute set to justify (&lt;div align="justify"&gt;&lt;/div&gt;) or applies it to the selected text. This aligns your text so each line is the same length.

**Indent (Shift+Ctrl+.)**
Indents your code starting where the cursor is positioned. This change appears only in the Code Editor and will not be rendered by a browser. It is used to help organize your code.
Unindent (Shift+Ctrl+,)
Unindents your indented code starting where the cursor is positioned. This change appears only in the Code Editor and will not be rendered by a browser. It is used to help organize your code.

Paragraph (Ctrl+Enter)
Inserts paragraph tags (<p></p>) tags or applies them to selected text.

Break
Inserts a break tag (<br />).

Non-Breaking Space
Inserts a non-breaking space character entity (&nbsp;), which is rendered by browsers as a space. This can be used to insert extra spaces, since HTML only allows for one space between each word.
Font Wizard

The Font Wizard allows you to create a font tag with detailed attributes. You can preview how your text looks in the Preview Text area.

For a detailed tutorial about how to use these options, read How to Change the Appearance of Text.

Fonts

Select the desired font family from the provided list and apply them to the font tag by clicking Add as Font 1, 2, or 3. Font 1 is the preferred font, and can technically be any font you want. However, if you do not choose a Web-safe font, it may not display correctly on all computers. We recommend making Font 2 and/or Font 3 a Web-safe font. You can also select a generic font, which always displays correctly, from the Generic drop-down list.

Web-safe fonts include:

- Arial
- Arial Black
- Courier New
- Times New Roman
- Comic Sans MS
- Georgia
- Impact
- Trebuchet MS
- Verdana
**Effects**  
Select from bold, italic, strikethrough, or underline.

**Text Position**  
Select whether your text will appear normally or as a subscript or superscript.

**Size**  
Select a font size from 1 (8 pt) to 7 (36 pt).

**Color**  
To select a color for your text, click the associated color swatch. This opens a drop-down list of 40 basic colors.

To browse even more colors, click **More Colors**. This opens a rainbow gradient that allows you to adjust brightness and select from a wider range of colors.
Tools Menu

The Tools menu contains tools you can use to work with your Webpage and the program.

**Test With Default Browser (Ctrl+F9)**
Opens your Website in the browser you have set as your default browser. This is done outside of the HTML Editor.

**Additional Browsers**
Expands to show a list of other browsers you can use to preview your Website.

To configure additional browsers, go to Tools > Preferences > Browser Testing tab. It’s good Web design practice to test your Website in several different browsers to ensure cross-browser compatibility. The most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari.

**Favorite Browser (Ctrl+F5)**
Opens the page in the browser specified the first slot in the Browser Testing tab.

**Applications**
Expands to show a list of external applications you can open from within the HTML Editor.

To add external applications, go to Tools > Preferences > Applications tab.

**Other Software and Services**
Expands to display a list of other software and services offered by CoffeeCup Software.
Fresh Ingredients for Your Website
Opens the HTML Editor Theme Shop

Get More Graphics...
Opens the CoffeeCup Graphics Shop

Get More Website Software...
Opens the CoffeeCup Software page
(http://www.coffeecup.com/software/) in your default Web browser.

Site Spider...
Opens CoffeeCup Website Spider, which contains various tools and utilities that provide information you can use to optimize your Website.

Code Cleaner...
Opens the Code Cleaner, which allows you to set your preferences for how you would like your code to be formatted, and then runs the code cleaner.

You can undo any changes made during the code cleaning using the Undo function.

Website Color Schemer...
Opens the built-in copy of Website Color Schemer, which allows you to select a color scheme for your Website. For more information about how to use Website Color Schemer, consult its documentation.
**Image Map...**
Opens the built-in copy of Image Mapper, which allows you to create an image map for your Website. For more information about how to use Image Mapper, consult its documentation.

**Search for Undocumented Characters...**
Checks your document for any undocumented special characters.

If it discovers an undocumented character, it gives you the option to replace it with the proper HTML entity. When it is finished, you will see a message that says “Finished!”

To add character entities for any special characters, use the Characters tab in the Resource browser on the left-hand side of the program.

**Check Spelling...**
Checks the spelling in your document. If there are no spelling errors, a window appears that reads, “The spelling check is complete.”
If there are misspelled words, the **Spelling** window opens, allowing you to review and change the spelling errors, and to adjust spelling options.

**Auto Spell Check**
Puts a red underline under any misspelled words.

**Spell Checker Options...**
Opens the **Spelling Options** window, which allows you to adjust your spelling options and add custom dictionaries.

**Thesaurus...**
Opens the **Thesaurus**, which gives you suggestions of synonyms for the selected word.

![Thesaurus Window]

**Toolbars and Menus**
Expands to display options for customizing the toolbars and menus within the program.

For a detailed tutorial about creating a custom toolbar, read **How to Create a Custom Toolbar**.
Customize...
Opens the Customize window, which allows you to customize the program toolbars.

Save Current Configuration As...
Allows you to save the current toolbar and menu configuration. This is useful if you have created a custom configuration you may wish to use later. When you save a configuration, it will appear beneath Default in this menu.

Default
Select this to switch to the default toolbar and menu configuration.

Document Display Properties
Opens the Customization tab of the Preferences window, which allows you to customize highlighting and toolbar options.

Preferences...
Opens the Preferences window, which allows you to adjust the program preferences, including working with the appearance and function of the program, setting file types the program can open, adding browsers and external applications, setting default folders, and customizing highlighting and toolbar options.
CoffeeCup Website Spider

CoffeeCup Website Spider contains various tools and utilities that provide information you can use to optimize your Website.

For more information on how to use the Website Spider, refer to its documentation, available under Help > Help Contents....
Code Cleaner

The Code Cleaner allows you to set your preferences for how you would like your code to be formatted, and then runs the code cleaner. You can undo any changes made during the code cleaning using the **Undo** option.

Mouse over each function for a detailed description of what it does. The description appears in the yellow pane at the bottom of the window.

For a detailed tutorial about using the Code Cleaner, read **How to Use the Code Cleaner**.

**Lay Out, Fix, and Convert Tab**

The Lay Out, Fix, and Convert tab allows you to adjust the layout and format of your code. Holding your mouse over an option opens a description in the yellow pane at the bottom of the window.
Document Tab

The Document tab allows you to work with the DOCTYPE and character encoding. Holding your mouse over an option opens a description in the yellow pane at the bottom of the window.
ASP and XML Tab

The ASP and XML tab allows you to set options pertaining to ASP, HTML, and XML. Holding your mouse over an option opens a description in the yellow pane at the bottom of the window.
Website Color Schemer

The Website Color Schemer is used to generate an attractive color scheme for your Website.

For more information on how to use the Website Color Schemer, refer to its documentation, available under Help > Help Contents (F1).
Image Mapper

The Image Mapper is used to create an interactive image map.

For more information on how to use the Image Mapper, refer to its documentation, available under Help > Help Contents.
Spelling Window

The Spelling window allows you to review and change the spelling errors, and to adjust spelling options.

Not Found
A word not found in the dictionary.

Replace With
Type the replacement word in this field or select a word from the Suggestion area. Click Change or Change All to replace the misspelled word with the word in this field.

Suggestions
Spelling suggestions for the misspelled word.

Undo
Undoes the last change you have performed.

Options
Opens the Spelling Options window, which allows you to adjust your spelling options and add custom dictionaries.

Ignore
Ignores the misspelled word and displays the next word not found in the dictionary.

Ignore All
Ignores all instances of the misspelled word and displays the next word not found in the dictionary.
**Change**  
Replaces the misspelled word with the word in the **Replace With** field.

**Change All**  
Replaces all instances of the misspelled word with the word in the **Replace With** field.

**Add**  
Adds the word in the **Not Found** field to the dictionary.

**Auto-Correct**  
Adds the words in the **Not Found** and **Replace With** fields to the **Auto-Correct** dictionary. If the **Auto Spell Check** option is enabled, the misspelling will automatically be replaced with the replacement word when you run the **Check Spelling** function.

To enable Auto-Correct, go to **Tools > Auto Spell Check**.
Spelling Options Window

The Spelling Options window allows you to adjust your spelling options and add custom dictionaries.

Options
Select the options you would like to enable when checking the spelling in your document.

Dictionaries
Lists the available dictionaries. By default, 11 language dictionaries are included in the program. You may select as many as you want.

Locate Dictionaries
Selecting this option opens a window that allows you to browse your computer for another dictionary file.

For more information about how to add dictionary files to the HTML Editor, read How do I import another language dictionary into the HTML Editor?
**Custom Dictionary**
If you have added a custom dictionary and would like to use it instead of or in addition to the dictionary or dictionaries selected in the Dictionaries area, select it from this drop-down list.

**Dictionaries...**
Opens the Dictionaries window, which allows you to add, edit, and delete custom dictionaries.

![Custom Dictionaries](image)

**Edit**
Opens the Edit .adu window for the selected dictionary file, which allows you to add words, auto-correct pairs, and excluded words.

**Delete**
Deletes the selected dictionary.

**New**
Opens the New Custom Dictionary window, which allows you to enter the name of another dictionary file you would like to add to your custom dictionaries.

For more information about how to add dictionary files to the HTML Editor, read **How do I import another language dictionary into the HTML Editor?**

**Reset Defaults**
Resets the Dictionaries area to include only the 11 default dictionaries.
Edit .adu Window

The Edit. adu window allows you to add words, auto-correct pairs, and excluded words to the selected dictionary file.

Added Words Tab
Allows you to add words to the dictionary file or delete custom words you have added.
Auto-Correct Pairs Tab

Allows you to add auto-correct pairs to the dictionary file or delete custom auto-correct pairs you have added.

If the Auto Spell Check option is enabled, the word in the Replace column will automatically be replaced with word in the With column when you run the Check Spelling function.

To enable Auto-Correct, go to Tools > Auto Spell Check.
Excluded Words Tab
Allows you to add words that will always be considered incorrect when running spell check, or to delete any excluded words you have added.
Customize Window

The Customize window allows you to customize the program toolbars.

For a detailed tutorial about creating a custom toolbar, read How to Create a Custom Toolbar.

- Toolbars tab
- Commands tab
- Options tab
Toolbars Tab

The Toolbars tab allows you to add or edit program toolbars. The grayed-out toolbars are not available to be edited.

Toolbars
Displays a list of the toolbars available in the program. Selecting the checkbox for a toolbar displays it in the HTML Editor workspace, and deselecting the checkbox removes it.

New
Opens the Add Toolbar window, which allows you to name the new toolbar.
When you create a new toolbar, it opens in the HTML Editor workspace.

**Rename**
Opens the **Rename Toolbar** window, which allows you to rename the selected toolbar.

**Delete**
Deletes the selected toolbar.

**Reset (Main Toolbar Only)**
Resets the main toolbar to its default configuration.
Commands Tab

The Commands tab allows you to view and add commands to your custom toolbar or to the main toolbar. To add a command, drag it from the Commands list to the desired toolbar and drop it there.

**Categories**

Broad categories to which individual commands belong. Categories cannot be added to a toolbar.

**Commands**

Individual commands that can be added to a toolbar. To add a command, drag it to the desired toolbar and drop it there.
Options Tab

The Options tab allows you to customize other aspects of your toolbars.

**Menus Show Recently Used Commands First**
Select this checkbox if you want the most recently used commands to appear at the beginning of your custom menu or toolbar.

**Show Full Menus After a Short Delay**
Select this checkbox if you want drop-down menus in your custom menu or toolbar to appear after a short delay.

**Reset My Usage Data**
Resets your usage data so your commands appear in the order you specified instead of being ranked in order of use.
**Large Icons**
Increases the size of the menu icons.

**Show Tooltips on Toolbars**
Select this checkbox to display tooltips when you mouse over toolbar icons.

**Show Shortcut Keys in Tooltips**
Select this checkbox to display keyboard shortcuts in the toolbar tooltips.

**Menu Animations**
Select the desired menu animation from this drop-down list.
Preferences Window

The Preferences window allows you to adjust options for working with the program and your code.

- General tab
- Files tab
- Browser Testing tab
- Applications tab
- Folders tab
- Customization tab
General Tab

The General tab allows you to set display and functional preferences for the HTML Editor.

Application Startup
Select whether you would like a specific document to open automatically in the Editor on startup. You can also choose whether the My Websites or My Computer tab will be open in the Resource browser. Finally, you can specify whether the tip of the day and the Welcome window will appear.

Initial Document Mode
Select whether you want the Visual or Code editor to open automatically on startup. You can also choose whether to show or hide the Visual Editor and/or Preview tab.

Initial Document Type
Select the initial document type that will be used on startup and when you create a new page from this drop-down list.

Proper Case Conversion
When converting to proper case, any letters after the characters entered in this field will be capitalized.
To convert your document or a selection of text and code to proper case, go to Edit > Convert to Proper Case.

**Miscellaneous**
Select the checkboxes for any of the display preferences you would like to apply.

**When Starting a New Website Project**
Select what you would like the program to do when you create a new Website Project.
Files Tab

The Files tab allows you to specify the file extensions you can open and edit in the HTML Editor. Format your entries with an asterisk followed by a period and a valid extension (e.g. *.html, *.css, *.php, etc.)

**File Extensions**
Specify the valid file extensions you would like to open and edit in the Editor in these fields. To reset them back to the program defaults, click the **Reset** button.

**Unix Files**
Specify any file extensions you would like to save as Unix files.

**File Extensions That Will Not Be Opened in Visual Editor**
Switching to the Visual Editor may cause unwanted formatting in some document types. Use this field to specify any file extensions you do not want to open in the Visual Editor. This ensures that you will not accidentally open them and lose the formatting of your code.
Browser Testing Tab

The Browser Testing tab allows you to add browsers you can use to preview your work. It’s good Web design practice to test your Website in several different browsers to ensure cross-browser compatibility. The most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari.

To access any browsers you add, go to Tools > Additional Browsers.

Select a Browser
Select the slot under Tools > Additional Browsers where you would like the browser to appear. Additional Browser 1 can be accessed using the keyboard shortcut Ctrl+F5.

Display Name
Enter the desired display name for the browser.

Application Location
Use the Browse icon to browse your computer for the .exe file for the browser you want to add. To remove a browser, click the Remove icon.
Applications Tab

The Applications tab allows you to add external applications that can be opened from within the HTML Editor.

To access any applications you have added, go to Tools > Applications.

Description
A custom description of the application that will appear under Tools > Applications. This is a personal reminder, so you can name it anything you want.

Custom Application .exe
Use the Browse icon to browse your computer for the .exe file for the application you want to add. To remove an application, click the Remove icon.
Folders Tab

The Folders tab allows you to select default folders used within the HTML Editor.

![Preferences dialog box showing Folders tab]

**Default Website Projects Folder**
Click the **Browse** icon to select the default folder where your Website Projects are saved.

**Default Working Folder**
Click the **Browse** icon to select the default Working folder. If you are using a Website Project, by default, the Working folder is the same as the Website Projects folder. Otherwise, the Working folder is where you save your Website files.

**Default Image Folder**
Click the **Browse** icon to select the default Image folder. Whichever folder you select will be open by default in the **Insert Image** window.

**Default Background Image Folder**
Click the **Browse** icon to select the default Background Image folder. Whichever folder you select will be open by default in the window that appears when you add a background image in the **Document Properties** window.
Default Sounds Folder
Click the Browse icon to select the default Sounds folder. Whichever folder you select will be open by default in the Insert Sound window.

Optional Prompts
These options prompt you when you add an image or insert a page and it is not located in your Working folder. If you are using a Website Project, by default, the Working folder is the same as the Website Projects folder. Otherwise, the Working folder is where you save your Website files.
Customization Tab

The Customization tab allows you to customize highlighting and toolbar options.

Documents
Select the document type whose highlighting scheme you want to modify from this drop-down list.

Modify Highlighting
Opens the Highlighting Options window, which allows you to modify the highlighting scheme for the selected document type. This scheme applies only to the code in the Editor as a personal reminder, and will not be rendered by Web browsers.

Modify Options
Opens the Editor Options window, which allows you to set display preferences for the Code Editor.

Toolbar Customization
Lists the custom toolbars you have configured and allows you to delete or rename them.

To create a custom toolbar, go to Tools > Toolbars and Menus > Customize.
Highlighting Options Window

The Highlighting Options window allows you to modify the highlighting scheme for the document type selected in the Customization tab of the Preferences window. This scheme applies only to the code in the Editor as a personal reminder, and will not be rendered by Web browsers.

For more information about working with highlighting options, read Adjusting Code Highlighting Options.

Current Language Style
Displays the document type you are editing.
Element
Lists the different elements of the current language. Select an element to adjust its highlighting options. Selecting Default Text gives you the option to apply the default settings to other elements.

Foreground and Background Color
To change the color of either of these elements, click the associated color swatch. This opens a drop-down list of 20 basic colors.

To browse even more colors, click Other. This opens the Color window, which allows you to choose a color by selecting it from the rainbow gradient or by manually entering various values associated with the desired color.
Text Attributes
Choose from bold, italic, or underline.

Use Defaults For
Select the Foreground or Background checkboxes if you want to apply the Default Text settings to the selected element.

Font
Select the desired font face from this drop-down list.

Size
Select the desired size from this drop-down list.

Charset
Select your preferred character set from this drop-down list.
Editor Options Window

The Editor Options window allows you to set display preferences for the Code Editor.

Print Options
Select the checkboxes for any of the display preferences you would like to apply when printing a document.

General Options
Select the checkboxes for any of the display preferences you would like to apply in the Code Editor.

Visible Right Margin
Select whether to display a visible right margin and then specify its width in pixels.
Visible Gutter
Select whether to display a visible gutter and then specify its width in pixels. A gutter is a bar to the left of the code where line numbers, bookmarks, and characters that represent line breaks are displayed.

Block Indent Step Size
Number of spaces automatically used to indent the next line of code when nesting elements.

Word Wrap Column
The column at which word wrapping occurs. Enter 0 if you want the word wrap to be set to the width of the window.

Show Word Wrap Column
Select this checkbox if you want to display the word wrap column.

Tab Column
The tab stops within the editing environment.

Tab Stop
The number of spaces the cursor moves when you click the Tab key.
Window Menu

The Window menu allows you to switch between the open files. Selecting one of the files opens it in whichever editor (Code or Visual) is open.

You can also switch between open files using the tabs in the Statusbar at the bottom of the program.
Help Menu

The Help menu allows you to access the different help options available in the program. This includes opening the PDF Help file, accessing information about CoffeeCup Software, and getting support from our fabulous technical support crew.

**View Help File... (F1)**
Opens the Help file. This is your go-to source for everything related to the HTML Editor.

**HTML Editor Help Online...**
Opens the HTML Editor Help page ([http://www.coffeecup.com/html-editor/help/](http://www.coffeecup.com/html-editor/help/)) in your default Web browser. From here, you can watch video tutorials or read knowledgebase articles that answer commonly asked questions about the program.

**Get Support**
Opens the CoffeeCup Software Support Center ([http://www.coffeecup.com/help/](http://www.coffeecup.com/help/)) in your default Web browser. From here, you can get in touch with the CoffeeCup technical support team, who will be happy to help you with any issues you may have.

**Tip of the Day...**
Opens the Tip of the Day window, which displays helpful tips for working with the program.
To navigate the tips, use the Previous and Next buttons. If you do not want to see these tips on startup, uncheck the checkbox next to Show tip of the day on startup.

To re-enable the Tip of the Day window, go to Help > Tip of the Day or use the options under Tools > Preferences > General tab.

About This Software...
Opens a window that provides basic information about the program and CoffeeCup Software.
Toolbar

The Toolbar is located across the top of the program and contains buttons that allow you to quickly access commonly used program features. Right-clicking the toolbar opens this menu:

Unchecking the Main Toolbar (or any custom toolbars that may be listed) removes it from the workspace. It can be re-added by checking it again. Selecting Customize... opens the Customize window, which allows you to customize the main toolbar or create your own.

New
Expands to display a list of options for creating new Webpages.

For detailed tutorials covering the four different ways to create a new Webpage, read Creating a New Webpage.

New From Quick Start...
Opens the Quick Start window, which allows you to define settings for your new page, including the page title, color scheme, meta information, and character set.

New Blank Page (Ctrl+N)
Creates a new page for you to edit from scratch. By default, new pages include some basic HTML to help get you started. This includes the DOCTYPE, html, head, title, meta, and body tags, as well as an HTML comment stating that the page was created with CoffeeCup HTML Editor.

New From Layout...
Opens a window that allows you to choose from several Webpage layouts.
A layout includes the HTML for a basic page structure. You provide the content. If you prefer to work with a page design, select **New From Theme**. For more information about the difference between layouts and themes, read **What is the difference between a layout and a theme?**

**New From Theme...**
Opens a window that allows you to choose from several Webpage themes.
A theme includes three pages (index.html, about-us.html, and contact-us.html) that include the HTML and images for a basic design. You can replace the images and text with your own content. If you prefer to work with a page structure, select New From Layout. For more information about the difference between layouts and themes, read What is the difference between a layout and a theme?

<table>
<thead>
<tr>
<th>Save</th>
<th>Expands to display a list of options for saving your work.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save (Ctrl+S)</td>
<td>Saves the file you are currently working on. We recommend you save frequently to prevent loss in case something happens to your computer while you are working.</td>
</tr>
<tr>
<td>Save As... (Ctrl+Shift+S)</td>
<td>Saves the current file under a different name. This will not overwrite the file you are currently working on; instead, it will create a new file that you can give a different name.</td>
</tr>
<tr>
<td>Save All</td>
<td>Saves all the open files.</td>
</tr>
<tr>
<td>Save Selected Text as Snippet...</td>
<td>Opens the Save Snippet window, which allows you to name and save the highlighted text as a snippet.</td>
</tr>
</tbody>
</table>
After you click OK, the new snippet will be added to the list in the **Code Snippets** tab. For a detailed tutorial about working with snippets, read **How to Use Snippets**.

**Open**
Expands to display a list of options for opening previously created work.

**Open... (Ctrl+O)**
Allows you to open and work with a previously created file.

**Open From Web...**
Opens the **Open From Web** window, which allows you to import an HTML page on the Internet into the HTML Editor. This option works best with HTML pages that do not contain PHP or SSI. These scripts are stored on the server, and sometimes add code to a Webpage that cannot be imported into the HTML Editor.

**Recent Files**
Displays a list of files you have worked with recently, which allows you to access them more quickly.

**Upload File to Server**
Expands to display a list of options for uploading your work.

**Previously Configured Servers**
Select a previously configured server and then select the folder where you would like to upload your file. This opens the **Upload File to Server** window, which displays the status of the upload and closes automatically when the upload is complete.
Add or Edit Servers...
Opens the Server Configuration – Add/Edit window, which allows you to configure a new or existing server profile.

Undo (Ctrl+Z)
Undoes the last action you have performed.

Redo (Ctrl+Q)
Redoes the last action. The Redo function comes in handy when you accidentally use the Undo function or change your mind about undoing an action.

Cut (Ctrl+X)
Removes the selected object or text from the screen and stores it on the Windows clipboard. It is then available to be pasted until something else is cut or copied to the clipboard.

Copy (Ctrl+C)
Makes a copy of the selected object or text and stores that copy on the Windows clipboard. The object is now available to be pasted until another object is cut or copied to the clipboard.

Paste (Ctrl+V)
Takes the object stored on the Windows clipboard and places it on the page. Pasting an object does not remove it from the clipboard, so you can paste the same object as many times as you need.

Find and Replace
Expands to display the find and replace options.

Find... (Ctrl+F)
Opens the Extended Find window, which allows you to search the current document, all open documents, or all the documents in a given folder for a search term.

Replace... (Ctrl+H)
Opens the Extended Find and Replace window, which allows you to search the current document, all open documents, or all the documents in a given folder for a search term, and then replace it with text of your choosing.
Extended Find Results
Displays the Search Results tab at the bottom of the program.

Spelling and Thesaurus
Expands to display the spelling and thesaurus options.

Check Spelling...
Checks the spelling in your document. If there are no spelling errors, you will see a window that says, “The spelling check is complete.”

If there are misspelled words, the Spelling window opens, allowing you to review and change the spelling errors, and to adjust spelling options.

Auto Spell Check
Puts a red underline under any misspelled words.

Thesaurus...
Opens the Thesaurus, which gives you suggestions of synonyms for the selected word.
**Document**
Expands to display document options.

**Document Weight...**
Opens the Document Weight window, which contains information about the size of the currently open document and how long it will take to download to a computer on several different connections.

**Document Dependencies...**
Opens the Document Dependencies window, which lists the background images, items, and external links in your document. You can use this information to keep track of your dependencies and prevent issues like broken links and images.
Document Properties...
Opens the Document Properties window, which lets you change the page title, character set, background image or color, link colors, and color scheme.

Validate HTML...
Opens http://validator.w3.org/ in your default Web browser. You can validate the HTML of pages you have already published to your server, or you can upload the files to this site and check them before uploading. For more information about using this tool, refer to the site's documentation (http://validator.w3.org/about.html).

Preferences
Opens the Preferences window, which allows you to work with the program preferences, including working with the appearance and function of the program, setting file types the program can open, adding browsers and external applications, setting default folders, and customizing highlighting and toolbar options.
Applications
Expands to show a list of other applications you can open from within the HTML Editor.

To add external applications, go to Tools > Preferences > Applications tab.

Search
Allows you to enter a search term and search for it in the open document. Use the **up** and **down** arrows to view the previous and next iterations of the search term.
Code Editor

The Code Editor allows you to view and edit the code that makes up your page. It can be used to edit HTML, server files such as PHP and CSS, and text. For a complete list of file types the program can open and to enter additional file types, go to Tools > Preferences > Files tab.

To add or edit code, just type it in! There are also a number of useful tools to help you code your page more quickly and efficiently. They can be accessed in the Menu Bar or using either of the following options:

- Code Editor toolbar
- Code and Visual Editor right-click menu
- Special features in the Code Editor
Code Editor Toolbar

The Code Editor toolbar is located across the top of the Code Editor and contains buttons that allow you to quickly access commonly used features. Right-clicking the toolbar opens this menu:

Unchecking the Main Toolbar (or any custom toolbars that may be listed) removes it from the workspace. It can be re-added by checking it again. Selecting Customize... opens the Customize window, which allows you to customize the main toolbar or create your own.

**Image (Ctrl+M)**

Opens the Insert Image window, which allows you to insert an image and any associated attributes, as well as create a thumbnail version of the image.

You can also add an image by dragging it from the My Websites or My Computer tab into the Code or Visual editor.

**Links**

Expands to display link options.

**Link... (Ctrl+L)**

Opens the Insert Link window, which allows you to insert a link and any associated attributes.

**E-mail Link... (Ctrl+E)**

Opens the Insert E-mail Link window, which allows you to insert an e-mail link and any associated attributes.
**Fonts**
Expands to display font options.

**Font Wizard...**
Opens the Font Wizard, which allows you to choose the attributes for a font tag.

**Font Sizes**
Select from font sizes 1 (8 pt) to 7 (36 pt) or adjust the size up or down one increment.

**Font Color...**
Opens the Color window, which allows you to choose a color by selecting it from the rainbow gradient or by manually entering various values associated with the desired color.

**Font Effects**
Allows you to apply one of the provided effects to your font.
Header Sizes
Select a header tag (<h1>–<h6>), and it will be inserted into your document or applied to any selected text.

Paragraph (Ctrl+Enter)
Inserts paragraph tags (<p></p>) tags or applies them to selected text.

Break
Inserts a break tag (<br/>).

Non-Breaking Space
Inserts a non-breaking space character entity (&nbsp;), which is rendered by browsers as a space. This can be used to insert extra spaces, since HTML only allows for one space between each word.

Bold (Ctrl+B)
Inserts bold tags (<b></b>) or applies them to selected text.

Italic (Ctrl+I)
Inserts italic tags (<i></i>) or applies them to selected text.

Underline (Ctrl+U)
Inserts underline tags (<u></u>) or applies them to selected text.

Left
Inserts a div tag with the align attribute set to left (<div align="left"></div>) or applies it to the selected text.
**Center**
Inserts a div tag with the align attribute set to center (<div align="center"></div>) or applies it to the selected text.

**Right**
Inserts a div tag with the align attribute set to right (<div align="right"></div>) or applies it to the selected text.

**Justify**
Inserts a div tag with the align attribute set to justify (<div align="justify"></div>) or applies it to the selected text. This aligns your text so each line is the same length.

**Horizontal Rule**
Opens the Insert Horizontal Rule window, which allows you to design a horizontal rule and add it to your page.

**Table Items**
Expands to display table options.

**Table Designer...**
Opens the Table Designer, which allows you to create a table. A table can be used to display information or as your page layout.

**Quick Table...**
Opens the Quick Table window, which allows you to design a table.
Drag your mouse over the squares to pick how many columns and rows are in your table. Click when you have specified the desired dimensions, and the code will be inserted on your page.

**Form Items**
Expands to display form options.

For comprehensive information about creating and modifying HTML forms, read the W3Schools tutorial [HTML Forms and Input](http://www.w3schools.com/html/html_forms.asp).
Get CoffeeCup Form Builder
Opens the CoffeeCup Web Form Builder page (http://www.coffeecup.com/form-builder/) in your default Web browser. This program simplifies the process of adding Web forms to your Website.

Insert Form...
Opens the Insert Form window, which allows you to set the form method, MIME post method, and URL where the form results will be directed. This information is important if you want your form to work properly!

Drop-Down List...
Opens the Insert Drop-Down List window, which allows you to configure the contents of a drop-down list.

Enter the options you would like to display in the Item field, and enter the values you would like to appear in the form results in the Value field. The Name appears in the form results, and the Alignment options control where the element appears on the page.

A drop-down list is a bar with an arrow that expands to show a list when clicked. It is best suited for lists in which your user can only select one option. The drop-down list configured above renders like this:
List Box...
Opens the Insert List Box window, which allows you to configure the contents of a list box.

Enter the options you would like to display in the Item field, and enter the values you would like to appear in the form results in the Value field. The Name appears in the form results, and the Alignment options control where the element appears on the page.

A list is a text box containing a list of items that your user can select, and is best suited for lists in which your user can select several options. The list box configured above renders like this:
Radio Button Group...
Opens the Insert Radio Button Group window, which allows you to configure a radio button group. Radio buttons must be grouped in order to work correctly.

Enter the options you would like to display in the Item field, and enter the values you would like to appear in the form results in the Value field. The Name appears in the form results, and the Alignment options control where the element appears on the page.

Checkbox
Inserts the code for a checkbox, which is a square box that can be selected and deselected, and is best suited for lists in which your user can select one or more answers. A checkbox looks like this:

Radio Button
Inserts the code for a radio button, which is a round button that your user can select but only deselect by selecting another option. They are best suited for lists in which your user can only select one answer. A radio button looks like this:
**Image**
Inserts the code for a form image. This is particularly helpful if you want to add custom buttons to your form.

**Text Box**
Inserts the code for a text box, which is a one-line field where your user can type information, and is best suited for short answers, such as name, e-mail address, phone number, etc. A text box looks like this:

![Text box example](image)

**Password Text Box**
Inserts the code for a password text box, which is a one-line field where your user can type a password. All the characters are disguised as asterisks.

![Password text box example](image)

**Hidden Text**
Inserts the code for hidden text, which appears in your copy of the form results and can be used for sorting and filtering information.

**File Browse Text Box**
Inserts the code for a file browse text box, which is used to browse your computer for a file. This file will be uploaded when the form is submitted.

**Text Area**
Inserts the code for a text area, which is a multiple-line field where your user can type information, and is best suited for longer answers, such as messages, feedback, etc. A text area looks like this:

![Text area example](image)

**Button**
Inserts the code for a generic “Submit Query” button.
Submit Button
Inserts the code for a submit button.

Reset Button
Inserts the code for a reset button.

List
Opens the Insert List window, which allows you to insert or import one of four different kinds of lists: bulleted, numbered, definition, or unformatted.

Style Sheet Items
Displays a list of options that let you insert various style sheet items.

For comprehensive information about creating and modifying style sheets, read the W3Schools tutorial CSS Introduction (http://www.w3schools.com/css/css_intro.asp).

Style Sheet Wizard...
Opens the Style Sheet window, which allows you to choose between creating a new style sheet class and applying a style sheet to a preexisting HTML tag.

After you make your choice, you will be taken to the Style Sheet Wizard, which allows you to set the various options for your style sheet.

Style Sheet Attribute Wizard...
Opens the Style Sheet Wizard, which allows you to set the various options for your style sheet.

CSS Menu Designer
Opens the CoffeeCup CSS Menu Designer, which allows you to design a CSS menu.
**Color**

This button opens the **Color window**, which allows you to choose a color by selecting it from the rainbow gradient or by manually entering various values associated with the desired color. The hex code for this color will be added wherever the cursor is positioned on the page.

---

**Edit Display**

Expands to display program display options.

**Toggle Word Wrap**

Select this option if you would like your text to automatically wrap to fit the Code Editor workspace.

**Toggle Gutter**

Enables the gutter, which is a bar to the left of the code where line numbers, bookmarks, and characters that represent line breaks are displayed.
Toggle Line Numbers
Turns on line numbers in the gutter.

Split-Screen Preview (F12)
Enables split-screen preview, which allows you to preview your work in an Internet Explorer browser area below the Code Editor.

To view your work in other browsers, use the Preview tool. It's good Web design practice to test your Website in several different browsers to ensure cross-browser compatibility. The most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari.
Test in Browser
Expands to display browser-testing options.

Test With Default Browser (Ctrl+F9)
Opens your Website in the browser you have set as your default browser. This is done outside of the HTML Editor.

Test with Favorite Browser (Ctrl+F5)
Opens the page in the browser specified the first slot in the Browser Testing tab.

Additional Browsers
Expands to show a list of other browsers you can use to preview your Website.

To configure additional browsers, go to Tools > Preferences > Browser Testing tab. It's good Web design practice to test your Website in several different browsers to ensure cross-browser compatibility. The most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari.
Split-Screen Preview (F12)
Enables split-screen preview, which allows you to preview your work in a browser area below the Code Editor.

To view your work in other browsers, use the Preview tool. It's good Web design practice to test your Website in several different browsers to ensure cross-browser compatibility. The most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari.

Upload File to Server
Expands to display a list of options for uploading your work.

Previously Configured Servers
Select a previously configured server and then select the folder where you would like to upload your file. This opens the Upload File to Server window, which displays the status of the upload and closes automatically when the upload is complete.
Add or Edit Servers...
Opens the Server Configuration – Add/Edit window, which allows you to configure a new or existing server profile.
Special Features in the Code Editor

There are a few special features in the Code Editor that help make it easier to code your documents by hand.

**Code Completion**
Typing a tag, tag attribute, or attribute value opens a list of (X)HTML entities that match the letters you have typed.

You can use your mouse or the **arrow** keys on your keyboard to select the tag, tag attribute, or attribute value you want to use, and it will be inserted into your document. Selecting a tag inserts the opening and closing tags, which prevents unclosed tags.

To customize which (X)HTML entities appear in the **Code Completion** list, go to **Edit > Edit XHTML Tags**. This opens the **Edit XHTML Tags window**, which allows you to add, modify, or delete (X)HTML tags, attributes, and attribute values. For a detailed tutorial that outlines this process, read **Customizing Code Completion Tags**.

**Syntax Highlighting**
When you look at the Code Editor workspace, you will notice that different parts of the code are different colors.
This is called syntax highlighting, and it is a useful way to tell different tags, tag attributes, and tag values apart. For example, it may be difficult or time-consuming to try to find every instance of an `<img>` tag, but if you set your highlighting options to make all `<img>` tags red, then all you’d have to do is look for the color red.

To customize your syntax highlighting options, go to Tools > Document Display Properties. Select the language whose syntax highlighting color scheme you want to change, and then click the Modify Highlighting button. This opens the Highlighting Options window, which allows you to create or modify the highlighting color scheme.
Visual Editor

The Visual Editor allows you to work directly with the elements in your page in a WYSIWYG (What You See Is What You Get) environment.

To work with your page elements, simply select them with your mouse and drag and drop them to the desired location. (You may need to use the Move and Unlock Object icon to enable this feature.) There are also a number of useful tools to help you work with your page more quickly and efficiently. They can be accessed in the Menu Bar or using either of the following options:

- Visual Editor toolbar
- Code and Visual Editor right-click menu
- Working with tables in the Visual Editor

If you cannot see the Visual Editor, it may not be enabled. To turn it on, go to Tools > Preferences > General tab and unselect the Hide Visual Editor tab checkbox.
Visual Editor Toolbar

The Visual Editor toolbar is located across the top of the Visual Editor and contains buttons that allow you to quickly access commonly used features. Right-clicking the toolbar opens this menu:

Unchecking the Main Toolbar (or any custom toolbars that may be listed) removes it from the workspace. It can be re-added by checking it again. Selecting Customize… opens the Customize window, which allows you to customize the main toolbar or create your own.

*Insert and Move Text*

Inserts the words “Your Text Here” into the Visual Editor. You can replace this message with your own text.

*Edit Element Source*

Opens the Edit Element Source window, which allows you to work with the HTML for the selected object.
Move and Unlock Object
Unlocks the object from its current position, which allows you to drag and drop it to the desired location on the page.

Image (Ctrl+M)
Opens the Insert Image window, which allows you to insert an image and any associated attributes, as well as create a thumbnail version of the image.

You can also add an image by dragging it from the My Websites or My Computer tab into the Code or Visual editor.

Links
Expands to display link options.

Link… (Ctrl+L)
Opens the Insert Link window, which allows you to insert a link and any associated attributes.

E-mail Link… (Ctrl+E)
Opens the Insert E-mail Link window, which allows you to insert an e-mail link and any associated attributes.

Fonts
Expands to display font options.

Font Wizard…
Opens the Font Wizard, which allows you to choose the attributes for a font tag.

Font Sizes
Select from font sizes 1 (8 pt) to 7 (36 pt) or adjust the size up or down one increment.

Font Color…
Opens the Color window, which allows you to choose a color by selecting it from the rainbow gradient or by manually entering various values associated with the desired color.
Font Effects
Allows you to apply one of the provided effects to your font.

Header Sizes
Select a header size (1-6) and it will applied to the selected text or any text typed after the current cursor position.
Paragraph (Ctrl+Enter)
Creates a new paragraph.

Break
Inserts a line break.

Bold (Ctrl+B)
Bolds the selected text or any text typed after the current cursor position.

Italic (Ctrl+I)
Italicizes the selected text or any text typed after the current cursor position.

Underline (Ctrl+U)
Underlines the selected text or any text typed after the current cursor position.

Left
Left-aligns the selected text or any text typed after the current cursor position.

Center
Centers the selected text or any text typed after the current cursor position.

Right
Right-aligns the selected text or any text typed after the current cursor position.

Justify
Justifies the selected text or any text typed after the current cursor position. This aligns your text so each line is the same length.

Horizontal Rule
Opens the Insert Horizontal Rule window, which allows you to design a horizontal rule and add it to your page.

List
Opens the Insert List window, which allows you to insert or import one of four different kinds of lists: bulleted, numbered, definition, or unformatted.
**Visual Table Elements**
Expands to display visual table options.

![](image)

**Table Designer...**
Opens the **Table Designer**, which allows you to create a table. A table can be used to display information or as your page layout.

**Quick Table...**
Opens the **Quick Table** window, which allows you to design a table.
Drag your mouse over the squares to pick how many columns and rows are in your table. Click when you have specified the desired dimensions, and the code will be inserted on your page.

**Toggle Invisible Grid Lines**
Displays table borders if they are set to 0. This is purely for design purposes and will not be rendered in a Web browser.

**Insert Column**
 Inserts a column into the table.

**Insert Row**
 Inserts a row into the table.

**Delete Column**
 Deletes the column where the cursor is positioned or the selected column(s).

**Delete Row**
 Deletes the row where the cursor is positioned or the selected row(s).

**Merge Cells**
This option is only available in the **Table Designer**.

**Split Cell**
 Splits the cell in half.

**Preview**
 Expands to display preview options.
Test With Default Browser (Ctrl+F9)
Opens your Website in the browser you have set as your default browser. This is done outside of the HTML Editor.

Test with Favorite Browser (Ctrl+F5)
Opens the page in the browser specified the first slot in the Browser Testing tab in the Preferences window.

Additional Browsers
Expands to show a list of other browsers you can use to preview your Website.

To configure additional browsers, go to Tools > Preferences > Browser Testing tab. It's good Web design practice to test your Website in several different browsers to ensure cross-browser compatibility. The most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari.

Upload File to Server
Expands to display a list of options for uploading your work.
Previously Configured Servers
Select a previously configured server and then select the folder where you would like to upload your file. This opens the **Upload File to Server** window, which displays the status of the upload and closes automatically when the upload is complete.

Add or Edit Servers...
Opens the **Server Configuration – Add/Edit window**, which allows you to configure a new or existing server profile.

**Color**
This button is only enabled in the **Code Editor**.
The right-click menu allows you to access commonly used features in the Code and Visual editors.

**Cut (Ctrl+X)**
Removes the selected object or text from the screen and stores it on the Windows clipboard. It is then available to be pasted until something else is cut or copied to the clipboard.

**Copy (Ctrl+C)**
Makes a copy of the selected object or text and stores that copy on the Windows clipboard. The object is now available to be pasted until another object is cut or copied to the clipboard.

**Paste (Ctrl+V)**
Takes the object stored on the Windows clipboard and places it on the page. Pasting an object does not remove it from the clipboard, so you can paste the same object as many times as you need.

**Select All (Ctrl+A)**
Selects everything in the workspace. This is helpful if you want to copy, cut, or delete many objects at a time instead of having to select them all individually.
**Move Text (Visual Editor Only)**
Moves any selected text into its own text box, which allows you to drag and drop it to another location.

**Move and Unlock Object (Visual Editor Only)**
Unlocks the object from its current position, which allows you to drag and drop it to the desired location on the page.

**Edit Element Source... (Visual Editor Only)**
Opens the Edit Element Source window, which allows you to work with the HTML for the selected object.

![Edit Element Source](image)

**Find... (Ctrl+F)**
Opens the Extended Find window, which allows you to search the current document, all open documents, or all the documents in a given folder for a search term.

**Replace... (Ctrl+H)**
Opens the Extended Find and Replace window, which allows you to search the current document, all open documents, or all the documents in a given folder for a search term, and then replace it with text of your choosing.

**Undo (Ctrl+Z)**
Undoes the last action you have performed.
**Redo (Ctrl+Q)**
Redoes the last action. The Redo function comes in handy when you accidentally use the Undo function or change your mind about undoing an action.

**Save (Ctrl+S)**
Saves the file you are currently working on. We recommend you save frequently to prevent loss in case something happens to your computer while you are working.

**Save As... (Shift+Ctrl+S)**
Saves the current file under a different name. This will not overwrite the file you are currently working on; instead, it will create a new file that you can give a different name.

**Save Selected Text as Snippet...**
Opens the Save Snippet window, which allows you to name and save the highlighted text as a snippet.

After you click OK, the new snippet will be added to the list in the Code Snippets tab. For a detailed tutorial about working with snippets, read How to Use Snippets.

**Test in Browser**
Expands to display browser-testing options.
Test With Default Browser (Ctrl+F9)
Opens your Website in the browser you have set as your default browser. This is done outside of the HTML Editor.

Test with Favorite Browser (Ctrl+F5)
Opens the page in the browser specified the first slot in the Browser Testing tab.

Additional Browsers
Expands to show a list of other browsers you can use to preview your Website.

To configure additional browsers, go to Tools > Preferences > Browser Testing tab. It's good Web design practice to test your Website in several different browsers to ensure cross-browser compatibility. The most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari.

Upload File to Server
Expands to display a list of options for uploading your work.
Previously Configured Servers
Select a previously configured server and then select the folder where you would like to upload your file. This opens the **Upload File to Server** window, which displays the status of the upload and closes automatically when the upload is complete.

![Upload File to Server window](image)

Add or Edit Servers...
Opens the **Server Configuration – Add/Edit window**, which allows you to configure a new or existing server profile.

Font
Expands to display font options.

---

Font Wizard...
Opens the **Font Wizard**, which allows you to choose the attributes for a font tag.

Font Sizes
Select from font sizes 1 (8 pt) to 7 (36 pt) or adjust the size up or down one increment.
Font Color...
Opens the Color window, which allows you to choose a color by selecting it from the rainbow gradient or by manually entering various values associated with the desired color.

Font Effects
Allows you to apply one of the provided effects to your font.

Header Sizes
Select a header tag (h1-h6), and it will be inserted into your document or applied to any selected text.
**Links**
Expands to display link options.

![Image of links button]

**Link... (Ctrl+L)**
Opens the **Insert Link** window, which allows you to insert a link and any associated attributes.

**E-mail Link... (Ctrl+E)**
Opens the **Insert E-mail Link** window, which allows you to insert an e-mail link and any associated attributes.

**Image...**
Opens the **Insert Image** window, which allows you to insert an image and any associated attributes, as well as create a thumbnail version of the image.

You can also add an image by dragging it from the **My Websites** or **My Computer** tab into the **Code** or **Visual** editor.

**Color...**
This button opens the **Color window**, which allows you to choose a color by selecting it from the rainbow gradient or by manually entering various values associated with the desired color. The hex code for this color will be added wherever the cursor is positioned on the page.
Spelling and Thesaurus
Expands to display spelling and thesaurus options.

Check Spelling...
Checks the spelling in your document. If there are no spelling errors, you will see a window that says, “The spelling check is complete.”
If there are misspelled words, the **Spelling window** opens, allowing you to review and change the spelling errors, and to adjust spelling options.

**Spell Checker Options...**
Opens the **Spelling Options window**, which allows you to adjust your spelling options and add custom dictionaries.

**Auto Spell Check**
Puts a red underline under any misspelled words.

**Thesaurus...**
Opens the **Thesaurus**, which gives you suggestions of synonyms for the selected word.

![Thesaurus Window]

**Close**
Closes the current file you have open, but leaves the program open.
Working With Tables in the Visual Editor

When you select a table in the Visual Editor, a pane appears at the bottom of the screen displaying options for modifying your table.

You can also design a table using the Table Designer. To access it, go to Insert > Table Designer.

Horizontal and Vertical Alignment
Select the horizontal and vertical alignment for the text in the selected cell.

Width and Height
Enter the width and height in pixels of the selected cell.

No Wrap
Select this checkbox if you do not want the text in the selected cell to automatically wrap to fit the width of the cell.

BG Color
Opens the Color window, which allows you to choose a color by selecting it from the rainbow gradient or by manually entering various values associated with the desired color.
No BG Color
Removes the background color.

Border Color
Opens the Color window, which allows you to choose a color by selecting it from the rainbow gradient or by manually entering various values associated with the desired color. The hex code for this color will be added wherever the cursor is positioned on the page.

No Border Color
Removes the border color.
Preview Tab

The Preview tab is a built-in browser (Internet Explorer) you can use to preview your Website.

To configure additional browsers, go to **Tools > Preferences > Browser** Testing tab. It’s good Web design practice to test your Website in several different browsers to ensure cross-browser compatibility. The most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari.

Since the Preview tab is powered by Internet Explorer, its right-click menu is the same as the right-click menu for the browser. For more information about how to use the options in the right-click menu, consult Internet Explorer’s documentation ([http://windowshelp.microsoft.com/Windows/en-US/internet-explorer.mspx](http://windowshelp.microsoft.com/Windows/en-US/internet-explorer.mspx)).

- Preview toolbar
Preview Toolbar

The Preview toolbar is located across the top of the Preview tab and contains buttons that allow you to quickly access commonly used features. Right-clicking the toolbar opens this menu:

Unchecking the **Main Toolbar** (or any custom toolbars that may be listed) removes it from the workspace. It can be re-added by checking it again. Selecting **Customize...** opens the **Customize window**, which allows you to customize the main toolbar or create your own.

**Back**
Takes you to the previously viewed page.

**Forward**
Takes you to the page you navigated back from.

**Stop**
Stops the page from loading.

**Refresh**
Reloads the content of the page.
**Test in Browser**
Expands to display browser-testing options.

**Test With Default Browser (Ctrl+F9)**
Opens your Website in the browser you have set as your default browser. This is done outside of the HTML Editor.

**Test with Favorite Browser (Ctrl+F5)**
Opens the page in the browser specified the first slot in the Browser Testing tab.

**Additional Browsers**
Expands to show a list of other browsers you can use to preview your Website.

To configure additional browsers, go to Tools > Preferences > Browser Testing tab. It's good Web design practice to test your Website in several different browsers to ensure cross-browser compatibility. The most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari.
**StatusBar**

The Statusbar is located at the bottom of the program, and allows you to switch between open documents and view basic information about the open file.

**File Tabs**

To switch between open documents, click the tab with the filename of the desired document.

To close a file from one of these tabs, right-click it. This opens a right-click menu that allows you to close the tab.

**File Path**

Holding your mouse over a file in the My **Computer** tab displays the full file path in the Statusbar.

**Line, Column, and Save Status**

The right-hand side of the Statusbar displays the line and column where the cursor is currently positioned. It also lets you know if your file is saved or unsaved.
Tag Information
When your cursor is positioned within an (X)HTML tag or CSS property, a list of valid attributes will appear in the Statusbar.

To access these attributes, start typing the one you want to use, or type a space. This opens the Code Completion list, which contains the available attributes you can use.
Resource Browser

The Resource browser is located on the left-hand side of the program. It is used to access Website Projects, code snippets, tags, and special characters. You can expand or collapse it using the arrow icon at the top.

- My Websites tab
  - Local Disk tab
    - Local Disk right-click menu
  - Server tab
    - Server right-click menu
  - My Websites toolbar
- My Computer tab
  - My Computer toolbar
  - My Computer right-click menu
- Code Snippets tab
  - Code Snippets toolbar
  - Code Snippets and Tags right-click menu
- Tags tab
  - Tags toolbar
  - Code Snippets and Tags right-click menu
- Characters tab
My Websites Tab

The My Websites tab is where you organize and work with your Website Projects.

For more information about using Website Projects, read Working With Website Projects.

- Local Disk tab
  - Local Disk right-click menu
- Server tab
  - Server right-click menu
- My Websites toolbar
Local Disk Tab

The Local Disk tab is where you work with the Website Project files saved on your computer. You can view the structure of your Website Project and edit the files using the My Websites toolbar or the Local Disk right-click menu.

To change which types of files display in the Local Disk tab, select the desired file type from the drop-down list at the bottom.
Another feature that appears at the bottom of the tab is an image preview that appears when an image is selected in the Local Disk tab.

- Local Disk right-click menu
- My Websites toolbar
Local Disk Right-Click Menu

Right-clicking the Local Disk tab opens a menu that allows you to work with the Website Project or the selected file.

**Insert as Link Into Current Document**
Inserts the selected file into the current document as a relative link.

You can also add a link to a document by dragging the document from the My Websites or My Computer tab into the Code or Visual editor. This opens a window asking if you want to insert the document or page as a link or if you want to open it in another tab for editing.

**Insert Image Into Current Document**
Inserts the selected image into the current document with an `<img>` tag.

You can also add an image by dragging it from the My Websites or My Computer tab into the Code or Visual editor.

**Open in Associated Application**
Opens the selected file in the associated application. For instance, if you selected a PDF, it would open in Adobe Acrobat.

**Edit**
Opens the selected file in a new tab.

**Rename**
Allows you to rename the selected file.

**Delete...**
Deletes the selected file.
**Create Folder**
Creates a new folder.

**Move File/Folder to Website Project**
Allows you to move the selected file to a different location within the Website Project.

**Upload Selected Files**
Uploads the selected file to the server specified in the Website Project Settings window.

⚠️ You can only assign one server per Website Project. If you want to upload any or all of your Website Project files to a different server than the one specified in this field, you have two options:

1. Go to My Websites > Website Project Settings, switch the server, and then upload the file(s).
2. Go to the My Computer tab, right-click the file(s) you want to publish, and select the server and folder where you want to upload them. If any of your published documents reference these files, the path to the files you are uploading must match the path specified in your HTML code.

**File Properties...**
Opens the Windows properties window for the selected file, which provides basic information about the file.
Server Tab

The Server tab is where you work with the Website Project files saved on your server. You can view the structure of your Website Project and edit the files using the My Websites toolbar or the Server right-click menu.

Additionally, you can click the Show FTP Log link at the bottom to view a log of your FTP activity in the Code Editor. This information can be useful if you experience issues when connecting or uploading.

- Server right-click menu
- My Websites toolbar
Server Right-Click Menu

Right-clicking a file in the Server tab opens a menu that allows you to work with the selected file.

**Edit**
Opens the selected file in a new tab. Saving the file saves it directly to the server.

**Download to [Website Project Path]**
Downloads the selected file to the main folder in your Website Project. Once you have downloaded it, you can move it to the desired folder.

**Rename**
Allows you to rename the selected file.

**Delete...**
Deletes the selected file.

**Create Folder**
Creates a new folder.

**File Properties...**
Opens a window that provides basic information about the file, including its name, size, and date it was first created.
My Websites Toolbar

The My Websites toolbar is located across the top of the My Websites tab and contains buttons that allow you to quickly access commonly used features. Right-clicking the toolbar opens this menu:

Unchecking the Main Toolbar (or any custom toolbars that may be listed) removes it from the workspace. It can be re-added by checking it again. Selecting Customize… opens the Customize window, which allows you to customize the main toolbar or create your own.

Website Projects
Expands to display Website Project options.

New Website Project…
Opens the Website Project Settings window, which lets you create a blank Website Project or to create a Website Project from existing files. You can also enter additional information, such as your server settings, and select your file upload options.

Open Website Project…
Allows you to open and work with a previously created Website Project.

Close Website Project
Closes the current Website Project you have open, but leaves the program open.

All Website Projects
Opens a list of all the Website Projects you have created, which allows you to access these Website Projects more quickly.
Remove Website Project
Removes the selected Website Project from the HTML Editor. The file will not be deleted from your computer.

Website Project Settings...
Opens the Website Project Settings window, which allows you to edit the settings for the current Website Project.

Tools
Expands to display upload and dependencies options.

You can only assign one server per Website Project. If you want to upload any or all of your Website Project files to a different server than the one specified in this field, you have two options:

1. Go to My Websites > Website Project Settings, switch the server, and then upload the file(s).
2. Go to the My Computer tab, right-click the file(s) you want to publish, and select the server and folder where you want to upload them. If any of your published documents reference these files, the path to the files you are uploading must match the path specified in your HTML code.

Upload Entire Website Project
Uploads the entire Website Project to your server. You will need to set up a server profile in order to perform this action.

Upload Selected Files
Uploads the currently selected Website Project files to your server. The file structure is preserved during the upload. For example, if you upload an image called image.png that is located in a folder called images, image.png will be uploaded into the images folder on the server. If there is no images folder on the server, it will be created during the upload process.

You will need to set up a server profile in the Website Project Settings window in order to upload your files.

Check Website Project Dependencies
Displays the Document Dependencies tab at the bottom of the program.
My Computer Tab

The My Computer tab allows you to view and edit files on your computer, add them to your Website Project or Working folder, and edit them in the Editor. It is divided into two sections. The top section allows you to browse files and folders on your computer. You can do so by clicking through folders and using the options in the My Computer toolbar.

Selecting a folder opens its contents in the bottom section. You can work with these files using the My Computer right-click menu.

To change which types of files display in the My Computer tab, select the desired file type from the drop-down list at the bottom.
• My Computer toolbar
• My Computer right-click menu
My Computer Toolbar

The My Computer toolbar is located across the top of the My Computer tab and contains buttons that allow you to quickly access commonly used features in the My Computer tab. Right-clicking the toolbar opens this menu:

Unchecking the Main Toolbar (or any custom toolbars that may be listed) removes it from the workspace. It can be re-added by checking it again. Selecting Customize... opens the Customize window, which allows you to customize the main toolbar or create your own.

- Desktop
  Opens the Desktop in the file browser.

- Up One Folder
  Moves up one folder from the selected folder in the file browser.

- Refresh
  Refreshes the content in the My Computer tab. If you have recently added a file and it does not appear, try refreshing this area.

- Go to Working Folder
  Opens your Working folder in the file browser. If you are using a Website Project, by default, the Working folder is the same as the Website Projects folder. Otherwise, the Working folder is where you save your Website files.
My Computer Right-Click Menu

Right-clicking a file in the bottom section of the My Computer tab opens a menu that allows you to work with the selected file.

**Insert as Link Into Current Document**
Inserts the selected file into the current document as a relative link.

You can also add a link to a document by dragging the document from the My Websites or My Computer tab into the Code or Visual editor. This opens a window asking if you want to insert the document or page as a link or if you want to open it in another tab for editing.

**Insert Image Into Current Document**
Inserts the selected image into the current document with an `<img>` tag. The program uses a relative link, so if the file is not located in your Website Project or Working folder, it may not display correctly on your Website.

You can also add an image by dragging it from the My Websites or My Computer tab into the Code or Visual editor.

**Insert Sound Into Current Document**
Inserts the selected sound into the current document with a `<bgsound>` tag. The program uses a relative link, so if the file is not located in your Website Project or Working folder, it may not display correctly on your Website.

**Copy File to Project**
Expands to display a list of folders in the currently open Website Project.
Select the folder where you would like the file to be stored, and a copy of the file will be created in that folder.

**Open in Editor**
Opens the selected file in a new tab in the Editor.

**Convert Image Format...**
Allows you to convert the format of the image. We recommend using .gif, .jpg, or .png image files.

**Open in Associated Application**
Opens the selected file in the associated application. For instance, if you selected a PDF, it would open in Adobe Acrobat.

**Upload File to Server**
Expands to display a list of options for uploading your work.

** Previously Configured Servers**
Select a previously configured server and then select the folder where you would like to upload your file. This opens the Upload File to Server window, which displays the status of the upload and closes automatically when the upload is complete.
Add or Edit Servers...
Opens the Server Configuration – Add/Edit window, which allows you to configure a new or existing server profile.

Copy
 Makes a copy of the selected file and stores that copy on the Windows clipboard. The file is now available to be pasted until another object is cut or copied to the clipboard.

Cut
 Removes the selected file and stores it on the Windows clipboard. It is then available to be pasted until something else is cut or copied to the clipboard.

Delete
 Removes the selected file(s).

Paste
 Takes the file stored on the Windows clipboard and places it in the folder. Pasting a file does not remove it from the clipboard, so you can paste the same file as many times as you need. In order for this function to work, you must click in an area outside of any other files.

Move
 Opens a window that allows you to move the file to a different location your computer.
**Rename**
Allows you to rename the selected file.

**Create Folder**
Creates a new folder.

**Views**
Displays a list of options for how the files under the *My Computer* tab in the *Resource* browser can be displayed: as icons, a list, details, small icons, or thumbnails. The following keyboard shortcuts can be used to access these options:

- **Icons** – Shift+Ctrl+F4
- **List** – Shift+Ctrl+F5
- **Details** – Shift+Ctrl+F7
- **Small Icons** – Shift+Ctrl+F8
- **Thumbnails** – Shift+Ctrl+F9
Code Snippets Tab

The Code Snippets tab contains the predefined code snippets that come with the program, as well as any snippets you may have added.

To add a snippet to your page, double-click it or drag and drop it into the Code Editor.

- Code Snippets toolbar
- Code Snippets and Tags right-click menu
Code Snippets Toolbar

The Code Snippets toolbar contains buttons that you can click to perform certain commonly used actions quickly. Right-clicking the toolbar opens this menu:

Unchecking the **Main Toolbar** (or any custom toolbars that may be listed) removes it from the workspace. It can be re-added by checking it again. Selecting **Customize**... opens the **Customize window**, which allows you to customize the main toolbar or create your own.

**Refresh**
Refreshes the content in the Code Snippets tab. If you have recently added a snippet and it does not appear, try refreshing this area.

**Insert Item Into Current Document**
Inserts the selected code snippet into the **Code Editor**.

You can also add a snippet by double-clicking it or dragging and dropping it into the Code Editor.

**Edit Snippet**
Opens the code snippet in its own tab in the HTML Editor workspace, which allows you to edit it.

**New Snippet**
Opens a new blank tab in the HTML Editor workspace, which allows you to enter the code for a new snippet.
Tags Tab

The Tags tab contains lists of the most commonly used HTML, PHP, and CSS tags. To add a tag to your page, double-click it or drag and drop it into the Code Editor.

To customize which (X)HTML entities appear in the Code Completion list, go to Edit > Edit XHTML Tags. This opens the Edit XHTML Tags window, which allows you to add, modify, or delete (X)HTML tags, attributes, and attribute values. For a detailed tutorial that outlines this process, read Customizing Code Completion Tags.

- Tags toolbar
- Code Snippets and Tags right-click menu
Tags Toolbar

The Tags toolbar allows you to select which group of tags is displayed. Right-clicking the toolbar opens this menu:

Unchecking the **Main Toolbar** (or any custom toolbars that may be listed) removes it from the workspace. It can be re-added by checking it again. Selecting **Customize...** opens the **Customize window**, which allows you to customize the main toolbar or create your own.

**HTML Tags**
Displays a list of the most commonly used HTML tags.

**PHP Tags**
Displays a list of the most commonly used PHP tags.

**CSS Tags**
Displays a list of the most commonly used CSS tags.
Code Snippets and Tags Right-Click Menu

Right-clicking the Code Snippets or Tags tab opens a menu that allows you to work with the selected tag or code snippet.

Only the **Insert Item Into Current Document** option works in both tabs.

**New Snippet (Code Snippet Tab Only)**
Opens a new blank tab in the HTML Editor workspace, which allows you to enter the code for a new snippet.

**Delete Snippet (Code Snippet Tab Only)**
Deletes the selected snippet.

**Insert Item Into Current Document**
Inserts the selected tag or code snippet into the **Code Editor**.

You can also add a tag to your page by double-clicking it or dragging and dropping it into the **Code Editor**.

**Open in New Window (Code Snippet Tab Only)**
Opens the code snippet in its own tab in the HTML Editor workspace, which allows you to view or edit it.
Characters Tab

The Characters tab displays a list of HTML entities for commonly used special characters.

To add an HTML entity to your page, double-click it or drag and drop it into the Code Editor.
Working With Website Projects

We cannot stress enough how important Website Projects are. If used correctly, this tool can make broken links a thing of the past. You’ll never see those pesky red X’s instead of your images again. Your Website’s structure will be organized and intuitive. You’ll rule the world!

Okay, you won’t rule the world, but you will save yourself a ton of headaches. So, how exactly does this awesome tool work? This question actually has a really lengthy answer. We’ll go over the basics here, but you should also check out a valuable guide built right into the HTML Editor. Go to My Websites > All Website Projects > What is a Website Project. This opens a comprehensive document that will answer all your questions about using Website Projects. Better yet, it actually is a Website Project, so you’ll get to see firsthand how they work.

Okay, let’s dive right in!

**Step 1: Creating a Website Project**
To create a new Website Project, use one of these options:

- Go to My Websites > New Website Project
- In the My Websites tab, click the Website Projects icon and select New Website Project

This opens the Website Project Settings window, which allows you to configure settings for your Website Project.
Here's what goes in the provided fields:

**Website Project Name**
This is the name of your Website Project. Since it's just a personal reminder, you can name it anything you want. Our recommendation, just to keep things simple, is to give your Website Project the same name as your Website.

**Website Project Location**
This is the location where your Website Project files will be saved. Use the **Browse** icon to browse your computer for the desired location.
If you want to create a Website Project using preexisting files, select the folder that contains the files you want to use. If you are starting from scratch, you will need to create a blank folder where your Website Project files will be stored. To do this, browse your computer for the place where you would like to store this folder, and then click **Create Folder**. Give the folder a name, make sure it is selected, and then click **OK**.

**Server**

This is the server where your Website files will be stored. You can select one of the servers you have already defined or define one using the fields in the **Server Configuration** window.
You can only assign one server per Website Project. If you want to upload any or all of your Website Project files to a different server than the one specified in this field, you have two options:

1. Go to My Websites > Website Project Settings, switch the server, and then upload the file(s).
2. Go to the My Computer tab, right-click the file(s) you want to publish, and select the server and folder where you want to upload them. If any of your published documents reference these files, the path to the files you are uploading must match the path specified in your HTML code.

Configure Servers
This opens the Server Configuration window, which allows you to configure a new or existing server profile.

Remote Root Folder
This is the root folder where your Website files are stored on your server. Common names include www, public_html, or web. If you are not sure of this information, contact your hosting provider.

Server URL
This is the TCP/IP hostname of your FTP server. It should be in the form of an IP address, your domain name (e.g. yourdomain.com), or your domain name preceded by ftp. (e.g. ftp.yourdomain.com). Do not include ftp:// or any directory name such as ftp.yourdomain.com/mysite, because these are invalid TCP/IP hostnames. It is up to your Web hosting company to assign your FTP server hostname, so you will need to find out from them what it is.

Examples of valid Web server addresses
ftp.mysite.com
24.24.100.100
mysite.com

Examples of invalid Web server addresses
ftp://ftp.mysite.com
ftp.mysite.com/mysite
http://www.mysite.com

Check Dependencies Before Uploading Files
This checks your document dependencies before uploading your files to your server to make sure they are referenced correctly. Website Project dependencies are links and external files, such as style sheets, images, etc. — basically anything that your HTML file links to. If one or more of your document dependencies aren't referenced correctly, you will receive information about the incorrectly referenced dependency.
If Dependencies Are Missing From Local System, Cancel File Upload
Checking this box cancels the file upload if any of the document dependencies are not located in the right place in your Website Project.

When Uploading Files...
You can choose to always upload dependent files (like images and style sheets), never upload them, or have the program confirm with you before uploading them.

When you’re done filling out these fields, click OK. Your new Website Project will appear in the My Websites tab.

You can always return to the Website Project Settings window to modify these changes later using one of these options:

• Go to My Websites > Website Project Settings
• In the My Websites tab, click the Website Projects icon and Website Project Settings
Step 2a: Adding Individual Pages to Your Website Project
The next thing we'll cover is adding pages to your Website Project. First, create a new page using one of the following options:

- Go to File and select New From Quick Start, New Blank Page, or New From Layout
- Click the New Items icon in the Toolbar and select New From Quick Start, New Blank Page, or New From Layout
- Use the keyboard shortcut Ctrl+N to create a new blank page

For more information about these options, read Creating a New Webpage.

Next, save your page using one of the following options:

- Go to File > Save
- Click the Save Items icon in the Toolbar and select Save
- Use the keyboard shortcut Ctrl+S

This opens a window that allows you to choose the location where your new page will be saved. By default, the program will prompt you to save your page to the root folder of your Website Project. Enter a name for your page and click OK.

If this page is going to be your Website homepage (front page), name it index.html.

Your file will appear in the My Websites tab.

Step 2b: Adding Themes to Your Website Project
An alternative to adding individual pages to your Website Project is to start with a theme. A theme includes three pages (index.html, about-us.html, and contact-
us.html) that include the HTML and images for a basic design, which means all the hard work is done for you.

For more information about themes, read the **New From Theme** section of *Creating a New Webpage*.

To choose a new theme, use one of the following options:

- Go to **File > New From Theme**
- Click the **New Items** icon in the **Toolbar** and select **New From Theme**

This opens the **Theme Chooser** window, which allows you to select a theme you would like to use as your Website.

Select the theme you would like to use, and then click **OK**. This opens a window prompting you to choose the Website Project where you would like to save your theme.
Step 3: Adding Folders to Your Website Project
An organized, intuitive structure is a really important aspect of a well-designed Website. One of the first things you can do to help organize your Website files is to create folders for specific page elements. Take a look at the Website Project created from a theme. See those subfolders of the main Website — css, images,
and js? Each of those folders is clearly labeled with the name of the type of file it contains. This system helps keep everything in its own place.

Let’s emulate this structure in our blank Website Project. (Of course, you can also add folders to a Website Project created with a theme.) To create a folder, right-click anywhere in the My Websites tab. This opens a right-click menu that contains options for working with your Website Project:

Select Create Folder. This creates a new folder. By default, it will be named New Folder 1, but you can give it any name you want. For this tutorial, let’s call this file images and use it to store — you guessed it — images.
Step 4: Adding Other Files to Your Website Project

Next, let’s add some images to our images folder. To do this, switch over to the My Computer tab.

Use the area at the top to browse your computer for the image you want to add to your page. Selecting a folder in the top area opens all its files in the bottom area. Let’s take a look inside Public Pictures > Sample Pictures.
When you find the image you want to use — in this case, let’s go with Toco Toucan — right-click it. This opens another right-click menu with options for working with the files on your computer. Select Copy File to Folder. This expands to display a list of the folders in your Website Project.
Since this is an image, we'll add it to images > [Here]. This opens a window that confirms whether you would like to copy the file to your Website project.

Next, return to your Website Project by clicking the My Websites tab. Expand the images folder by clicking the little plus sign to the left of it. There, you'll see your newly added image.
Now, anyone familiar with Websites will know that spaces in filenames are a total no-no. Let’s rename this image to something more Web-friendly. To rename the image, right click it and select Rename. Now enter a new name for the image — in this case, toco-toucan should work just fine.

**Step 5: Linking to Files and Pages in Your Website Project**

Now that we’ve added an image to our Website Project, let’s add it to our page. To do this, right-click the image and select Insert Image Into Current Document. This inserts the HTML for an image in the place where your cursor was positioned in the Code Editor. The code looks like this:

```html
<img src="/images/toco-toucan.jpg" width="1024" height="768" alt="" border="0">
```

For a detailed tutorial about other ways to add an image to your page, read Adding an Image to Your Page.

Next, let’s create a link to another page in your Website Project. Of course, before we can do this, we’ll have to add another page. To do this, use the method described in Step 2a. For this tutorial, name your page about-us.html.

Switch over to index.html by clicking the index.html tab in the Statusbar at the bottom of the program.

Next, right-click about-us.html and select Insert as Link Into Current Document. This inserts the HTML for a link in the place where your cursor was positioned in the Code Editor. The code looks like this:
Next, let’s enter some link text, which is the text your user will click to be taken to about-us.html. By default, link text is blue and underlined. For this tutorial, we’ll use this as the link text: Learn more about us! Your code will look like this now:

```html
<a href="about-us.html">Learn more about us!</a>
```

Finally, just for the sake of formatting, let’s put this link in some paragraph tags. To do this, use one of the following options:

- Manually enter paragraph tags (`<p></p>`) around the link HTML
- Highlight the link HTML and go to Format > Paragraph
- Highlight the link HTML and click the Paragraph icon in the Code Editor toolbar
- Highlight the link HTML and use the keyboard shortcut Ctrl+Enter

For a detailed description about other ways you can add the many different kinds of links to your page, read Working With Links.

**Step 7: Previewing Your Website Project**

Let’s take a look at how your Webpage looks! To do this, click to the Preview tab at the top of the program. The Preview tab is a built-in Web browser (Internet Explorer, to be exact), so you’ll get a chance to test your Webpage in its native environment.
Okay, admittedly it’s probably not the Website of your dreams, but it’s a start. Your image displays correctly, and your link points to your About Us page.

For a detailed tutorial about the many different ways you can preview your work, read Previewing Your Work.

Step 8: Uploading Your Website Project
Even though your Website isn’t quite done yet, let’s still walk through the steps involved in uploading it. It’s pretty simple — just click the Tools icon at the top of the Website Projects tab and select Upload Entire Website Project. This opens the Upload Files to Server window, which displays the status of your file upload.
This window closes automatically once the upload is complete. Now you can switch over to the **Server** tab and check out your files on your server!

You'll notice that your file structure is perfectly preserved, which means all your links and images will be referenced correctly.

What if you don’t want to upload your entire Website Project? Easy: Just select the file(s) you want to upload, and then use one of these options:

- Click the **Tools** icon and select **Upload Selected Files**
- Right-click the selected file(s) and select **Upload Selected Files**

The cool thing about Website Projects is that even when you’re uploading individual files, your file structure will still be preserved.

And that’s pretty much it! By now, you should have a pretty good idea of how to use Website Projects. If you want any additional information, we highly recommend checking out the sample Website Project included in the HTML Editor. To access it, go to **My Websites > All Website Projects > What is a Website Project.**
Creating a New Webpage

There are four ways to create a new page in the HTML Editor: using the Quick Start Wizard, starting from scratch, using a layout, or loading a template.

**New Blank Page**
This option is best for people who want to jump right into coding their Website. If that sounds like you, here's what you gotta do:

**Step 1**
Open the HTML Editor and select **New Blank Page** from the **Welcome** window.

If you already have the Editor open, use one of the following options instead:

- Go to **File > New Blank Page**
- Click the **New Items toolbar icon** and elect **New Blank Page**
- Use the keyboard shortcut **Ctrl+N**

**Step 2**
A new blank page will open in the **Code Editor**. By default, new pages include some basic HTML to help get you started. This includes the DOCTYPE, html, head, title, meta, and body tags, and an HTML comment stating that the page was created with CoffeeCup HTML Editor.

And that's all there is to it! Let the coding begin.
New From Quick Start

If you want to customize your page before you get started, this is probably the option for you. The Quick Start Wizard lets you specify some basic page properties, including the title, DOCTYPE, character set, meta information, background, and color scheme. When you’re done specifying this information, the corresponding code is automatically added to your page. Here’s how to get started with the Quick Start Wizard:

Step 1
Open the HTML Editor and close the Welcome window.

Step 2
Open the Quick Start window using one of these options:

- Go to File > New From Quick Start
- Click the New Items toolbar icon and select New From Quick Start.

Step 3
Enter the following information in the provided fields in the Quick Start window.
**Page Title**
The text displayed in the bar across the top of a Web browser and that also appears in search results. A good page title succinctly describes the content on the page. For example, let’s say your Website is named **My Himalayan Adventures**, and you use it to blog your adventures climbing in the Himalayas. If this particular Webpage describes your trip up K2, your page title could be any one of these:

- My Himalayan Adventures | Conquering K2
- My Himalayan Adventures | My Trip up K2
- My Himalayan Adventures | Climbing K2: What the Hell Was I Thinking?

You may have noticed that the name of the Website is included in all these titles, and the rest of the description is separated by the pipe character. This isn’t required, but it looks nice and keeps the name of your Website fresh in your visitors’ minds.

**Background Image**
To select a background image for your page, enter the file path in this field or click the **Browse** icon to browse your computer for the image you wish to use. To remove a background image, click the **red X** icon.

If you choose to use a background image, it should be clean and simple. Flashy background images can be distracting or look amateurish. The HTML Editor automatically repeats the background image to fit the size of the page, so your image should look natural when repeated. When you browse for a background image, the default folder contains predefined backgrounds that come with the HTML Editor. You can use any of these in your Website, or use them as a guide for what your custom background image should look like. For this tutorial, we’ll browse for an image, open the **beige** folder, and select **basket.jpg**.

**Colors**
There are five color options available: page background, text, and three different states of links: visited, unvisited, and active. A visited link is a link that has already been clicked by the user, and an unvisited link has not been clicked by the user. A link is active while a user is clicking it.

To change the color of any of these elements, click the color swatch next to it. This opens a drop-down list of 40 basic colors.
Click whichever color you would like to apply. To browse even more colors, click **More Colors**. This opens a rainbow gradient that allows you to adjust brightness and select from a wider range of colors.

To select one of these colors, click the color you want to use, and then adjust the slider on the right-hand side to change the brightness.

**Color Scheme Drop-Down List**
If you would like to use a predefined color scheme for these color options, you can select one from the **Color Scheme** drop-down list.
To preview how a scheme looks, select it from the list. You can always customize it or return to the default by selecting **(Default)**. For this tutorial, we’ll stick with the default theme — why rock the boat?

**Save**
If you do choose to use one of the color schemes, but decide to change one or more of the options, click this button to save these changes to the scheme. This overwrites the default scheme, so make sure you really want to replace it before you save over it!

**Save As...**
If you create a custom color scheme or customize one of the existing themes and don’t want to overwrite it, click this button to save the changes under a new name. This opens a window that allows you to enter a name for your new scheme.

After you click **OK**, the scheme will be available under the **Color Scheme** drop-down list.

**Delete**
Click this button to delete the selected scheme. This change is permanent, so make sure you really want to delete it before you go ahead and click this button!
Don’t Underline Links
Check this box if you would like to remove the automatic underline from your links. We recommend keeping the underline — it’s one of the main ways your visitors will be able to distinguish your links from your normal text, so why make things more difficult for them?

DOCTYPE
Select the desired DOCTYPE from this drop-down list. A DOCTYPE tells the Web browser the type and version of the language the page is written in.

Charset
Select your preferred character set from this drop-down list. A character set is the set of characters available to be used in your code and on your Website. For example, if you want to create a Website using Cyrillic, that would use a different character set than a Website that used the Latin alphabet.

Meta Description
This is a short description of your Website that sometimes appears in search results. It should be no longer than 50 words.

Meta Keywords
These are words that describe your Webpage. They must each be separated by a comma and a space.

Step 4
When you're done entering this information, click OK. The code will be inserted into your page for you.

You’re all done getting started — the rest is in your hands!

New From Layout
This option allows you to choose a basic layout to start with. A layout contains the HTML for a basic page structure. This is a good starting place for people who want to start with a bare bones structure and add a design from there. Here’s how to get started with layouts:

Step 1
Open the HTML Editor and close the Welcome window.

Step 2
Open the Layout Chooser using one of these options:

- Go to File > New From Layout
- Click the New Items toolbar icon and select New From Layout.
Step 3
Select the desired layout from the Layout Chooser.

You can preview how the different layouts look in the Preview area. (FYI, liquid layouts resize automatically to fit the size of the user’s browser, whereas fixed layouts always stay the same size.)

Step 4
When you find a layout you like, click OK. The code will be inserted into your page for you.

Once the code is inserted, you can replace the generic text with your own, tweak elements of the code, add images, and whatever else you need to complete your Webpage!

New From Theme
If you're a total beginner and have no idea where to start, this is the place. This option is also great if you want to put together a professional-looking Website with a minimum of muss, fuss, and time. A theme includes three pages (index.html, about-us.html, and contact-us.html) that include the HTML and images for a basic design — which basically means all the hard work is done for you! Here's how you get started with themes:

Step 1
Open the HTML Editor and select Start With a Theme from the Welcome window.
If you already have the Editor open, open the **Theme Chooser** using one of these options:

- Go to **File > New From Theme**
- Click the **New Items toolbar icon** and select **New From Theme**.

**Step 2**
Select the desired theme from the **Theme Chooser**.
You can preview how the different themes look in the Preview area.

**Step 3**
When you find a theme you like, click OK. The code will be inserted into your page for you.

Once the code is inserted, you can replace the generic text and images with your own, tweak elements of the code, and do whatever else you gotta do to complete your Webpage!
Adding an Image to Your Page

There are two different methods of adding an image to your page: Using the Insert Image window and using the Resource browser. The Insert Image window is a good choice if you want to specify image attributes and/or create a thumbnail version of the image. The Resource browser is best if you want to skip all that stuff and just add an image to your page.

Method 1: Insert Image Window

This method is a good choice if you want to specify image attributes and/or create a thumbnail version of the image. There are a few different ways to reach the Insert Image window:

- Go to Insert > Image.
- Click the Image icon on the Code or Visual Editor toolbar.
- Right-click the Code or Visual Editor and select Image…
- Use the keyboard shortcut Ctrl+M.

Each of these options opens the Insert Image window, which allows you to choose an image and specify additional information, like alt text, alignment, border, size, and other fancy stuff, like adding a link or creating a thumbnail.
Here’s what you do:

**Step 1: Locate Your Image**

Use the file browse area on the left-hand side of the window to look through your computer for the image you want to use. When you find the image you want, click it with your mouse. For now, the image may be located anywhere on your computer — you’ll get a chance to save it in your Website Project or Working folder in a few steps.

If the phrases “Working folder” and “Website Project” left you scratching your head, take some time to check out this tutorial: [Working With Website Projects](#).

**Step 2: Enter General Information**

Now you can use the fields under the **General** tab to enter some additional information about the image. It’s by no means necessary, but it can help your page load more efficiently and make your page more accessible to disabled users. We’ll go through each field step by step, and you can decide which you want to include. In this example, we have chosen a picture of a landscape that will be featured prominently on our page.

![Image Fields](image.png)

**Image**

This is where the path to the image goes. If you have selected an image using the file browse section on the left-hand side of the window, the path will automatically
appear in this field for you. If you just happen to know the file path off the top of your head, you can also enter it manually.

**Alt**
This field contains what’s called “alt text,” which is a description of the image that is displayed when the image cannot be shown. This is most commonly used in text-only or speech browsers, which the blind use to access the Internet, but it also appears before the image loads if someone is surfing the Web on a slow connection. You should always include detailed alt text for all prominent or contextually important images on your Webpage, otherwise you run the risk of some users not getting the full gist of your Webpage. Since the image we are using is important to our page, we’ll use the alt text “A desert landscape.”

**Title**
A title is a description of the image that pops up in a tooltip when the user holds their mouse over the image. This can be used to provide additional information about the image. For this tutorial, we’ll use the location of the landscape and the date when we took the picture as our title. It’s not necessary information, but some users might find it interesting, so why not include it?

**Align**
Select the alignment of the image from this drop-down list. The options should be pretty self-explanatory, but in case you’re wondering about them, you can check out a handy guide at HTML Code Tutorial [here](http://www.htmlcodetutorial.com/images/_IMG_ALIGN.html). We’ll keep it simple and select **left** for our image.

**Border**
This is a black border, measured in pixels, that appears around the image. The larger the number, the thicker the border. For a typical border, we recommend using a number between 1 and 5. Our image isn’t going to use a border, so we’ll keep it set to 0.

**Width and Height**
These fields display the width and height of your image, and these attributes are included in the HTML for your page. This is helpful because it tells the browser how much space to allot for the image. If a user is viewing your Webpage on a slow connection, this will ensure that the text is formatted properly even before the image loads. For that reason, it’s important to include the size measurements. If you decide you’d rather not, just uncheck the **Include size** checkbox. We’ll leave it checked in this example.

You can also use these fields to resize your image, but be careful if you do! The image resize feature should only be used to make minor
adjustments, since the HTML Editor doesn’t maintain the aspect ratio. This means that unless you know the exact ratio of the width to the height, your image will likely end up distorted. If you need to make changes to the size of your image, save yourself a headache and use an image-editing program.

**URL to Link To**
If you would like to make the image into a clickable link, use this field to enter the URL where your user will be taken when they click the image. If you are linking to an external Website, be sure to include the full Web address, including the http://www bit.

If you are linking to a page or document in your Website, you can use a relative link by clicking the file icon to browse your computer for the file you want to link to.

¡Careful where you link! If the file you link to isn’t located in your Working folder or your Website Project, it may not be referenced correctly — meaning the link won’t work. Need more information about working with Website Projects? Check out this tutorial: Working With Website Projects.

**Step 3: Create a Thumbnail**
This step is totally optional. Thumbnails are usually used to link to the larger original version of the image. This gives you a bit more design freedom, since you don’t have to work around tons of large images, and users on slow connections will thank you for not increasing download times with tons of large files.

If you’re just adding a regular ol’ image to your page, you can skip this part and go straight to Step 4. But if this sounds useful, switch over to the Thumbnail tab and follow along!
Create and Insert Image as Thumbnail
Select this checkbox if you would like to use the image as a thumbnail.

Link to Original Image
Select this checkbox if you would like the thumbnail to link to the original image.

Thumbnail Filename Prefix
This is a prefix that appears at the beginning of the thumbnail filename. Since this feature creates a new, smaller version of the image you added, it needs a new name to differentiate it from the original. The default prefix is `tn_`, but you can change it to whatever you want.

Thumbnail Width and Height
Enter the width and height of the thumbnail here. The HTML Editor maintains the aspect ratio for thumbnails, which means your thumbnail won’t end up distorted.

Thumbnail Format and Quality
Choose the desired image file format (.gif or .jpg) and quality (65-95). Keep in mind that high-quality images look better, but are also larger, which can make for longer download times. In today’s day and age, a high-quality image isn’t really going to slow anyone down, so don’t feel guilty about splurging and going with a quality of 95.

Step 4: Adding Your Image to Your Working Folder or Website Project
When you’re done entering all the additional information, click OK. This opens a window that asks if you want to copy your image file to your Website Project.
We can’t stress enough how important it is to save your images to your Website Project or Working Folder! If you don’t, they may not be uploaded to your server, which means they won’t show up on your Website. Instead, you’ll get those annoying red X’s — not to mention a huge headache.

**Method 2: Resource Browser**

Using this method, you can simply drag an image from the **Resource** browser on the left-hand side of the screen to your page. Here’s the step-by-step version:
Step 1
Open the My Computer tab in the Resource browser on the left-hand side of the program.

Step 2
Use the area at the top to browse your computer for the image you want to use. Selecting a folder in the top area opens all its files in the bottom area.

Step 3
When you have found the image you want to add, use your mouse to drag it to your Webpage. This opens a window that asks if you want to copy your image file to your Website Project.
We can’t stress enough how important it is to save your images to your Website Project or Working Folder! If you don’t, they may not be uploaded to your server, which means they won’t show up on your Website. Instead, you’ll get those annoying red X’s — not to mention a huge headache.

**Step 4**
The image will now appear on your page without any special formatting. If you need to work with the alignment, border settings, alt text, or any other associated attributes, switch to the **Code Editor** if you aren’t there already, and then edit the code directly.
How to Change the Appearance of Text

Unlike people, not all text is created equal. Some text is **bold** or *italicized*. Other text can be different colors, such as red, blue, or orange. Some text is **enormous**, whereas other text is downright tiny.

If all those different formats didn’t inspire you to change the style of the text on your page, nothing will! There are a couple of different ways to change the appearance of your text in the HTML Editor. To tweak basic attributes, such as size, color, and effects like bold, italic, and underline, there are a few quick’n’easy tools you can use. Open up the **Format** menu and take a look at the first half of the options:

![Format menu](image)

These options are pretty self-explanatory. To use them, just highlight the text you want to change, and then select the attribute you want to apply. You can also access these options with the keyboard shortcuts displayed in the **Format** menu, as well as in the **Code** and **Visual Editor** right-click menu and toolbar.

To make more in-depth changes to your text, use the **Font Wizard**. Here’s how:

**Step 1**
Highlight the text you want to change.
**Step 2**
Open the **Font Wizard** by going to **Format > Font Wizard**, clicking the **Font** icon in the **Code** or **Visual Editor** toolbar, or right-clicking and selecting **Font > Font Wizard**...

**Step 3**
Start working with the options in the **Font Wizard**! This tool allows you to change the typeface, effects (bold, italic, strikethrough, or underline), position (normal, subscript, or superscript), size, and color of the font. Let’s take a deeper look at these options:

![Insert Font Tag](image)

**Fonts**
Select the font you want to use from this list, and then apply it to your text using one of the three **Add as Font** buttons to the right.

Why are there three font boxes? Well, just like fonts, not every computer is created equal. Your computer might have some crazy-funky-fresh font installed that’ll look just **perfect** on your Website, but that same font might not be installed on someone else’s computer. When that happens, the other person’s Web browser
defaults to a default to a generic font (usually Arial or something similar). This can mess up the appearance of your Website, with words running out of boxes, elements getting pushed out of the way of marauding text, and other such chaos that basically messes up your entire Website. Yikes!

You can avoid this mess by using **Web-safe fonts**. These are fonts that are installed on every computer by default, which means that they will always display correctly on every computer. They include such timeless classics as:

```
Arial          Times New Roman          Impact
Arial Black    Comic Sans MS           Trebuchet MS
Courier New    Georgia                Verdana
```

So, if Web-safe fonts are so, well, safe, then why doesn't everyone use them? Frankly, because they're kind of boring. Fortunately, the HTML Editor gives you three choices. For **Font 1**, use your first-choice font. Go as funky and crazy as you want, and if the font happens to be installed on your user's computer, awesome! If not, the browser can just look for the second font you specified. Make **Font 2** and **Font 3** Web safe, and you'll be golden. For extra security, you can also select a generic font, which always displays correctly, from the **Generic** drop-down list. Generic fonts are totally no-frills, but you can rest assured that they'll always work, even in the very, very rare instance when a Web-safe font might not.

By specifying multiple fonts, you can tell the browser to first try a fancy, non-Web-safe font. That way, you can make sure that your Website will look good whether you're using a cool, custom font or a secure, Web-safe font.

**Effects**
Select from **bold**, **italic**, **strikethrough**, or **underline**.

**Text Position**
Select whether your text will appear normally or as a **subscript** or **superscript**.

**Size**

Select a font size from 1 (8 pt) to 7 (36 pt).

**Color**

To select a color for your text, click the color swatch. This opens a drop-down list of 40 basic colors.
If you see a color you like, click it. If you want to see even more colors, click **More Colors**. This opens a rainbow gradient that allows you to adjust brightness and select from a wider range of colors.

**Step 4**  
When you're done formatting your text options, click **OK**. All the code will automatically be added to your page for you!
Working With Links

How important are links? Wicked important — it’s no exaggeration when we say that without them, the Internet as we know it wouldn’t exist.

This section will teach you the basics about absolute and relative links, and then walk you through the process of adding links your pages in the HTML Editor. To skip ahead to the tutorials, use these links:

- Adding a link to your page
- Adding an e-mail link to your page
- Linking to a downloadable document
- Linking to different parts of the same page

**Absolute vs. Relative Links**

One of the most common things newcomers to HTML get confused about is linking to other pages and sites, especially when absolute and relative paths come into play. But worry not! Creating links — relative and absolute alike — is actually fairly easy. Read on, and by the end of this article, you’ll know the difference between these two types of links, as well as when and how to use them.

When you create links using the Website Projects tool, it automatically creates valid relative links for you — one less thing to think about! Of course, it’s still important to understand how this all works, so read on...

First off, as you may or may not know, you would use the following code to create a link in HTML:

```html
<a href="linkhere.html">Click Me</a>
```

`linkhere.html` would be the page you want to link to, and **Click Me** would be the blue, underlined link that the page displays.

In the example above, we used a relative path. You can tell if a link is relative if the path isn’t a full Website address. (A full Website address includes `http://www`.) As you may have guessed, an absolute path does provide the full Website address. Here are a few examples of relative and absolute paths:

**Relative Paths**
- index.html
- /graphics/image.png
- /help/articles/how-do-i-set-up-a-webpage.html

**Absolute Paths**
- `http://www.example.com/index.html`
- `http://www.example.com/graphics/image.png`
- `http://www.example.com/help/articles/how-do-i-set-up-a-webpage.html`
Absolute Paths
http://www.mysite.com
http://www.mysite.com/graphics/image.png
http://www.mysite.com/help/articles/how-do-i-set-up-a-webpage.html

The first difference you'll notice between the two different types of links is that absolute paths always include the domain name of the Website, including http://www., whereas relative links only point to a file or a file path. When a user clicks a relative link, the browser takes them to that location on the current site. For that reason, you can only use relative links when linking to pages or files within your site, and you must use absolute links if you're linking to a location on another Website.

So, when a user clicks a relative link, how does their browser know where to take them? Well, it looks for the location of the file relative to the page where the link appears. (That's where the name comes from!) Let's get back to our first example:

```
<a href="linkhere.html">Click Me</a>
```

This link points to a filename, with no path provided. This means that linkhere.html is located in the same folder as the page where this link appears. If both files were located in the root directory of the Website http://www.website.com, the actual Website address the user would be taken to is http://www.website.com/linkhere.html. If both files were located in a subfolder of the root directory called files, the user would be taken to http://www.website.com/files/linkhere.html.

How about another example? Let's say we our http://www.website.com domain had a subfolder called pictures. Inside the pictures folder is a file called pictures.html. The full path to this page would be http://www.website.com/pictures/pictures.html.

Still with me? Good. Let's say in this pictures.html file, we have a link:

```
<a href="morepictures.html">More Pictures</a>
```

If someone clicked that link, where do you think it would take them? If you said http://www.website.com/pictures/morepictures.html, you'd be right! You probably know why it would take them there: because both files are saved in the pictures subfolder.

Now, what if we wanted to use a relative link to show a page in another folder? If you want to link to a file in a subfolder of the current folder, provide the file path to that file, like so:
<a href="/pictures/tahiti-vacation/tahiti.html">Read about my Tahiti vacation.</a>

In this example, you're telling the browser to look in the current folder (pictures) for a subfolder (tahiti-vacation) that contains the file you want the user taken to (tahiti.html). You can link to as many subfolders as you need using this method.

What if you want to link to a file in a folder above the current folder? You have to tell the browser to move up one folder in your relative link by putting two periods and a slash (../) in front of the filename or path:

<a href="../about.html">Learn more about my Website.</a>

When the browser sees ../ in front of the filename, it looks in the folder above the current folder. You can use this as many times as you need to.

You can also tell the browser to look in a subfolder of the directory above the current one. Using the same example Website from above, let's say we wanted to create a link that would take the user to a page called stories.html located in another folder called stories. This folder is located in the root directory, one folder up from the current folder, pictures. Here's how a relative link to this file would look:

<a href="../stories/stories.html">Read Stories</a>

Now, let's talk about absolute paths. Like we mentioned earlier, absolute paths provide the complete Website address where you want the user to go. An absolute link would look like this:

<a href="http://www.coffeecup.com">Click here to visit CoffeeCup Software.</a>

You must use absolute paths when linking to another Website, but you can also use absolute paths within your own Website. This practice is generally frowned upon, though. Relative links make it easy to do things like change your domain name without having to go through all your HTML pages, hunting down links and changing the names. As an added bonus, they force you to keep your site structure neat and organized, which is always a good idea.
Adding a Link to Your Page
Open the **Insert Link** window using one of these options:

- Go to **Insert > Link**
- Right-click the page and select **Links > Link**
- Click the **Links** icon in the **Code Editor** toolbar and select **Link**
- Use the keyboard shortcut **Ctrl+L**

These options open the **Insert Link** window, which allows you to insert a link and any associated attributes.

Let’s go over what each of these fields does.

**Link Text**
The text your user will click. By default, link text is blue and underlined. In the example above, the link text would look like this on your Webpage:

**Click here for great software!**
URL
This is the location where your user will be taken when they click the link text. If you are linking to an external Website, you must include the full link, including http:// and www, if applicable. The example above links to an external Website, http://www.coffeecup.com. If you are linking to a page or document in your Website, you can use a relative link by clicking the file icon to browse your computer for the desired page. You should make sure the file is located in your Working folder or your Website Project to make sure it is referenced correctly.

For more information about using Website Projects, read Working With Website Projects.

Target
This is the frame you want the link to open in, and is only necessary if you are using frames or if you want to open the link in a new window. To open the link in a new window, select New Browser Window (target="_blank").

For a detailed tutorial about using frames, read How to Use the Frame Designer.

Title
This is a description of the link that appears as a tooltip when your user holds their mouse over the link. It’s totally optional, but it is a nice source of information for your users.

Show Statusbar Message on Mouseover
If you check this box, a description of the link will display in the Statusbar at the bottom of the Web browser screen when your user holds their mouse over the link. This option is only enabled in Internet Explorer, so it’s best to use a title instead if you want to provide this additional information.

Web Browser Window Message
If you do decide to use a Statusbar message, type it in this field.

When you’re done filling out all this information, click OK. The code will automatically be inserted wherever your cursor was positioned on your page. You can move it around by selecting it and dragging it to the desired location on the page.
Adding an E-mail Link to Your Page
Open the Insert E-mail Link window using one of these options:

- Go to Insert > E-mail Link
- Right-click the page and select Links > E-mail Link
- Click the Links icon in the Code Editor toolbar and select E-mail Link
- Use the keyboard shortcut Ctrl+E

These options open the Insert E-mail Link window, which allows you to insert an e-mail link and any associated attributes. When your user clicks on this link, their default e-mail client (Thunderbird, Outlook Express, etc.) will open with this e-mail address in the To: field.

![Insert E-mail Link window]

**Link Text**
This is the text your user will click. By default, link text is blue and underlined. In the example above, the link text would look like this on your Webpage:

Click here to get in touch.
E-mail Address to Link To
This is the e-mail address that will appear in the user's default e-mail client when they click the link text.

Subject
Whatever text you enter in this field will automatically appear in the Subject field in your user's e-mail client.

Show Statusbar Message on Mouseover
If you check this box, a description of the link will display in the Statusbar at the bottom of the Web browser screen when your user holds their mouse over the link. This option is only enabled in Internet Explorer, so it's best to use a title instead if you want to provide this additional information.

Web Browser Window Message
If you do decide to use a Statusbar message, type it in this field.

When you're done filling out all this information, click OK. The code will automatically be inserted wherever your cursor was positioned on your page. You can move it around by selecting it and dragging it to the desired location on the page.

Linking to a Downloadable Document
Follow these steps to add a link to a downloadable document on your page.

This tutorial assumes you are working with Website Projects. For more information about how to use Website Projects, read Working With Website Projects.

Step 1: Locating the File
First, go to the My Computer tab and select the file you want to add to your Website Project. In this tutorial, we'll add a PDF file.
Step 2: Adding the File to Your Website Project
Right-click the file you want to add to your project and select Copy File to Project > [Folder], where Folder is the folder where you want to store the file. In this tutorial, we'll add the file to the Website Project root folder, but you may want to store your downloadable files in a special subfolder.
This opens a window confirming whether you want to copy the file to your Website Project Folder. Click Yes.
Step 3a: Linking to the File From Your Website Project
There are two methods you can use to link to your file. The first is from inside your Website Project. To do this, go back to the My Websites tab, where you'll see the file you just added to your Website Project. Right-click it and select Insert as Link Into Current Document.

This inserts the HTML code for a link to this document on your page. In this case, the link would look like this:

```html
<a href="newsletter.pdf"></a>
```

Next, enter the link text you want the user to click between `>` and `</a>`. The final code might look like this:

```html
<a href="newsletter.pdf">Our PDF newsletter.</a>
```

Step 3b: Linking to the File Using the Insert Link Window
The second method is to use the Insert Link window. Follow the instructions provided in Adding a Link to Your Page, only instead of choosing an .html file, select the file you added to your Website Project. In this case, it will be the newsletter PDF.

When you're done filling out all this information, click OK. The code will automatically be inserted wherever your cursor was positioned on your page. You can move it around by selecting it and dragging it to the desired location on the page.
A note about PDFs and other downloadable files you may wish to add: Most of the time, PDF files will open automatically. This is because almost all visitors already have the Adobe Acrobat Reader installed, and, depending on the browser, the PDF file will either open directly in the browser or in a separate reader window. Additionally, anyone visiting your site with Internet Explorer will be able to open files created in any Office application (Word, PowerPoint, Excel, etc.) directly in the browser.

If you want to make sure your users download the file, you can also place a small reminder somewhere on the page that says something like, "Right-click and select Save Link As... to save this to your computer."

Linking to Different Parts of the Same Page
You’ve been designing your site and have figured out that a page can be as long as necessary. This is great, but it can be a pain when you’re dealing with longer pages. Help out your visitors by providing links that quickly take them to specific locations on the page. Here’s how:

Step 1: Create a Target
The first step is to set a target. The target is the place on the page where you want the user to be able to jump to. To insert a target, go to Insert > Target. This opens the Insert Target window.

Enter a name for the target in the Target Name field, and then click OK. This inserts the code for the target on your HTML page. In this example, the target will be an employee profile for John Smith on our About Us page, so we’ll name the target jsmith. The resulting code looks like this:
Step 2: Position the Target
Since our target is associated with John Smith’s employee profile, let’s move it to the same location as his profile on the HTML page. To do this, just click and drag the target code to the desired location.

```
<a name="jsmith"></a>
<h4>John Smith</h4>
<p>He's a lean, mean, coding mac<br>hobbies include fly-fishing, fix</p>
```

Step 3: Link to the Target
Now that our target is in position, let’s return to the top of the page and create a link to it. To do this, create a new link using the options described in Adding a Link to Your Page.

Once in the Insert Link window, instead of linking to a URL or a page in your Website Project, instead enter the name of your target preceded by a pound sign (#). In keeping with our example, we’d type #jsmith in the URL field and “Learn more about John Smith” in the Link Text field.
When you're done, click OK. This inserts the link code in your page, which, in our example, would look like this:

```html
<a href="#jsmith">Learn more about John Smith</a>
```

And that's it! Now you can switch over to the Preview tab to see your link and target in action.
How To Create a List

Lists are a great way to present your information in a more organized, eye-catching way. Sure, you could use plain text to get your point across, but lists are much easier and faster to read. Follow these steps to learn how to create a list in the HTML Editor:

**Step 1**
Open the Insert List window using one of these options:

- Go to Insert > List
- Click the List icon in the Code or Visual Editor toolbar

**Step 2**
This opens the Insert List window, which allows you to select what kind of list you want to add and to add items and a title to it.

Let’s take a look at what each of the available options can do:

**List Type**
Select the type of list you want to create. Your options are bulleted, numbered, definition, and none, which is just a list of items with no special formatting. Here’s how each of the different list types look:
**Bullet Style**
This option is only available if you create a bulleted or numbered list, and it allows you to choose the style of the bullets or numbers. Here’s how the different bullets and numbers look:

- **Bullet**
  - Plain
  - Old
  - Arabic
  - Numerals
- **Circle**
  - List
  - Of
  - Items
- **Disk**
  - Uppercase
  - Roman
  - Numerals
- **Square**
  - Lowercase
  - Letters

**List Header Text**
This is the title of your list, and it is only available if you create a bulleted or numbered list.

**List Item Field**
This is where you enter your list items. Put each separate list item on its own line.
If you are creating a definition list, each item you type is a definition title (e.g. “This is a definition list” in the example above). To add definitions, switch to the **Code Editor** and type them between the corresponding `<dd></dd>` tags.

**Import List**

If you have already formatted a list and just want to import its contents, click this button. This opens a window that allows you to browse your computer for a text file containing your list. You can only import lists in .txt format.

When you find the file you want to import, select it and click **Open**. The contents will be inserted in the **List Item** field.

**Step 3**

When you are done configuring your list items and options, click **OK**. The code will be inserted in the page for you.
How to Use Snippets

If you've ever been frustrated at having to type the same piece of code over and over, you'll love snippets. A snippet is a piece of code stored in the HTML Editor that can be used and reused as many times as you need. You can save snippets of HTML, JavaScript, DHTML, Perl, or any other scripting language. The HTML Editor comes with several built-in snippets and gives you the option to create your own.

Viewing Snippets
To see a list of available snippets, open the Code Snippets tab in the Resource browser on the left-hand side of the program. When you select a snippet name from the top pane, the code will appear in the bottom pane. All the built-in snippets come with a detailed HTML comment explaining what the code does.
**Inserting Snippets**
Use any one of the following options to insert your snippet into your page:

- Double-click its name.
- Select it and click the **Insert Item Into Current Document** icon in the **Code Snippets** toolbar.
- Right-click it and select **Insert Item Into Current Document**.
- Drag it onto your page.

**Creating Snippets**
To create a snippet, highlight the text you would like to save as a snippet and use one of the following options to open the **Save Snippet** window:

- Go to **File > Save Selected Text as Snippet**.
- Click the **Save** icon in the **Toolbar** and select **Save Selected Text as Snippet**.

![Save Snippet window]

Name the snippet and click **OK**. The new snippet will be added to the list in the **Code Snippets** tab.

You can also add a new snippet using the options in the **Code Snippets** tab:

- Click the **New Snippet** icon in the **Code Snippets** toolbar.
- Right-click a snippet and select **New Snippet**.

Both of these options open a new tab in the **HTML Editor** workspace. When you are done entering the snippet text, save the document normally. This opens the **Save Snippet** window.
Editing Snippets
To edit an existing snippet, select it and click the **Edit Snippet** icon in the **Code Snippets** toolbar. This opens the snippet code in a tab in the HTML Editor workspace. Edit it and then save it normally.

Deleting Snippets
To delete an existing snippet, right-click it and select **Delete Snippet**, or use the keyboard shortcut **Del** key. This opens a window asking if you are sure you want to delete the snippet. If you change your mind about deleting the snippet, click **No**.

Refreshing the Code Snippets Tab
If you have added, edited, or deleted a snippet but haven’t seen the changes in the **Code Snippets** tab, click the **Refresh** icon in the **Code Snippets** toolbar. This refreshes the area so you can see the most up-to-date snippets.
How to Add a Flash™ Element Created with a CoffeeCup Flash™ Program

Follow these step-by-step instructions to add a Flash™ element created in one of CoffeeCup Software’s Flash™ applications (Photo Gallery, Web Form Builder, Web JukeBox, etc.) to a page created in the HTML Editor. You should have both applications open.

In this tutorial, we will add a form created in Web Form Builder to the HTML Editor page, but the process is the same for all our Flash™ applications.

**Step 1**
Save your Flash™ element to the same folder where the HTML page it will appear on is saved. This should be in the Working folder or Website Projects folder you specified in the HTML Editor.

![Image](image.png)

> This step is very important! If you don’t save the files associated with your Flash™ element in the same folder as the HTML file where it appears, the element will not display correctly — or at all.

**Step 2**
Saving opens the Files window, which lists the files you must upload in order for your Flash™ object to display correctly, as well as the HTML code you must paste on every page where you want the object to appear. Copy this code to your Windows clipboard by clicking the Copy to Clipboard button.
Step 3
Open the HTML Editor page where you want the Flash™ object to appear, and paste the code between the <body> and </body> tags.

Step 4
Upload your changes to your server, making sure you include the files associated with your Flash™ element as well as the page containing the code.
How to Use the Frame Designer

So, you’re ready to put your coding experience to the test by creating a page with frames? The HTML Editor can give you a boost with its Frame Designer. Here’s how you work with it:

To open the Frame Designer, go to **Insert > Frame Designer**.

As you create your frames-based layout, you can keep an eye on how your design will look using the **Preview** pane on the left-hand side of the window. You can also use this area to select frames for individual editing. Just click a frame to edit it. You can tell which frame is selected, because it will be blue.

Here’s how you use each of the options in this window:

**Frame Style**
Choose from a number of predefined frame styles. These styles include the number of frames, where they are located, and what function they perform. For example, **Header Two Frame** contains two frames, one intended for use as a header and another larger one where the body content goes.
Frame Width and Height
Use these drop-down menus to set the width and height of the selected frame. The width and height are measured in the percentage of the page the frame takes up. If the selected frame takes up the entire height or width of the page by default, you will not be able to adjust that attribute. For example, look at the header frame in the image above. Because it automatically takes up 100% of the width of the screen, you cannot adjust the width. Otherwise, what would go in the space it left behind?

Frame Scrolling
Choose whether your users can scroll within the frame. Auto adds a scroll bar when necessary, Yes adds a scroll bar at all times, and No will not add a scroll bar at any time.

Allow Frame Resize
Select this checkbox if you want your users to be able to resize the frames.

Frame Border
Select this checkbox to enable a frame border, and then enter the width of the border in the number field. 0 pixels is the thinnest border and 50 pixels is the largest. We recommend keeping the border between 1 and 5 pixels.

Frame Name
Enter a name for the frame here. You should use a name that relates to the frame’s function.

Source URL
Enter the URL of the page you want to appear in the frame here. If you are linking to an external Website, you must include the full link, including the http://www bit. If you are linking to an external Website, be sure to include the full Web address, including the http://www bit. If you are linking to a page or document in your Website, you can use a relative link.

Careful where you link! If the file you link to isn’t located in your Working folder or your Website Project, it may not be referenced correctly — meaning the link won’t work. Need more information about working with Website Projects? Check out this tutorial: Working With Website Projects.

Once you have entered the required information, click OK. The code will automatically be added to the page for you. If you have already created the HTML files that will be used as the source for each frame, click the Preview button in the Toolbar, and you’ll be able to view your page, frames and all!
How to Use the CSS Menu Designer

The CSS Menu Designer is a new addition to the HTML Editor. It’s an awesome tool that creates a sophisticated navigation menu for your Website. Read on to learn how to use it!

**Step 1: Before You Get Started**

It is extremely important to remove any old menu code (DHTML or CSS) from your document before inserting a new menu. If you don’t, your menu won’t work! If you are creating your first menu, these instructions don’t apply, so you can skip ahead to **Step 2**.

To remove your old code, first open the **Code Editor** and find the code you have to remove. The code will look different depending on whether you have inserted a CSS or DHTML menu.

**Removing CSS Menu Code**

Remove the following code from between your `<head></head>` tags:

```html
<link rel="stylesheet" type="text/css" href="css/menu-menu.css" media="screen">
```

*css/menu-menu.css* is the default name and location of the menu style sheet. If you have changed the name or location of this style sheet, this file path will reflect your changes. Next, remove this code from between the `<body></body>` tags:

```html
<ul class="menu-menu">
  <li class="first"><a href="page1.html">Menu Item 1</a></li>
  <li><a href="page2.html">Menu Item 2</a></li>
</ul>
```

This example contains just two menu items, but your menu may contain more. Be sure to remove the `<ul class...></ul>` tags and all the code between them. **menu-menu** is the default name for the menu class. If you have changed the name of the menu, the name you specified will appear here instead. *page1.html* and *page2.html* are the links you specified for the menu items. **Menu Item 1** and **Menu Item 2** are the names you specified for the menu items.

**Removing DHTML Menu Code**

Remove the code between `<script type='text/javascript'>` and `</script>`. This code should be located just below the `<body>` tag.
Step 2: Opening the CSS Menu Designer
Now that you have removed your old menu code, the next step is to work with the menu you want to insert in its place. First, open up the CSS Menu Designer by going to Insert > CSS Menu Designer...

The options at the bottom of this window appear no matter which tab is selected. Here’s what they do:

**Open Menu**
Click this button to open an existing menu.

**Save Menu**
Click this button to save your menu. We recommend you save frequently to prevent loss in case something happens to your computer while you are working.

**Preview**
Click this button to preview your menu in your default Web browser.

**OK**
Click this button to insert your menu code into the current document. We’ll talk more about this option in Step 5.

**Cancel**
Click this button to abandon any unsaved changes to your menu and exit the CSS Menu Designer.
The next step goes over the process of opening a preexisting menu. If this is your first menu, skip ahead to Step 4.

**Step 3: Opening a Previously Designed Menu**
If you have already designed a menu in the CSS Menu Designer or the DHTML Menu Builder and want to make edits to it, click the **Open Menu** button. This opens a window that allows you to browse your computer for the `.mnu` file for your existing menu.

![Open Menu Window](image)

When you find the file you want to open, select it and click **OK**. This opens the menu in the CSS Menu Designer.

> You can open a menu created in the DHTML Menu Builder in the CSS Menu Designer! Just find and open the `.mnu` file for your DHTML menu. You can then edit it normally. When you save or insert your menu code, it will be converted to CSS.

**Step 4: Designing a Menu**
Now that we’ve covered the nuts and bolts of opening a menu, let’s get down to business: designing it!
The CSS Menu Designer is broken up into three tabs: Menu Designer, Menu Colors, and Options. The **Menu Designer** tab is where you work with the structure of your menu; the **Menu Colors** tab is where you pick out your menu color scheme; and the **Options** tab is sort of the catchall section, where you can configure the rest of your menu options.

Let’s go through each of these options and design our menu!

**Menu Designer Tab**

First, take a look at the **Your Menu** section. This is where you can keep an eye on the structure of your menu.

First, let’s add a root item, which is a button in the main part of the menu. Clicking the **Add Root Item** button inserts a button called, by default, **Untitled1**.
Let’s change the text that appears on this button from **Untitled1** to something a bit more useful. In the **Text** field, type **Contact Us**. Next, let’s link this button to our contact us page, which, for the sake of this tutorial, we’ll assume is **contact-us.html**. Type that into the **Link** field.

We’ll be using **relative links** in this tutorial. Not sure what relative links are? Definitely, definitely take the time to read **Absolute vs. Relative Links**.

Our first menu item is configured! Let’s do another one. Click the **Add Root Item** button again, and name the new item **Learn More**. Don’t assign it a link just yet — we’re going to do something a bit different with this menu item.

Making sure that **Learn More** is selected in the **Your Menu** section, click the **Add Subitem** button. This adds an item that will appear underneath the **Learn More** menu item when your user clicks it. Name your subitem **About Us**, and link it to **about-us.html**.

You can add a subitem that expands when a subitem is clicked, but any further subitems aren’t allowed. This is because there’s no navigational benefit to having subitems of subitems of subitems — plus it sounds really silly to say, “subitems of subitems of subitems” in tutorials ;)}
Let’s add another subitem to the **Learn More** item. You could select **Learn More** and click the **Add Subitem** button, or you could use a different method and click **About Us** and click the **Add Sibling** button. This adds another item on the same level as the selected item. Let’s name this new subitem **Privacy Policy** and link it to **privacy.html**.

Here’s how the **Menu Designer tab** looks after all these changes:

![Menu Designer Tab](image)

Let’s switch over to the **Menu Colors** tab and customize our menu colors.
Menu Colors Tab

First, take a look at the **Menu Color Sample** area. This is where you can keep an eye on your menu color scheme. Next, let’s take a look at what each of these options does.

**Background Color**
The background color of the menu.

**Mouseover Background Color**
The background color of the menu when the user holds their mouse over it.

**Font Color**
The color of the menu text.

**Mouseover Font Color**
The color of the menu text when the user holds their mouse over it.

**Border Color**
The color of the menu border.

Okay, now that we know what everything does, let’s pick out some colors! How about a pretty dark green for the menu background? To change this, click the color swatch next to where it says **Background Color**, and select the dark green shade you want:
Hmm, looks like there isn't much choice in terms of dark greens, so let's click **Custom Color**. This opens a rainbow gradient where we can browse even more colors and adjust brightness.

Perfect! Next, let's use the same process to pick a light green for the mouseover color. The rest of the colors look good as is, but let's change the submenu colors to
match our main menu colors. To do this, click the **Use Main Menu Colors** button. Right now, the **Menu Colors** tab looks like this:

![Menu Colors Tab](image)

Awesome! Let’s switch on over to the **Options** tab to make a few more changes to our menu.

**Options Tab**

![Options Tab](image)
First, let’s take a look at what each of these options does.

**Orientation**
Choose whether you would like a horizontal and vertical layout. For now, let’s stick with a horizontal menu.

**Margin Top and Left**
Use these fields to set the top and left margin in pixels. A margin is the blank space surrounding the menu. When the margin is increased, more space will appear between the menu and the objects surrounding it. We’ll keep the defaults for now, but if you decide you want to give your menu a bit more breathing room once you see it on your page, you can always reopen it and adjust these fields later.

**Border Width**
Use this field to set the width of the menu border in pixels. Again, we’ll leave this as the default — why rock the boat?

**Font Face, Size, and Style**
Use this area to set the font and size of the menu item text, as well as whether it is bold or italicized. Let’s work with these options after we get through these explanations!

**Menu and Submenu Text Alignment**
Use this area to choose how you want the text in the menu to be aligned: to the left, right, or center.

**Top and Left Padding**
Use these fields the top and left padding in pixels. Padding is the blank space inside the menu, between the border and the menu contents. When the padding is increased, more space will appear between the text and the border.

**Use Fixed Width for Menu Items**
Select this checkbox if you would like to use a fixed width for the menu items. This means the menu items will always be the same width, regardless of how long their content is. This is another option we’ll work with.

**Item Width**
Set the width of your menu items in pixels here.

Okay, now that you know what everything does, let’s make some adjustments! First, let’s change the font face. Click the **Font** icon to open the **Font** window, which allows you to select which font face you would like to use.
Let’s choose a Web-safe font, just so we know it will display correctly. How about Times New Roman? Select it from the list and then click OK.

For more information about Web-safe fonts, read How to Change the Appearance of Text.

Next, let’s change the size and style of our menu text. Since Times New Roman looks a bit small, let’s change it to size 12, and make it bold by checking the Bold checkbox.

Finally, let’s make sure our menu items have enough room for their text. Make sure Use Fixed Width for Menu Items is checked, and then change the Item Width to 200 pixels. That should be more than enough room.

Having made all these changes, the Options tab will look like this:
And that's it for customization! Let's insert our menu, shall we?

**Step 5: Inserting Your Menu**

To insert your menu, click OK. This opens two windows containing information about your menu code:

![CoffeeCup CSS Menu Designer](image)

This window reminds you that you must remove all your old menu code before inserting new code. If you followed the instructions in *Step 1*, you don’t need to
worry about this window. Click **OK**. This opens the **Save Menu** window, which allows you to save your menu to work with it later.

Go ahead and click **Save** — you wouldn’t want to lose all the changes you just made, right? This opens a window that allows you to choose the folder where your menu files are saved. By default, it will be saved into your Working folder or your Website Project.
Once you have saved your menu, the code will automatically be inserted into your page. The code for our menu looks like this:

```html
<link rel="stylesheet" type="text/css" href="css/menu-menu.css" media="screen">

</head>
<body>
<ul class="menu-menu">
<li class="first"><a href="contact-us.html">Contact Us</a></li>
<li>
<a href="" class="first"><a href="about-us.html">About Us</a></li>
<li><a href="privacy.html">Privacy Policy</a></li>
</ul>

</body>
</html>
```

The top part that comes before the `</head>` tag is a link to the menu style sheet, and the bottom part is the HTML code that is modified by the style sheet.
Interested in learning more about what style sheets are and how they work? Check out the comprehensive tutorial about this awesome Web design tool at W3Schools (http://www.w3schools.com/css/css_intro.asp).

Switch on over to the Preview tab and see how your new menu looks!

Pretty snazzy, huh?

**Step 6: Positioning Your Menu**

To change where your menu appears on your page, your best bet is to use `<div></div>` tags to position it. To do this, place `<div></div>` tags around the menu code that appears between the `<body></body>` tags, which would look like this:

```
<div>
  <ul class="menu-menu">
    <li class="first"><a href="contact-us.html">Contact Us</a></li>
    <li>
      <a href="">Learn More</a>
      <ul>
        <li class="first"><a href="about-us.html">About Us</a></li>
        <li><a href="privacy.html">Privacy Policy</a></li>
      </ul>
    </li>
  </ul>
</div>
```
Next, add the align attribute to the opening <div> tag, and give it one of these values: bottom, center, justify, left, right, or top. For instance, if you wanted to center your menu, the opening <div> tag would look like this:

```html
<div align="center">
```

**Step 7: Adding Your Menu to Your Other Pages**

Using Code Snippets, you can easily add your menu to all the pages in your Website. To do this, first select the code in your menu that appears between the <head></head> tags, which looks like this:

```html
<link rel="stylesheet" type="text/css" href="css/menu-menu.css" media="screen">
```

Next, use one of these options to save it as a snippet:

- Go to File > Save Selected Text as Snippet
- Click the Save Items icon in the Toolbar and select Save Selected Text as Snippet
- Right-click the text and select Save Selected Text as Snippet

This opens the Save Snippet window. Enter the name for the snippet in the Filename field. In this case, we'll call our snippet Menu Style Sheet. When you're done, click OK.

Next, highlight the menu code that appears between the <body></body> tags — <div> tags and all! — and create another new snippet. Call this one Menu Code. Now switch over to the Code Snippets tab, where you'll see your new snippets!
Now whenever you want to insert your menu into another page, just go to the **Code Snippets** tab and insert the snippets into the correct locations in your page.

For more information about how to use Code Snippets, read **How to Use Snippets**.
How to Use the Open From Web Function

With the HTML Editor, you can import published Webpages from the Internet and open them in the program. To do this, go to File > Open From Web. This opens the Open From Web window, which allows you to enter the URL of the page you wish to open and to specify options for saving this file to your computer.

A few notes about this function before we describe how you use it. First, it can only be used to download one file at a time. If you want to download multiple files from a Website, you may want to use an FTP client such as Direct FTP (http://www.coffeecup.com/direct-ftp/) or Free FTP (http://www.coffeecup.com/free-ftp/) to download several files at once.

Second, this option works best if you are downloading an HTML page that does not use PHP or SSI, because scripting languages like these can add code to a published page. As a result, you may not download the correct HTML.

Finally, if the page doesn't load correctly, the server may be responding slowly. In this case, repeat the Open From Web function.
All right, now that you know what this function can and cannot do, let’s get started! The first step is to enter the URL for the exact Webpage you want to download. For instance, say you wanted to emulate the oh-so-snazzy design of the CoffeeCup About Us page (http://www.coffeecup.com/about/). You would have to type that entire URL into the **URL to Open From Web** field. If you tried just using http://www.coffeecup.com, you’d get the CoffeeCup Software homepage — still snazzy, but not the page you were looking for.

Once you’ve entered the URL of the page you want to download, it’s time to choose where you would like to download the file and what parts of the page you would like to download. That’s where the **Options** tab comes into play:

![Options tab screenshot](image)

**Download Only the HTML Page (Without Images or Other Required Files) and Open it in the Editor**

This option downloads only the HTML from the page. That means any images, CSS, JavaScript, and anything else associated with the page won’t be downloaded. This option also does not save the file to your computer. Instead, it just opens the HTML in the Editor. This is a good option if you want to get your hands on the raw structure of the page and start editing it right away. Once you’re done making your edits, you can save the file normally.

**Save to Disk**

This option saves the page to a location you specify on your computer. To specify a location, click the **Browse** icon and choose the folder where you want the file saved. If you choose to save to disk, you can also use the provided checkboxes to:

- Have the page open in the Editor after it has been saved to your computer
- Download images that appear in the page
- Download related files such as CSS and scripts
- Open related CSS files in the HTML Editor

These options come in handy if you want to work with more than just the page HTML.
The last step is to switch over to the **Proxy Settings** tab, where you can enter proxy information if necessary.

![Proxy Settings](image)

To be honest, if you aren’t sure whether you should use this information, chances are really good that you do not have to. If you want to be extra‐sure, contact your hosting provider, and they’ll be able to give you a definitive answer.

Once you’ve configured all your settings, go ahead and click **Open**. You can track the progress of your download in the **Download Status** area at the bottom of the window. When it’s done, edit your newly downloaded files normally.
How to Use Bookmarks

Maybe it’s the last place you left off editing, a portion of the page where you make a lot of changes and updates, or a design element you want to run by a client — for whatever reason, you need to come back to a certain part of your code at another time. This is where bookmarks come in handy. These unobtrusive tools mark places in your code so you can return to them whenever you need to.

Bookmarks appear as green book icons labeled with a number in the gutter, the area on the left-hand side of the code that also contains line numbers and symbols representing paragraph breaks.

Setting Bookmarks
To set a bookmark, use one of the following options:

• Go to Document > Set Bookmark and select which bookmark number you want to set.
• Use the keyboard shortcut Shift+Ctrl+[0-9]. Choose the digit that corresponds to the bookmark number you want to set. For instance, if you wanted to set bookmark number 5, you would use the keyboard shortcut Shift+Ctrl+5.

You can set up to 10 bookmarks per document.

Locating Bookmarks
To locate a bookmark, use one of the following options:

• Go to Document > Go to Bookmark and select the bookmark number you want to locate.
• Use the keyboard shortcut Ctrl+[0-9]. Choose the digit that corresponds to the bookmark number you want to locate. For instance, if you wanted to go to bookmark number 5, you would use the keyboard shortcut Ctrl+5.

Resetting Bookmarks
There are two methods for resetting bookmarks. If you want to reset an individual bookmark, just set the bookmark number in another location. For instance, if you were using Bookmark 0 to mark your meta tags but wanted to use it to mark your footer HTML, just position your cursor at your footer HTML and set Bookmark 0 using one of the methods described above.
The second method is to clear all your bookmarks at once. To do this, go to Document > Clear All Bookmarks.
How to Use the Code Cleaner

If you've ever tried to edit someone else's code, you know how much of a hassle it can be to pick through a style that isn't your own. Reformatting can be a pain, but with the HTML Editor's **Code Cleaner**, it's a breeze. The Code Cleaner filters through source code, restyles it to fit your personal taste, and weeds out pesky errors in the document. If you have trouble loading a document in a browser, running the Code Cleaner may be able to find the problem for you.

Here's how to use the Code Cleaner:

**Step 1**
Go to **Tools > Code Cleaner...** This opens the **Code Cleaner** window, which allows you to set your code cleaning preferences.

The Code Cleaner will always reformat your document tags because of the way it parses the tags. If you are dissatisfied with the cleanup, select **Undo** from the Edit menu.

- **Wrap**: 66
- **Tab Spaces**: 2
- **Indent**: Auto
- **Indent Spaces**: 2
- **Indent Attributes**: No
- **Upper case tags**: Yes
- **Upper case attributes**: No
- **Wrap attributes**: Yes
- **Fix backslash**: Yes
- **Break before <br>**: Yes
- **Fix bad comment tags**: Yes
- **Fix script literals**: Yes
- ** simplemente quote**: Yes
- **Drop font tags**: Yes
- **Numeric entities**: Yes
- **Clean and convert to CSS**: Yes
- **Hide end tags**: Yes

If checked, this writes non-breaking space characters as "&nbsp;".

**Step 2**
To view detailed descriptions on how a given option works, place your mouse over that option and read the description in the yellow pane at the bottom of the window. You can also switch to the **Document** and **ASP and XML** tabs to see more options.
**Step 3**
Select all the attributes you would like to apply to your code, and when you’re done, click OK. This starts the code cleaning process.

If you change your mind about the edits the Code Cleaner made, you can undo them by going to **Edit > Undo**. You can always rerun the Code Cleaner using different settings until you are satisfied with the results.
How to Use Extended Find and Replace

If your site has more than one page — like pretty much every Website ever — then you know that making a global change can be pretty difficult. For example, say you want to replace every instance of color="red" on your Website with color="black". Whether you had to change this on 5 or 500 pages, locating every instance of that code would get old fast. What's a Webmaster to do?

With the HTML Editor's **Extended Find and Replace** function, global changes like this are easy. Just follow these simple steps:

**Step 1**
Open the **Extended Find and Replace** window using one of these options:

- Go to **Edit > Replace…**
- Click the **Find and Replace** icon in the **Toolbar** and select **Replace…**
- Use the keyboard shortcut **Ctrl+H**

![Extended Find and Replace](image)

**Step 2**
Enter the text or code you want to find in the **Find** field, and then enter its replacement in the **Replace With:** field.

342
Step 3
Specify where the changes need to be made. Choose Current Document if you only want the changes to apply to the document currently open in the HTML Editor, and choose All Open Documents if you want the changes to apply to all the documents currently open in the HTML Editor. If you want to change all the files in a given folder, choose Look in Folder and then click the folder icon to browse your computer for the desired folder.

Use the Look in Folder option with caution, because you won't be warned before changes are made to your code. To be safe, make backups of all your files before you make these changes. Also note that this feature will only work on files that have previously been opened in the HTML Editor.

Step 4
Click Replace All, and let the HTML Editor do the rest!
Previewing Your Work

There are a ton of different options available for previewing your work. After all, it’s good Web design practice to view your Website in several different browsers to ensure cross-browser compatibility, so we made sure to give you plenty of different ways to test your pages, retest them, and test them again just to be sure.

FYI, the most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari, so you should make sure your Website looks good in all of them — yep, all of them. Use these links to download these browsers and install them on your computer:

- Opera: http://www.opera.com/
- Google Chrome: http://www.google.com/chrome

And now, onto the many ways you can preview your work in the HTML Editor!

**Preview Tab**

The Preview tab is a fully functional, built-in browser (Internet Explorer) you can use to preview your Website. To access it, just click the Preview tab at the top of the workspace.
Split-Screen Preview
This is a fully functional, built-in browser (Internet Explorer) that allows you to preview your work in a browser area below the Code Editor. To access it, use one of these options:

- Go to View > Split-Screen Preview
- Click the Edit Display icon in the Code or Visual Editor toolbar and select Split-Screen Preview
- Click the Test in Browser icon in the Code or Visual Editor toolbar and select Split-Screen Preview
- Use the keyboard shortcut F12

Additional Browsers
Since both built-in browsers are Internet Explorer, the HTML Editor offers the option to add up to 10 additional browsers for previewing your work. To add these browsers, go to Tools > Preferences > Browser Testing tab.
Select a Browser
Select the slot under Tools > Additional Browsers where you would like the browser to appear. Additional Browser 1 can be accessed using the keyboard shortcut Ctrl+F5.

Display Name
Enter the desired display name for the browser.

Application Location
Use the Browse icon to browse your computer for the .exe file for the browser you want to add. To remove a browser, click the Remove icon.

To preview your work in any of the additional browsers you have added, use one of these options:

- Go to Tools > Additional Browsers and select the browser you want to use
- Click the Test in Browser icon in the Code or Visual Editor toolbar and select the browser you want to use.
- Use the keyboard shortcut Ctrl+F5 (applies only to Additional Browser 1)
Switching Between Open Files

There are a couple of different options for switching between open files in the HTML Editor.

**Window Menu**
The Window menu allows you to see all the files open in the Editor. Click a file to open it for editing.

![Window Menu Example](image)

**Statusbar Tabs**
The Statusbar, located at the bottom of the program, displays tabs for each of the open documents in the Editor. To switch between open documents, click the tab for the file you want to edit.

![Statusbar Tabs Example](image)
Adjusting Code Highlighting Options

Code syntax highlighting is a great way to tell different tags, tag attributes, and tag values apart. For example, it may be difficult or time-consuming to try to find every instance of an `<img>` tag, but if you set your highlighting options to make all `<img>` tags red, then all you’d have to do is look for the color red.

Follow these steps to create your own code highlighting color scheme:

**Step 1**
Go to **Tools > Document Display Properties**. This opens the **Customization** tab of the **Preferences** window.

![Preferences window]

**Step 2**
Select the language whose highlighting scheme you want to edit from the provided drop-down list. In this tutorial, we’ll be working with **HTML/PHP Documents**, so select it. Next, click the **Modify Highlighting** button. This opens the **Highlighting Options** window.

![Highlighting Options window]
Step 3
Select the element whose color you want to change from the Element list. In this tutorial, we'll change HTML Attributes, so select that option from the list.

Step 4
Apply the color and/or style changes you want to appear in the code syntax. You can preview them in the area at the bottom of the window. For this example, let’s change HTML attributes to be magenta and bold. To change the text color, select it from the Foreground color swatch.
And to make it bold, select the **Bold** checkbox.

After making these changes, you’re all done! Click **OK** to close this window, and then return to the **Code Editor**, where you’ll get to see your custom code syntax highlighting in action.
How to Create a Custom Toolbar

Everyone loves a toolbar. Why spend time digging around in menus when you can accomplish a task with the click of a button? Well, with the HTML Editor’s customizable interface, you can get create a toolbar that contains the icons you use all the time with no superfluous elements. Follow these steps to create your own toolbar:

**Step 1: Open the Customize Window**

Open the Customize window using one of these options:

- Go to **Tools > Toolbars and Menus > Customize**
- Right-click any toolbar and select **Customize**

These options open the Customize window, which lists the toolbars in the program and allows you to create a custom toolbar or customize the main toolbar, which appears across the top of the HTML Editor workspace. In this tutorial, we will create our own custom toolbar.
Step 2: Create a New Toolbar
Click New. This opens the Add Toolbar window. Type a name for your new toolbar. In this tutorial, we’ll call ours My Toolbar.

When you’re done, click OK. The new toolbar will be added to the Toolbars list.

You’ll also see a tiny, blank toolbar just to the left of the Customize window.
The next step will show you how to fill that toolbar up with helpful icons!

**Step 3: Add Icons to Your Toolbar**
To add buttons to your toolbar, switch over to the **Commands** tab.

The **Categories** list contains broad categories of individual commands. You can’t add these to a toolbar, but you can select them to view the commands they contain. For our toolbar, let’s add some basic commands from the **File** menu. Click **File** to display these commands in the **Commands** list.
Let's add **New Blank Page** to our toolbar. To do this, just click and drag **New Blank Page** onto the toolbar. When you see the little plus sign, let go of the mouse. This adds the icon to the toolbar.

Awesome! Let's add a few more icons — how about **Open**, **Close**, and **Save**?

Looks good!
Step 4: Changing the Orientation of the Toolbar
Say you wanted your toolbar to be horizontal instead of vertical. No sweat! — just click one of the sides with your mouse and drag further to the side, or click the bottom and drag the bottom of the toolbar up.

You can have your icons stacked or all in a line — it’s up to you!

You may notice that My Toolbar doesn’t display fully. That’s because your custom toolbars only take up as much space as they need, which helps conserve space.

Step 5: Adjusting Additional Toolbar Options
If you want to work with more toolbar options, switch over to the Options tab.
Let’s take a look at what each of these options does.

**Menus Show Recently Used Commands First**
Select this checkbox if you want the most recently used commands to appear at the beginning of your custom toolbar.

**Show Full Menus After a Short Delay**
Select this checkbox if you want the drop-down menus in your custom toolbar to appear after a short delay.

**Reset My Usage Data**
Clicking this button resets your usage data so your commands appear in the order you originally specified instead of being ranked in order of use.

**Large Icons**
Select this checkbox to increase the size of the toolbar icons. Large toolbar icons look like this:

![Large Icons Example](image)

**Show Tooltips on Toolbars**
Select this checkbox to display tooltips when you mouse over toolbar icons. Tooltips state what the icons do.

**Show Shortcut Keys in Tooltips**
Select this checkbox to display keyboard shortcuts in the toolbar tooltips.

**Menu Animations**
Select the desired menu animation from this drop-down list. Your options are Random, Unfold, Slide, or Fade.

For now, let’s leave these options alone — our toolbar is spiffy enough as is.

**Step 6: Dock Your Custom Toolbar**
You may notice that your custom toolbar is free-floating. However, you can dock your toolbar in several locations in the workspace: at the top, along the left or right side, or on the bottom. To do this, just click and drag the toolbar to the desired location.
location. Once you have docked it, you can change its position by clicking and dragging the solid or dashed lines in the toolbar.

**Step 7: Further Customizing Your Toolbar**
You also have the option to add or remove buttons right from inside the toolbar. To do this, click the downward-facing arrow:

Uncheck a selection to remove it from your menu. You can always re-add it by reselecting it from the list.

**Step 8: Removing Your Toolbar**
If you decide you don’t want your toolbar to display in your workspace, but you don’t want to delete it, you can remove it by clicking the X in the upper right-hand corner.
Customizing Code Completion Tags

Have you ever wanted to know how to add your own custom tags, tag attributes, or attribute values to the Code Completion list in the HTML Editor? It’s actually pretty easy. For example, let’s say you wanted to add a custom attribute for the `<img>` tag. Here’s how you’d go about doing this:

**Step 1**
Go Edit > Edit XHTML Tags. This opens the Edit XHTML Tags window.

![Edit XHTML Tags window](image-url)
Step 2
Select IMG from the Tags list on the left-hand side of the window. When you do, all the available attributes will appear in the Selected Tag Attributes list.

Step 3
At the bottom of the Selected Tag Attributes list, you'll see a green plus sign icon. Click this icon to add a new attribute to the list. By default, it is called Attribute1.
Step 4
Make sure Attribute1 is selected, and then click the Edit Attribute Name icon, which is also located at the bottom of the Selected Tag Attributes list. In this tutorial, we’ll change the name to LONGDESC, but naturally, you can give your attributes any names you want.

And that’s it! Click Close. Now whenever you add an `<img>` tag to your HTML document, the LONGDESC attribute will show up in the Code Completion list. It will also appear in the Tags tab on the left-hand side of the program when HTML Tags is selected.
Frequently Asked Questions

Features, Tools, and Functionality
How do I add special characters?
How do I change my code case?
Is there a JavaScript or HTML debugger included in the program?
What is a horizontal rule?
What is the difference between a layout and a theme?
How do I use Website Projects?
What happened to the DHTML Menu Builder?

Customization
How do I turn on the Visual Editor?
How do I import another language dictionary into the HTML Editor?

Error Messages and Troubleshooting
I get an error that refers to MFC42.dll.
Vista isn’t displaying the files in my Working folder.
I get an error message that says, “No such interface supported.”
I get an error I/O 183.
I see red X’s instead of my images.
Squares or question marks appear instead of spaces.

Miscellaneous
What is the difference between the HTML Editor and the Free HTML Editor?
How do I install HTML Editor themes?
I built my site using a third party’s Webpage builder. Will I be able to use the HTML Editor?

Features, Tools, and Functionality

How do I add special characters?
To add special characters — which include symbols not commonly included on keyboards, such as trademark signs, accents, umlauts, etc., non-breaking spaces, and symbols a Web browser might interpret as HTML (namely < and >) — use an HTML entity. This is a special code that browsers render as the corresponding symbol.

To add an HTML entity in the HTML Editor, click the Characters tab on the left-hand side of the screen, position your cursor in the location on the page where you want the character to appear, and then double-click the character of your choice. You can also drag and drop the character to the page. The correct HTML entity will automatically be inserted for you.
How do I change my code case?
There are no standards in place for how HTML tags are displayed. Some coders prefer all caps (<BODY>), whereas others prefer lowercase (<body>). Using the tools in the HTML Editor, you can easily switch from one standard to another. If you only want to change a few lines of code or content, first select it with your mouse, and then go to the Edit menu. There, you can select between converting to uppercase, lowercase, or proper case, which capitalizes the first letter of words appearing after certain characters. To modify which letters are capitalized in proper case, go to Tools > Preferences > General tab, and use the option under the Proper Case Conversion heading.

If you want to change all your code, use the Code Cleaner. To do this, go to Tools > Code Cleaner > Lay Out and Convert tab. If you want uppercase tags and/or attributes, select the associated checkboxes; if you prefer lowercase, unselect these checkboxes. Next, click OK. The specified changes will be applied to your document.

Is there a JavaScript or HTML debugger included in the program?
There are no JavaScript debugging tools in HTML Editor, but there is an HTML code cleaner that can find unclosed and unsupported tags, as well as other anomalies in your code. To access it, go to Tools > Code Cleaner.

You can also validate your code using the W3C markup validation service. To do this, go to Document > Validate HTML. This opens the W3C markup validation service (http://validator.w3.org/) in your default Web browser.

What is a horizontal rule?
A horizontal rule (<hr>) is a line that goes across a Webpage. To create a customized horizontal rule, go to Insert > Horizontal Rule. This opens the Insert Horizontal Rule window, which allows you to set properties for the line, including alignment, width, color, shading, and thickness. The Preview area allows you to see how the properties look as you adjust them. When you are done, click OK, and the HTML will be automatically inserted into your page.

What is the difference between a layout and a theme?
A layout includes the HTML for a basic page structure and allows you to provide your own content. This gives you more freedom over the appearance of your design. A theme includes three pages (index.html, about-us.html, and contact-us.html) that include the HTML and images for a basic design, allowing you to replace the images and text with your own content. This is a great option for beginners, since the bulk of the work has already been done for you.
How do I use Website Projects?
This question actually has a really lengthy answer! Rather than trying to
tackle it here, we’re going to direct you to a couple of helpful resources.
First, check out the step-by-step tutorial in this manual: Working With Website Projects. After perusing that guide, switch over to the HTML Editor and
go to My Websites > All Website Projects > What is a Website Project. This
opens a comprehensive guide to using Website Projects. Better yet, it actually is a
Website Project, so you’ll get to see firsthand how they work.

What happened to the DHTML Menu Builder?
In the latest version of the HTML Editor, we replaced the DHTML Menu Builder
with the CSS Menu Designer. This new tool is a vast improvement — it renders
properly in all the major browsers, it’s valid according to W3C standards, and it
produces a lot less code than the DHTML Menu Builder, which makes for faster
load times.

If you want to convert your DHTML menu to CSS, just go to Insert > CSS Menu Designer > Open Menu button, and then browse your computer for the .mnu file you created with the DHTML Menu Builder. Click Open, and then resave the menu. This automatically converts the code to CSS for you! If you're interested in even more information about using the CSS Menu Designer, check out this tutorial: How to Use the CSS Menu Designer.

If you're all about the old-school DHTML Menu Builder, you can still use it. Just download the free, stand-alone version from this location: http://www.coffeecup.com/free-dhtml/

Customization

How do I turn on the Visual Editor?
By default, the Visual Editor is turned off. To turn it back on, go to Tools > Preferences > General tab, and uncheck Hide Visual Editor tab.

How do I import another language dictionary into the HTML Editor?
To import other language dictionaries into the HTML Editor for spell checking needs, download the proper .adm file from
http://www.coffeecup.com/help/articles/how-do-i-add-custom-dictionaries-to-the-html-editor/ and save it into C:\Program Files\CoffeeCup Software\.

Next, open the HTML Editor and go to Tools > Spell Checker Options > Dictionaries button > New button. This opens a window that allows you to add
custom dictionaries. Enter the name of the .adm file you downloaded and then click OK.

You can also go to Tools > Spell Checker Options and select Locate Dictionaries from the Dictionaries area. This opens a window that allows you to browse your computer for the .adm file you added.

After using either of these options, the dictionary will appear in the Dictionaries area of the Spelling Options window. Put a checkmark in the box next to whichever dictionary you want to use, and then click OK.

Error Messages and Troubleshooting

I get an error that refers to MFC42.dll.
When you receive this error, it means the version of MFC42.dll on your computer is older than the one installed with the program. For whatever reason, the file is not being updated during the install. Follow these steps to fix the problem:

1. Uninstall the HTML Editor from your computer.
2. Do a search for MFC42.dll, and then rename it. What you decide to call it doesn't matter; what you're doing here is, in essence, removing the file with the name MFC42.dll so that when you reinstall the HTML Editor, it can install the newest version of the file.
3. Install the latest version of the HTML Editor from your download center (http://www.coffeeecup.com/help/myorders/).

If this doesn't work, you may need to install a patch from Microsoft from this link: http://support.microsoft.com/default.aspx?scid=kb;en-us;259403.

Vista isn't displaying the files in my Working folder.
By default, the HTML Editor will save files in the Working folder, which is located at C:\Program Files\CoffeeCup Software\Working. However, Vista may interfere with this process, creating a virtual folder and writing the files there.

To give the application full permission to write to the proper folder, make sure the HTML Editor is closed, and then right-click the HTML Editor desktop icon. Select Run as Administrator. This should properly launch the program for you. If it does, great! You can continue to launch the program in this way, or you can go a step further and configure the shortcut to always run as administrator. Here’s how:

1. Right-click the shortcut icon and select Properties.
2. Click the Compatibility tab.
3. Put a checkmark next to Run This Program as an Administrator.
4. Put a checkmark next to **Run This Program in Compatibility Mode For:** and then select **Windows XP Pro Service Pack 2.**
5. Click **OK.**

Now when you double-click the HTML Editor shortcut, it will run and save files normally. For more information about this issue and file virtualization, check out Scott Hanselman's Computer Zen ([http://www.hanselman.com/blog/VistasShowCompatibilityFilesAndTheScrumptiousWonderThatIsFileVirtualization.aspx](http://www.hanselman.com/blog/VistasShowCompatibilityFilesAndTheScrumptiousWonderThatIsFileVirtualization.aspx)).

**I get an error message that says, “No such interface supported.”**
If you receive the "No Such Interface Supported" error when launching the HTML Editor or trying to access the Visual Editor in the program, you have installed the software under a limited user account. The Visual Editor requires access to the system32 folder, which a limited user account cannot access. To correct this problem, log into Windows as an administrator.

**I get an error I/O 183.**
You may receive this error if you are trying to edit files that the HTML Editor cannot understand because they don't contain valid HTML code. You will not be able to edit these files with the HTML Editor.

If you are trying to open a file created in another Web design program, such as Visual Site Designer, there is a way to work around this. If you have uploaded your work to your server, you can download the HTML files using an FTP client such as Direct FTP ([http://www.coffeecup.com/direct-ftp](http://www.coffeecup.com/direct-ftp)), or with the HTML Editor’s **Open From Web** function. To open a file from the Web, go to **File > Open From Web**, and then enter the URL of the page you wish to download. This method only works one page at a time, so if you want to work with an entire Website instead of a single Webpage, you may be better off downloading the files with an FTP client.

**I see red X’s instead of my images.**
There are a couple of different reasons that could explain why your images are not displaying correctly:

1. In addition to uploading the HTML page, you also need to upload the images it references. For instance, if you have a page called **page.html** that displays two images, **dog.png** and **cat.png**, you will need to upload all three files: **page.html**, **dog.png**, and **cat.png**.

2. The HTML code must reference these images correctly. Your document could be linking to the files on your hard drive or in the wrong location in your **Working** folder, or the links could be formatted incorrectly.
3. Make sure the capitalization in the image file name matches the capitalization in the HTML document. For example, if you link to `dog.png` but the actual file name is `Dog.png`, the image will not display correctly.

Most of these problems can be solved by transitioning to using Website Projects. For more information about how Website Projects work, return to the HTML Editor and go to My Websites > All Website Projects > What is a Website Project. This opens a comprehensive guide to using Website Projects. Better yet, it actually is a Website Project, so you’ll get to see firsthand how they work.

If you aren’t sure whether you uploaded your images, try to visit the URL of the image. For example, if you have an image saved in the root folder of your server called `dog.png`, use your favorite Web browser to visit `http://www.yourwebsitename.com/dog.png`. If you get a 404 error, you either did not upload the image or uploaded it to a different folder on your server.

To resolve this issue, switch to Website Projects, which you to keep track of where your images are located in your Website structure and can insert correct links to the image in your HTML page.

If your image tags are referencing images on your hard drive instead of your server, save your current Website files to a new Website Project. Next, correct the code on your Webpages so it uses relative paths to your image files. To do this, open the page where your images are being referenced incorrectly. For each image, you will find an image tag (`<img>`) and the `src` attribute (`<src=image.png>`), which look something like this:

```html
<img src="file://C:\Program Files\CoffeeCup Software\Working\filename.png">
```

That file path is what’s causing all the trouble — it tells the Web browser to look for a file on your computer. Delete this whole chunk of code and then find the image in your Website Project. Right-click it and select Insert Image Into Current Document. This places an accurate relative link to the file in your page for you. Now just save your work and upload your changes to your server.

**Squares or question marks appear instead of spaces.**
These characters will appear in place of spaces if the text was originally written in another application, such as Microsoft Word, and then copied and pasted into the Visual Editor. The reason for this is that the original application does not use the same hex value to represent spaces that the HTML Editor does. To correct this issue, switch to the Code Editor and manually delete the squares.
Miscellaneous

What is the difference between the HTML Editor and the Free HTML Editor?
The HTML Editor contains a few key features not found in Free HTML Editor, including the CSS Menu Designer, the table designer, and the ability to add and edit XHTML tags, as well as the built-in copies of Site Spider, Image Mapper, and Website Color Schemer.

How do I install HTML Editor themes?
Follow these step-by-step instructions to install HTML Editor themes:

1. Download your HTML Editor Themes from your download center (http://www.coffeecup.com/help/myorders/). The themes will be in .zip format.
2. Make sure the HTML Editor is closed.
3. Unzip the themes using your favorite ZIP utility or by right-clicking the folder and selecting Extract All.
4. Go to the following file path: C:\Program Files\CoffeeCup Software\Themes. There, you’ll see a list of folders that correspond with the categories in the Theme Chooser. If you want to save your theme to one of these categories, drag and drop the extracted folder to the desired category. If you would rather create a new category for the theme, create a new folder, give it the name you want to appear in the Theme Chooser, and then drag and drop the extracted folder into this folder.
5. Open the HTML Editor and click Start With a Theme. This opens the Theme Chooser. Select your theme and click OK.
6. In the window that appears, select the Website Project where you would like to save the theme.
7. Double-click the page you wish to edit, such as index.html, about-us.html, or contact-us.html. It will open in the Code Editor, and you will be able to modify it normally.

I built my site using a third party's Webpage Builder. Will I be able to use the HTML Editor?
Yes! You can use CoffeeCup HTML Editor to open any HTML page created with another company’s Web design software.
Keyboard Shortcuts

HTML Editor offers the option to access many of its most commonly used functions quickly by using keyboard shortcuts. Below is a complete list of all the keyboard shortcuts available in this program:

- **New Blank Page** – Ctrl+N
- **Open** – Ctrl+O
- **Save** – Ctrl+S
- **Save As** – Shift+Ctrl+S
- **Print** – Ctrl+P
- **Undo** – Ctrl+Z
- **Redo** – Ctrl+Q
- **Cut** – Ctrl+X
- **Copy** – Ctrl+C
- **Paste** – Ctrl+V
- **Delete (Table Designer Only)** – Ctrl+Del
- **Select All** – Ctrl+A
- **Convert to Uppercase** – Shift+Ctrl+U
- **Convert to Lowercase** – Shift+Ctrl+L
- **Find** – Ctrl+F
- **Replace** – Ctrl+H
- **Find Next** – F3
- **Icon View** – Shift+Ctrl+F4
- **List View** – Shift+Ctrl+F5
- **Detail View** – Shift+Ctrl+F7
- **Small Icon View** – Shift+Ctrl+F8
- **Thumbnail View** – Shift+Ctrl+F9
- **Split-Screen Preview** – F12
- **Set Bookmark 0–9** – Shift+Ctrl+[0–9]
- **Go to Bookmark 0–9** – Ctrl+[0–9]
- **Go to Line Number** – Ctrl+G
- **Insert Link** – Ctrl+L
- **Insert Target** – Ctrl+T
- **Insert E-mail Link** – Ctrl+E
- **Insert Image** – Ctrl+M
- **Insert Comment** – Shift+Ctrl+C
- **Bold** – Ctrl+B
- **Italic** – Ctrl+I
- **Underline** – Ctrl+U
- **Indent** – Shift+Ctrl+.
- **Unindent** – Shift+Ctrl+,
- **Paragraph** – Ctrl+Enter
- **Test With Default Browser** – Ctrl+F9
- **Test With Favorite Browser** – Ctrl+F5
- **View Help File** – F1
Glossary

A

alt text
A description of an image displayed when the image cannot be shown, such as in a text-only or speech browser, or if a user has a slow connection. You should always use detailed alt text for all contextually important or prominent images on your Webpage.

attribute
Provides additional information about an HTML element. For example, in the HTML for a link (<a href="http://www.coffeecup.com">Click here for great software!</a>), href would be an attribute of the element a.

attribute value
The value of a given attribute. Attribute values are always enclosed in double quotes. For example, in the HTML for a link (<a href="http://www.coffeecup.com">Click here for great software!</a>), http://www.coffeecup.com would be a value of the attribute href.

C

character set
The set of characters available to be used in your code and on your Website. For example, if you want to create a Website using Cyrillic, that would use a different character set than a Website that used the Latin alphabet.

Code Editor
The area of the program used to view and edit the code that makes up a page. It can be used to edit HTML, server files such as PHP and CSS, and text.

code snippet
A predefined or custom chunk of code that has been saved and can be reused. Code snippets are found in the Code Snippets tab.
comment
HTML elements that are not rendered by Web browsers and can be used to leave notes for yourself or for anyone else who may view your code.

CSS
Abbreviation for Cascading Style Sheets. This is a language that is stored in a style sheet and defines how an HTML document is displayed.

D – G

DOCTYPE
Abbreviation for Document Type Declaration. This tells a Web browser the type and version of the language the page is written in.

document dependency
A link to an external file, such as an image or external Website, in a document.

drop-down list
In a form, this is a bar with an arrow that expands to show a list of items when clicked. It is best suited for lists in which your user can only select one option.

element
Everything between the start and end HTML tag. For example, `<a href="http://www.coffeecup.com">Click here for great software!</a>` is an element.

form method
The method used to transfer form data to or from a server.

frame
An individual section of a frames-based layout. Frames allow you to have multiple Webpages open in the same window.

FTP
Abbreviation for File Transfer Protocol. This is the process of transferring Website files to a server.

gutter
A bar to the left of the code in the Code Editor where line numbers, bookmarks, and characters that represent line breaks are displayed.
**H**

**head element**
The section of an HTML document that contains head elements, including the following tags: `<meta>`, `<script>`, `<style>`, and `<title>`.

**hex code**
A six-character code consisting of letters and/or numbers that represents a color.

**hidden text**
Form text that is not rendered by Web browsers but that does appear in the form results. It can be used for sorting and filtering information.

**highlighting scheme**
A system of highlighting that can be applied to different code languages in the HTML Editor. This can be used to help distinguish different elements and attributes.

**horizontal rule**
A horizontal line that can be added to your page design.

**host name**
The address you need to connect to the server. If you do not know this information, contact your hosting provider.

**HTML**
Abbreviation for HyperText Markup Language. This is the language used to create Webpages.

**hyperlink**
A reference on a Webpage that takes you to a new location.

**I – L**

**image map**
An interactive image with areas that can be clicked to link the user to a different location.

**kilobyte**
A kilobyte (abbreviated Kb) equals 1024 bytes and is a reference to file size.

**layout**
A feature in the HTML Editor that contains the HTML for a basic page structure.
link
Short for hyperlink.

link hover color
The color of a link when a user holds their mouse over it.

list box
A text box containing a list of items that your user can select. A list box is best suited for lists in which your user can select several options.

M – N
margin
The white space surrounding an element. When the margin is increased for a selected element, more space will appear between the element and the objects surrounding it.

menu bar
Located at the top of the program, the Menu bar gives you access to all the program options and tools, as well as things like printing projects, customizing the appearance of the workspace, and exiting the program.

meta description
A short description of your Website. It should be no longer than 50 words.

meta keyword
Words that describe your Webpage. They must each be separated by a comma and a space.

meta tag
An HTML tag located in the head section that contains keywords and a description.

MIME Post Method
A type of application that processes form data.

non-breaking space (&nbsp;)
A character entity rendered by Web browsers as a space. This can be used to insert extra spaces, since HTML only allows for one space between each word.
padding
The white space within an element. When padding is increased for a selected element, more space will appear between its outer edges and the objects contained within it.

passive mode
A way of connecting to a server. Enable passive mode if you experience trouble connecting.

pre tags
HTML tag that preserve the formatting of the text they surround, including extra spaces and indenting.

PHP
A scripting language used to create dynamic Webpages.

pixel
A computer screen consists of numerous tiny colored dots. These dots are called pixels.

port
FTP information that defines how the server responds to a certain protocol. For most FTP connections, the port should be set to 21.

Preview tab
The area of the program that contains built-in browser (Internet Explorer) you can use to preview your Website.

proxy
A special kind of FTP connection. If you are unsure whether you use a proxy to connect, chances are you do not, but you can contact your hosting provider to make sure.

remote folder
In an FTP profile, this setting determines where files will be stored on a server. Typical folder names are public_html, web, and www. If you do not know this information, you will need to contact your hosting provider.

Resource browser
The area on the left-hand side of the program that contains the My Websites, My Computer, Tags, Code Snippets, and Character tabs.
script
A program in a language like JavaScript or PHP that creates interactive Webpages.

server
A computer that stores Website files so others may view the site on the Internet.

StatusBar
Located at the bottom of the workspace, the StatusBar allows you to switch between open documents and view basic information about the open file.

style sheet
A CSS document that defines how an HTML document is displayed.

T

tag
The content inside angle brackets in an HTML element. For example, in the HTML for a link (<a href="http://www.coffeecup.com">Click here for great software!</a>), <a href="http://www.coffeecup.com"> is the starting tag, and </a> is the ending tag.

target
A specific location where a link points. This can be a different area on the same page, another frame, or a new browser window.

text area
A multiple-line field where your user can type information. This is best suited for longer answers, such as messages, feedback, etc.

theme
A page creation option that includes three pages (index.html, about-us.html, and contact-us.html) that include the HTML and images for a basic design.

thumbnail
A smaller version of an image. Thumbnails are often used as links to the original version of the image.

title tag
Used to specify a page title, which appears on the browser’s title bar and appears in search results. A good page title succinctly describes the content on the page.

toolbar
Located across the top of the program and the different components within the program, toolbars offer shortcuts to commonly used program functions.
undocumented character
A character that is not supported in a given character set or code language.

URL
A Web address. http://www.coffeccup.com is a URL.

Visual Editor
The area of the program that allows you to work directly with the elements in your page in a WYSIWYG (What You See Is What You Get) environment.

Web browser
A program used to access the Internet. The most popular browsers are Firefox, Internet Explorer, Opera, Google Chrome, and Safari.

Website Project
A comprehensive system that keeps your Webpages and any associated files organized. You can work with Website Projects in the Website Projects tab.

Working folder
If you are using a Website Project, by default, the Working folder is the same as the Website Projects folder. Otherwise, it is the folder where your Website files are saved.

WYSIWYG
Abbreviation for What You See Is What You Get. This is a kind of Web design software where users work with the actual page elements instead of HTML code.

XHTML
Abbreviation for Extensible Hypertext Markup Language. This is a language used to create Webpages.
About CoffeeCup Software

CoffeeCup Software, Inc. was founded in 1996, but the roots of our name go back a bit further. Here’s how it all started:

The story of CoffeeCup began in a real coffeehouse called The Raven & The Sparrow in 1994. It was the only place in Corpus Christi, Texas (and one of only a dozen or so worldwide) that offered free Internet access. People could come by, order a cappuccino, and surf the Web, which was quite new at the time. As more people were exposed to the Internet, more people wanted to be a part of it.

With all these computer junkies as guests, it was clear that the coffeecup.com domain name needed to be purchased and that a Website for the coffeehouse needed to be made. The coffeehouse got a little press from TV and the local newspaper, and other businesses started to call about making Websites for them, too. Back then in the early days of the Internet, good software to easily create good-looking Websites was really hard to find. So, as with the first Website for the coffeehouse, these sites were made with hand-coded HTML using Notepad.

One day, while chatting with a few regulars about creating Websites, the idea of a simple yet powerful HTML editor was born. We wanted to create a nifty piece of software that would make it easy for people like us to build our own Websites. One of the regulars was a programmer, so we got to work, and in August of 1996 the first version of our HTML Editor was released. Since the coffeehouse already had the www.coffeecup.com domain name, our first software program was called the CoffeeCup HTML Editor, and the company was named CoffeeCup Software. The software was posted on the Website, and it was an instant hit! People from all over the world were downloading the program and e-mailing their praises.

At the same time the coffeehouse started to encounter parking problems. You see, the coffeehouse was quite popular, and with only eight parking spots, people often parked along the street. Apparently this was a problem to the city of Corpus Christi. The City Council suggested we buy more land and put in a new parking lot, but that would be an expensive venture. Besides, creating software was a lot more fun, and with that amount of money, whole new applications could be built!

Soon the coffeehouse was closed as we focused on creating and releasing shareware applications like the Image Mapper and Direct FTP. After some time, the efforts began to pay off as more and more people started using (and paying for) the software. The rest is Internet history.
In the last 10 years we have moved to a larger office, started a Web hosting company, a search engine submission service, and created over 25 other software programs so that others could fulfill their dreams of Web design, too.

Now with more than 29,905,323 users worldwide, and software sold in over 87 countries, CoffeeCup Software has grown beyond our wildest dreams. We have won lots of awards, including being No. 400 in the Interactive 500, a ranking of the best Internet and E-Commerce companies. We still remember the good old days though, when we were just a small coffeehouse. We strive to keep that same level of personal service with a smile that went with every cup of steaming hot cappuccino.
Contact Us

We give you more then just software.

We have a mission when it comes to support: Be extraordinary!

When you buy our software, what you get goes well beyond what you expect from a software company. We do not offer tech support — we offer coaches and counselors to help you with the software and Web design. We are here for you so you can be a successful Webmaster, not just learn a piece of software.

Registered customers always get:

- The software you paid for, of course.
- Free live chat support (ask a question, get an answer live).
- Free upgrades for life and access to download software at any time.
- Access to our User Forum where you can talk about Web design or business tips.
- Availability to visit our offices to sit down for some pointers.
- Exclusive discounts and sneak peeks at new software or services.

Trial Support Services:

We are always happy to help you with your questions about our software. If you are using a trial version of our software you can use the Online Help and Knowledgebase links above or e-mail our support staff any time. Feel free to ask us your questions, and we will reply as soon as possible.

Get priority support and access to our Customer Care Center when you order our software. Our mission is to provide the best possible service to our customers. Join the ranks of Webmasters worldwide and order our software today. You'll be happy you did. :)

Our Address:

CoffeeCup Software
165 Courtland Street
Suite A, Box 312
Atlanta, GA 30303
USA
Phone: (678) 495-3480
http://www.coffeecup.com
Thank You

To all our users — you know who you are...

Without the support and feedback of those who download and buy our software, we wouldn't be here. We are very lucky to have had so many people over the years think our software is great, and we are proud that you still do.

Thank You Everyone!
End User License Agreement

BY CLICKING THE ACCEPT BUTTON OR INSTALLING THE SOFTWARE, YOU (EITHER AN INDIVIDUAL OR A SINGLE ENTITY) CONSENT TO BE BOUND BY AND BECOME A PARTY TO THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS AGREEMENT, CLICK THE BUTTON THAT INDICATES THAT YOU DO NOT ACCEPT THE TERMS OF THIS AGREEMENT AND DO NOT INSTALL THE SOFTWARE. (IF APPLICABLE, YOU MAY RETURN THE PRODUCT TO THE PLACE OF PURCHASE FOR A FULL REFUND.)

1. License Grant. Subject to the payment of the applicable license fees, and subject to the terms and conditions of this Agreement, CoffeeCup Software hereby grants to you a non-exclusive, non-transferable right to use one copy of the specified version of the Software and the accompanying documentation (the "Documentation") on one computer only.

2. Term. This Agreement is effective for an unlimited duration unless and until earlier terminated as set forth herein. This Agreement will terminate automatically if you fail to comply with any of the limitations or other requirements described herein. Upon any termination or expiration of this Agreement, you must destroy all copies of the Software and the Documentation. You may terminate this Agreement at any point by destroying all copies of the Software and the Documentation.

3. Ownership Rights. The Software is protected by United States copyright laws and international treaty provisions. CoffeeCup Software and its suppliers own and retain all right, title and interest in and to the Software, including all copyrights, patents, trade secret rights, trademarks and other intellectual property rights therein. Your possession, installation, or use of the Software does not transfer to you any title to the intellectual property in the Software, and you will not acquire any rights to the Software except as expressly set forth in this Agreement.

4. Restrictions. You may not rent, lease, loan, sublicense or resell the Software. You may not permit third parties to benefit from the use or functionality of the Software via a timesharing, service bureau or other arrangement. You may not transfer any of the rights granted to you under this Agreement. You may not reverse engineer, decompile, or disassemble the Software, except to the extent the foregoing restriction is expressly prohibited by applicable law. You may not modify, or create derivative works based upon, the Software in whole or in part. You may not copy the Software or Documentation. except that you may either (a) make one copy of the Software solely for backup or archival purposes, or (b) transfer the Software to a single hard disk provided that you keep the original solely for backup or archival purposes. You may not remove any proprietary
notices or labels on the Software. All copies must contain the same proprietary notices that appear on and in the Software. All rights not expressly set forth hereunder are reserved by CoffeeCup Software.

5. Warranty and Disclaimer.

a. Limited Warranty. CoffeeCup Software warrants that for sixty (60) days from the date of original purchase the media (e.g., CD-Rom) on which the Software is contained will be free from defects in materials and workmanship.

b. Remedies. CoffeeCup Software's and its suppliers' entire liability and your exclusive remedy for any breach of the foregoing warranty shall be, at CoffeeCup Software's option, either (i) return of the purchase price paid for the license, if any, or (ii) replacement of the defective media in which the Software is contained. You must return the defective media to CoffeeCup Software at your expense with a copy of your receipt. This limited warranty is void if the defect has resulted from accident, abuse, or misapplication. Any replacement media will be warranted for the remainder of the original warranty period. Outside the United States, this remedy is not available to the extent CoffeeCup Software is subject to restrictions under United States export control laws and regulations.

c. Warranty Disclaimer. Except for the limited warranty set forth herein, THE SOFTWARE IS PROVIDED "AS IS." TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, CoffeeCup Software DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT WITH RESPECT TO THE SOFTWARE AND THE ACCOMPANYING DOCUMENTATION. YOU ASSUME RESPONSIBILITY FOR SELECTING THE SOFTWARE TO ACHIEVE YOUR INTENDED RESULTS, AND FOR THE INSTALLATION OF, USE OF, AND RESULTS OBTAINED FROM THE SOFTWARE. WITHOUT LIMITING THE FOREGOING PROVISIONS, CoffeeCup Software MAKES NO WARRANTY THAT THE SOFTWARE WILL BE ERROR-FREE OR FREE FROM INTERRUPTIONS OR OTHER FAILURES OR THAT THE SOFTWARE WILL MEET YOUR REQUIREMENTS. SOME STATES AND JURISDICTIONS DO NOT ALLOW LIMITATIONS ON IMPLIED WARRANTIES, SO THE ABOVE LIMITATION MAY NOT APPLY TO YOU. The foregoing provisions shall be enforceable to the maximum extent permitted by applicable law.

6. Limitation of Liability. UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER IN TORT, CONTRACT, OR OTHERWISE, SHALL CoffeeCup Software OR ITS SUPPLIERS BE LIABLE TO YOU OR TO ANY OTHER PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION,
7. Miscellaneous. This Agreement is governed by the laws of the United States and the State of Texas, without reference to conflict of laws principles, and the parties agree that the sole location and venue for any litigation which may arise hereunder shall be Nueces County, Texas. The application of the United Nations Convention of Contracts for the International Sale of Goods is expressly excluded. This Agreement sets forth all rights for the user of the Software and is the entire agreement between the parties. This Agreement supersedes any other communications with respect to the Software and Documentation. This Agreement may not be modified except by a written addendum issued by a duly authorized representative of CoffeeCup Software. No provision hereof shall be deemed waived unless such waiver shall be in writing and signed by CoffeeCup Software or a duly authorized representative of CoffeeCup Software. If any provision of this Agreement is held invalid, the remainder of this Agreement shall continue in full force and effect. The parties confirm that it is their wish that this Agreement has been written in the English language only.

8. The Software and Documentation are provided with Restricted Rights. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in subparagraph (c)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) of the Commercial Computer Software - Restricted Rights 48 CFR 52.227-19, as applicable.

9. You agree that you will not export or re-export the Software or Documentation to any country, person, entity or end user subject to U.S.A. export restrictions. Restricted countries currently include, but are not necessarily limited to Cuba, Iran, Iraq, Libya, North Korea, Sudan, and Syria. You warrant and represent that neither the U.S.A. Bureau of Export Administration nor any other federal agency has suspended, revoked or denied your export privileges.

Copyright © 1996-2007 CoffeeCup Software, Inc. All Rights Reserved.

CoffeeCup Software® is a registered trademark of CoffeeCup Software, Inc.
Notice of Copyright

Acceptance of Terms

Welcome to the Website (the "Website") of CoffeeCup Software, Inc. ("CoffeeCup"). On this Website, CoffeeCup makes available to you a wide range of information, software, products, downloads, documents, communications, files, text, graphics, publications, content, tools, forums, resources, and services.

PLEASE READ THE TERMS OF USE CAREFULLY BEFORE USING THIS WEBSITE. By accessing and using this Website in any way, including, without limitation, browsing the Website, using any information, using any content, using any services, downloading any materials, and/or placing an order for products or services, you agree to and are bound by the terms of use described in this document ("Terms of Use"). IF YOU DO NOT AGREE TO ALL OF THE TERMS AND CONDITIONS CONTAINED IN THE TERMS OF USE, DO NOT USE THIS WEBSITE IN ANY MANNER. The Terms of Use are entered into by and between CoffeeCup and you. If you are using the Website on behalf of your employer, you represent that you are authorized to accept these Terms of Use on your employer's behalf.

CoffeeCup reserves the right, at CoffeeCup's sole discretion, to change, modify, update, add, or remove portions of the Terms of Use at any time without notice to you. Please check these Terms of Use for changes. Your continued use of this Website following the posting of changes to the Terms of Use will mean you accept those changes.

Use of Materials Limitations

All materials contained in the Website are the copyrighted property of CoffeeCup, its subsidiaries, affiliated companies and/or third-party licensor's. All trademarks, service marks, and trade names are proprietary to CoffeeCup, or its subsidiaries or affiliated companies and/or third-part licensor's.

Unless otherwise specified, the materials and services on this Website are for your personal and non-commercial use, and you may not modify, copy, distribute, transmit, display, perform, reproduce, publish, license, create derivative works from, transfer, or sell any information, software, products or services obtained from the Website without the written permission from CoffeeCup.

Privacy Policy
CoffeeCup respects your desire for privacy. Your information may be stored and processed in the United States or any other country in which CoffeeCup or CoffeeCup representatives and affiliates maintain facilities. This information is highly protected and is stored in a secure and controlled environment. By using this site, you consent to any such transfer of information outside of your country and you consent to the terms of our Privacy Policy. CoffeeCup’s Privacy Policy can be found at http://www.coffeecup.com/legal/privacy.html.

Use of Software on the Website

Any software that is made available to download from the Website ("Software") is the copyrighted work of CoffeeCup and/or its suppliers. Use of the Software is governed by the terms of the End User License Agreement, if any, which accompanies or is included with the Software ("License Agreement"), or as expressly stated on the Website pages accompanying the software. An end user will be unable to download or install any Software that is accompanied by or includes a License Agreement, unless he or she first agrees to the License Agreement terms.

The Software is made available for download solely for use by end users according to the License Agreement. Any use, reproduction or redistribution of the Software not in accordance with the License Agreement is expressly prohibited by law, and may result in severe civil and criminal penalties. Violators will be prosecuted to the maximum extent possible. Absent a License Agreement that accompanies the Software, use of the Software will be governed by the Terms of Use.

WITHOUT LIMITING THE FOREGOING, COPYING OR REPRODUCTION OF THE SOFTWARE TO ANY OTHER SERVER OR LOCATION FOR FURTHER REPRODUCTION OR REDISTRIBUTION IS EXPRESSLY PROHIBITED, UNLESS SUCH REPRODUCTION OR REDISTRIBUTION IS EXPRESSLY PERMITTED BY THE LICENSE AGREEMENT ACCOMPANYING SUCH SOFTWARE.

THE SOFTWARE IS WARRANTED, IF AT ALL, ONLY ACCORDING TO THE TERMS OF THE LICENSE AGREEMENT. EXCEPT AS WARRANTED IN THE LICENSE AGREEMENT, COFFEECUP SOFTWARE, INC. HEREBY DISCLAIMS ALL WARRANTIES AND CONDITIONS WITH REGARD TO THE SOFTWARE, INCLUDING ALL WARRANTIES AND CONDITIONS OF MERCHANTABILITY, WHETHER EXPRESS, IMPLIED OR STATUTORY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT.

FOR YOUR CONVENIENCE, COFFEECUP MAY MAKE AVAILABLE AS PART OF THE SERVICES OR IN ITS MATERIALS OR SOFTWARE PRODUCTS, TOOLS AND UTILITIES FOR USE AND/OR DOWNLOAD. COFFEECUP DOES NOT MAKE ANY ASSURANCES WITH REGARD TO THE ACCURACY OF THE
RESULTS OR OUTPUT THAT DERIVES FROM SUCH USE OF ANY SUCH TOOLS AND UTILITIES. YOU SHALL RESPECT THE INTELLECTUAL PROPERTY RIGHTS OF OTHERS WHEN USING THE TOOLS AND UTILITIES MADE AVAILABLE ON THE SERVICES OR IN COFFEECUP SOFTWARE PRODUCTS.

Use of Documents and Publications on the Website

Except as expressly prohibited on this Website, you are permitted to view, copy, print and distribute publications and documents within this Website (such as FAQs, white papers, datasheets, press releases and so on), subject to your agreement that: a) your use of the information is for informational, personal, and non-commercial purposes only, b) you will not modify the documents, publications or graphics, c) you will not copy or distribute graphics separate from their accompanying text and you will not quote materials out of their context, d) you will display the below copyright notice and other proprietary notices on every copy you make, and e) you agree that CoffeeCup may revoke this permission at any time and you shall immediately stop your activities related to this permission upon notice from CoffeeCup. Use for any other purpose is expressly prohibited by law, and may result in severe civil and criminal penalties. Violators will be prosecuted to the maximum extent possible.

The permission above to use documents and publications does not include permission to copy the design elements, look and feel, or layout of this Website. Those elements of the Website are protected by law, such as trade dress, trademark, unfair competition, and other laws and may not be copied or imitated in whole or in part. No logo, graphic, sound or image from the Website may be copied or retransmitted unless expressly permitted by CoffeeCup.

EXCEPT AS EXPRESSLY PROVIDED OTHERWISE, COFFEECUP AND/OR ITS RESPECTIVE SUPPLIERS MAKE NO REPRESENTATIONS ABOUT THE SUITABILITY OF THE INFORMATION CONTAINED IN THE DOCUMENTS AND PUBLICATIONS AND RELATED GRAPHICS PUBLISHED ON THE WEBSITE FOR ANY PURPOSE. EXCEPT AS EXPRESSLY PROVIDED OTHERWISE, ALL SUCH DOCUMENTS AND RELATED GRAPHICS ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. EXCEPT AS EXPRESSLY PROVIDED OTHERWISE, COFFEECUP AND/OR ITS RESPECTIVE SUPPLIERS HEREBY DISCLAIM ALL WARRANTIES AND CONDITIONS WITH REGARD TO THIS INFORMATION, INCLUDING ALL WARRANTIES AND CONDITIONS OF MERCHANTABILITY, WHETHER EXPRESS, IMPLIED OR STATUTORY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT SHALL COFFEECUP AND/OR ITS RESPECTIVE SUPPLIERS BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF INFORMATION AVAILABLE FROM THE WEBSITE.

THE DOCUMENTS AND RELATED GRAPHICS PUBLISHED ON THE SERVICES COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN. COFFEECUP AND/OR ITS RESPECTIVE SUPPLIERS MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S) AND/OR THE PROGRAM(S) DESCRIBED HEREIN AT ANY TIME WITHOUT NOTICE.

**Disclaimers and Other Notices on the User of the Website**

EXCEPT AS EXPRESSLY PROVIDED OTHERWISE, ALL INFORMATION, SOFTWARE, DOCUMENTATION, MATERIALS, SERVICES AND PUBLICATION ARE PROVIDED "AS-IS" WITHOUT WARRANTY OF ANY KIND AND COFFEECUP HEREBY DISCLAIMS ALL WARRANTIES EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. IN ADDITION, EXCEPT AS EXPRESSLY PROVIDED OTHERWISE, CoffeeCup DISCLAIMS ANY WARRANTIES OF NON-INFRINGEMENT, TITLE, OR QUIET ENJOYMENT. IN NO EVENT SHALL COFFEECUP AND/OR ITS RESPECTIVE SUPPLIERS BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OF THIS WEBSITE, USE OR PERFORMANCE OF SOFTWARE, DOCUMENTS, MATERIALS, PUBLICATIONS, PROVISION OF OR FAILURE TO PROVIDE SERVICES, OR INFORMATION AVAILABLE FROM THE WEBSITE.

EXCEPT AS EXPRESSLY PROVIDED OTHERWISE, YOU ASSUME ALL RISKS CONCERNING THE SUITABILITY AND ACCURACY OF THE INFORMATION WITHIN THE WEBSITE, MATERIALS, PUBLICATIONS AND DOCUMENTS. THE WEBSITE, MATERIALS, PUBLICATIONS AND DOCUMENTS MAY CONTAIN TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS. COFFEECUP ASSUMES NO RESPONSIBILITY FOR AND DISCLAIMS ALL LIABILITY FOR ANY SUCH INACCURACIES, ERRORS OR OMISSIONS IN THE WEBSITE, MATERIALS, PUBLICATIONS AND DOCUMENTS AND IN ANY OTHER REFERENCE.

COFFEECUP MAY MAKE CHANGES TO THE WEBSITE, INFORMATION, SOFTWARE, WEBSITE, DOCUMENTS, PUBLICATIONS, PRICES, TECHNICAL SPECIFICATIONS, PRODUCT OFFERINGS AND ANY OTHER INFORMATION AND MATERIALS ON THE WEBSITE AT ANY TIME AND WITHOUT NOTICE.
THE WEBSITE, DOCUMENTS AND PUBLICATIONS ARE DISTRIBUTED INTERNATIONALLY AND MAY CONTAIN REFERENCES OR CROSS-REFERENCES TO COFFEECUP PRODUCTS, PROGRAMS, AND SERVICES THAT HAVE NOT BEEN ANNOUNCED OR AVAILABLE IN YOUR COUNTRY. SUCH REFERENCES DO NOT IMPLY THAT COFFEECUP INTENDS TO ANNOUNCE SUCH PRODUCTS, PROGRAMS, OR SERVICES IN YOUR COUNTRY. THE WEBSITE CONTAINS LINKS TO THIRD-PARTY SITES WHICH ARE NOT UNDER THE CONTROL OF COFFEECUP AND COFFEECUP IS NOT RESPONSIBLE FOR THE CONTENTS ON ANY LINKED SITE OR ANY LINK CONTAINED IN A LINKED SITE, OR ANY CHANGES OR UPDATES TO SUCH SITES. COFFEECUP IS NOT RESPONSIBLE FOR WEBCASTING OR ANY OTHER FORM OF TRANSMISSION RECEIVED FROM ANY LINKED SITE. COFFEECUP IS PROVIDING THESE LINKS TO YOU ONLY AS A CONVENIENCE, AND THE INCLUSION OF ANY LINK DOES NOT IMPLY THAT COFFEECUP ENDORSES OR ACCEPTS ANY RESPONSIBILITY FOR THE CONTENT ON SUCH THIRD-PARTY SITES.

Accounts and Security

If any of the services on the Website requires you to open an account, you must complete the registration process by providing us with true, current, complete and accurate information as prompted by the applicable registration form, and you will maintain and promptly update such information to keep it true, current, complete and accurate. You also will choose a password and a user name. You are entirely responsible for maintaining the confidentiality of your password and account. Furthermore, you are entirely responsible for any and all activities that occur under your account. You agree to notify CoffeeCup immediately of any unauthorized use of your account or any other breach of security. CoffeeCup will not be liable for any loss that you may incur as a result of someone else using your password or account, either with or without your knowledge. However, you could be held liable for losses incurred by CoffeeCup or another party due to someone else using your account or password. You may not use anyone else's account at any time, without the permission of the account holder. You acknowledge and agree that certain services may provide password-restricted access to customer information such as names and certain terms of your contracts. By using this Website and registering for such services, you consent to CoffeeCup’s display of such information via the services and accept all risks of unauthorized access to such information. If you provide any information that is false, inaccurate, out of date, or incomplete, or CoffeeCup has reasonable grounds to suspect that such information is false, inaccurate, not current, or incomplete, CoffeeCup may suspend or terminate your account and refuse any and all current or future use of the services or any portion thereof. You are responsible for all costs and charges, including without limitation, phone charges and telecommunications equipment, that you incur in order to use the services.
No Unlawful or Prohibited Use

As a condition of your use of the Website, you will not use the Website for any purpose that is unlawful or prohibited by these terms, conditions, and notices. You may not use the Services in any manner that could damage, disable, overburden, or impair any CoffeeCup server, or the network(s) connected to any CoffeeCup server, or interfere with any other party’s use and enjoyment of the Website. You may not attempt to gain unauthorized access to services, materials, other accounts, computer systems or networks connected to any CoffeeCup server or to the Website, through hacking, password mining or any other means. You may not obtain or attempt to obtain any materials or information through any means not intentionally made available through the Website.

Use of Services on the Website

The Website may contain e-mail services, bulletin board services, chat areas, news groups, forums, communities, personal web pages, calendars, photo albums and/or other message or communication facilities designed to enable you to communicate with others (each a "Communication Service" and collectively "Communication Services"). You agree to use the Communication Services only to post, send and receive messages and material that are proper and, when applicable, related to the particular Communication Service. By way of example, and not as a limitation, you agree that when using the Communication Services or the Website, you will not:

- Use the Communication Services or the Website in connection with surveys, contests, pyramid schemes, chain letters, junk e-mail, spamming or any duplicative or unsolicited messages (commercial or otherwise).
- Defame, abuse, harass, stalk, threaten or otherwise violate the legal rights (such as rights of privacy and publicity) of others.
- Publish, post, upload, distribute or disseminate any inappropriate, profane, defamatory, obscene, obscene as to minors, child pornography, racist, lewd, lascivious, filthy, excessively violent, harassing, indecent, unlawful, or otherwise objectionable topic, name, material or information.
- Upload, or otherwise make available, files that contain images, photographs, software or other material protected by intellectual property laws, including, by way of example, and not as limitation, copyright or trademark laws (or by rights of privacy or publicity) unless you own or control the rights thereto or have received all necessary consent to do the same.
- Use any material or information, including images or photographs, which are made available through the Website in any manner that infringes any copyright, trademark, patent, trade secret, or other proprietary right of any party.
- Upload files that contain viruses, Trojan horses, worms, time bombs, cancelbots, corrupted files, or any other similar software or programs that may damage the operation of another's computer or property of another.
• Advertise or offer to sell or buy any goods or services for any business purpose, unless such Communication Services specifically allows such messages.
• Download any file posted by another user of a Communication Service that you know, or reasonably should know, cannot be legally reproduced, displayed, performed, and/or distributed in such manner.
• Falsify or delete any copyright management information, such as author attributions, legal or other proper notices or proprietary designations or labels of the origin or source of software or other material contained in a file that is uploaded.
• Restrict or inhibit any other user from using and enjoying the Communication Services.
• Violate any code of conduct or other guidelines which may be applicable for any particular Communication Service.
• Harvest or otherwise collect information about others, including e-mail addresses.
• Violate any applicable laws or regulations.
• Create a false identity for the purpose of misleading others.
• Use, download or otherwise copy, or provide (whether or not for a fee) to a person or entity any directory of users of the Communication Services or other user or usage information or any portion thereof.
• Use any CoffeeCup domain name as a pseudonymous return e-mail address for any communications that you transmit from another location or through another service.
• Transmit unsolicited or bulk communications to any CoffeeCup account holder or to any CoffeeCup.com or affiliated e-mail address (regardless of whether you use the Website to transmit any such communication).
• Disrupt the normal flow of dialogue, cause a screen to "scroll" faster than other users of the Website are able to type, or otherwise act in a manner that negatively affects other users' ability to engage in real time exchanges.

CoffeeCup has no obligation to monitor the Communication Services. However, CoffeeCup reserves the right to review materials posted to the Communication Services and to remove and/or edit any materials in its sole discretion. CoffeeCup reserves the right to terminate your access to any or all of the Communication Services at any time, without notice, for any reason whatsoever.

CoffeeCup reserves the right at all times to disclose any information as CoffeeCup deems necessary to satisfy any applicable law, regulation, legal process or governmental request, or to edit, refuse to post or to remove any information or materials, in whole or in part, in CoffeeCup's sole discretion.

Always use caution when giving out any personally identifiable information about yourself or your children in any Communication Services. CoffeeCup does not control or endorse the content, messages or information found in any Communication Services and, therefore, CoffeeCup specifically disclaims any liability with regard to the Communication Services and any actions resulting from
your participation in any Communication Services. Managers and hosts are not authorized CoffeeCup spokespersons, and their views do not necessarily reflect those of CoffeeCup.

Materials uploaded to the Communication Services may be subject to posted limitations on usage, reproduction and/or dissemination; you are responsible for adhering to such limitations if you download the materials.

**Notices and Procedures for Making Claims of Copyright Infringement**

CoffeeCup will investigate notices of copyright infringement and take appropriate actions under the Digital Millennium Copyright Act, Title 17, United States Code, Section 512(c)(2) ("DMCA"). Pursuant to the DMCA, written notification of claimed copyright infringement must be submitted to the following Designated Agent for this Website:

Service provider(s): CoffeeCup Software, Inc.
Name of agent designated to receive notification of claimed infringement: J. Cornelius
Full address of designated agent to which notification should be sent:

165 Courtland Street
Suite A, Box 312
Atlanta, GA 30303

Telephone number of designated agent: (678) 495-3480
Facsimile number of designated agent: (678) 495-3481
E-mail address of designated agent: admin@coffeecup.com

To be effective, the Notification must include the following:

1. A physical or electronic signature of a person authorized to act on behalf of the owner of an exclusive right that is allegedly infringed.
2. Identification of the copyrighted work claimed to have been infringed, or if multiple copyrighted works at a single online site are covered by a single notification, a representative list of such works at that site.
3. Identification of the material that is claimed to be infringing or to be the subject of infringing activity and that is to be removed or access to which is to be disabled, and information reasonably sufficient to permit the service provider to locate the material.
   Information reasonably sufficient to permit the service provider to contact the complaining party, such as an address, telephone number, and if available, an electronic mail address at which the complaining party may be contacted.
4. A statement that the complaining party has a good faith belief that use of the material in the manner complained of is not authorized by the copyright owner, its agent, or the law.

5. A statement that the information in the notification is accurate, and under penalty of perjury, that the complaining party is authorized to act on behalf of the owner of an exclusive right that is allegedly infringed.

**Spam E-mail and Postings**

You agree that CoffeeCup would be irreparably harmed by the use, by you or others, of the Website or facilities in connection with the transmission of spam newsgroup postings or unsolicited e-mail in violation of these Terms of Use, and that CoffeeCup is entitled to obtain injunctive relief against any such transmission (in addition to all other remedies available at law or in equity). CoffeeCup reserves the right to block, filter or delete unsolicited e-mail.

**Indemnity**

You agree to indemnify, defend and hold CoffeeCup, and its subsidiaries, affiliates, officers, agents, co-branders, partners, and employees, harmless from any claim or demand, including reasonable attorneys' fees, made by any third party due to or arising out of your Submissions, your use of the Website, including any use by your employees, your connection to the Website, your violation of the Terms of Use, or your violation of any rights of another.

**Advertisements and Promotions**

CoffeeCup may run advertisements and promotions from third parties on the Website. The manner, mode and extent of advertising by CoffeeCup is subject to change. Your correspondence or business dealings with, or participation in promotions of, advertisers other than CoffeeCup found on or through the Website, including payment and delivery of related goods or services, and any other terms, conditions, warranties or representations associated with such dealings, are solely between you and such advertiser. CoffeeCup is not responsible or liable for any loss or damage of any kind incurred as the result of any such dealings or as the result of the presence of such non-CoffeeCup advertisers on the Website.

**Copyright and Trademark Information**

1. COPYRIGHT NOTICE: Copyright © 1996-2004 CoffeeCup Software, Inc., 711 N. Carancahua Street, Corpus Christi, TX 78475 USA. All Rights Reserved. Use, duplication, or disclosure by the United States Government is subject to the restrictions set forth in DFARS 252.227-7013(c)(1)(ii) and FAR 52.227-19.
The Terms of Use constitute the entire agreement between you and CoffeeCup and govern your use of the Website, superseding any prior agreements between you and CoffeeCup on the subject matter (including, but not limited to, any prior versions of the Terms of Use). Notwithstanding the prior provision, to the extent, and only to the extent, that any terms set forth in this Terms of Use expressly contradicts any terms of a prior written agreement between you and CoffeeCup in effect as of the date of your use of the Website and specifically regarding your use of the Website ("Executed Agreement"), such contradictory terms set forth in the Executed Agreement shall govern. You also may be subject to additional terms and conditions that may apply when you use other CoffeeCup services, third-party content or third-party software. You must not assign or otherwise transfer the Terms of Use nor any right granted hereunder.

Texas law and controlling U.S. federal law govern any action related to the Terms of Use, without regard to the principles of choice of law. The parties specifically disclaim the U.N. Convention on Contracts for the International Sale of Goods.

CoffeeCup controls and operates this Website from its headquarters in various locations in the United States of America and makes no representation that this Website is appropriate or available for use in other locations. If you use this Website from other locations, you are responsible for compliance with applicable local laws including but not limited to the export and import regulations of other countries.

You acknowledge and agree that material on this Website is subject to the U.S. Export Administration Laws and Regulations. Diversion of such material contrary to U.S. law is prohibited. You agree that none of the material on this Website, nor any direct product therefrom, is being or will be acquired for, shipped, transferred, or re-exported, directly or indirectly, to proscribed or embargoed countries or their nationals, nor be used for nuclear activities, chemical biological weapons, or missile projects unless authorized by the U.S. Government. Proscribed countries are set forth in the U.S. Export Administration Regulations. Countries subject to U.S. embargo are: Cuba, Iran, Libya, North Korea, Syria, and Sudan. This list is subject to change without further notice from CoffeeCup, and you must comply with the list as it exists in fact. You certify that you are not on the U.S. Department of Commerce’s Denied Persons List or affiliated lists or on the U.S. Department of Treasury’s Specially Designated Nationals List. You agree to comply strictly with all U.S. export laws and assume sole responsibility for obtaining licenses to export or re-export as may be required.

2. The failure of CoffeeCup to exercise or enforce any right or provision of the Terms of Use does not constitute a waiver of such right or provision. If a court of competent jurisdiction finds any provision of the Terms of Use to be invalid, the parties nevertheless agree that the court should endeavor to give effect to the
parties' intentions as reflected in the provision, and the other provisions of the Terms of Use remain in full force and effect. Regardless of any statute or law to the contrary, any claim or cause of action arising out of or related to use of the Website or the Terms of Use must be filed within one (1) year after such claim or cause of action arose or be forever barred. The section titles in the Terms of Use are for convenience only and have no legal or contractual effect.
Software Privacy Policy

Here at CoffeeCup Software, we understand the importance of your privacy. CoffeeCup Software, Inc. will never willfully disclose individually identifiable information about its customers to any third party without first receiving that customer's permission. You can sleep well knowing your information will not leave our offices.

1. Will CoffeeCup ever send spam to my e-mail address?
We do not send spam. By entering your e-mail address, you agree to receive e-mail from us about product updates and special deals. We usually send only one message each month. If you do not wish to receive these messages, you can remove your e-mail address from our list at any time by visiting this page: http://www.coffeecup.com/help/myprofile/mysubscriptions/.

2. Why do we collect user information when you download?
When you download a piece of software from us, we log your name, e-mail address, and IP address. We do this to help detect illegal downloads and software piracy. Our software is quite popular and believe it or not, there are some crooked people out there who try to steal it.

3. How is the information we collect used?
We keep a database of our users' names and e-mail addresses for product update and upgrade notifications. When we release a new version of any of our software titles, we send a message to all our registered users to let them know. Other than that, we like to tell our shareware users about new and exciting products.

4. Will this personal information ever be used for any other purpose?
The only time we would ever use your personal information for any other reason is to aid the proper authorities in finding fraudulent credit card charges or in finding those responsible for illegal distribution or piracy of our software.

5. Will CoffeeCup ever sell this information to a third party for advertising?

If you have any additional questions about our usage of your personal information, please contact us at:

CoffeeCup Software
165 Courtland Street
Suite A, Box 312
Atlanta, GA 30303 USA
ATTN: Abuse Department
abuse@coffeecup.com